Re: Can't load any mxj with Max 5.1.7 and leopard snow


TSt

Nick, thank you for your reply

but, ist the syntax wrong or what? this is the max.java.config.txt which works well with MaxMsp 4.6.3 in xp home sp3,
but not in Max ver.6 – funny!

for information: I’ve tested Java in MaxMsp 4.6.3 under my 10.5.8-osx-system,
sure: at first I’ve recompile all written java-mxj’s etc and it seems ok
with software-update I’ve update the jdk to ver.1.6.0 and the terminal shows the java-version correctly

but if I try to load e.g. a patcher which includes several mxj I’ve got in the Max-window this:

(excerpt)

MXJ System CLASSPATH:
/Applications/MaxMSP 4.6/Cycling ’74/java/lib/circuit.jar
/Applications/MaxMSP 4.6/Cycling ’74/java/lib/core.jar
/Applications/MaxMSP 4.6/Cycling ’74/java/lib/dfilter.jar
/Applications/MaxMSP 4.6/Cycling ’74/java/lib/ej.jar
/Applications/MaxMSP 4.6/Cycling ’74/java/lib/fourier.jar
/Applications/MaxMSP 4.6/Cycling ’74/java/lib/ftmjava.jar
/Applications/MaxMSP 4.6/Cycling ’74/java/lib/javazoom.jar
/Applications/MaxMSP 4.6/Cycling ’74/java/lib/jitter.jar
/Applications/MaxMSP 4.6/Cycling ’74/java/lib/jode-1.1.2-pre-embedded.jar
/Applications/MaxMSP 4.6/Cycling ’74/java/lib/loadedstring.jar
/Applications/MaxMSP 4.6/Cycling ’74/java/lib/max.jar
/Applications/MaxMSP 4.6/Cycling ’74/java/lib/physics.jar
/Applications/MaxMSP 4.6/Cycling ’74/java/lib/circuit.jar
/Applications/MaxMSP 4.6/Cycling ’74/java/lib/core.jar
/Applications/MaxMSP 4.6/Cycling ’74/java/lib/dfilter.jar
/Applications/MaxMSP 4.6/Cycling ’74/java/lib/ej.jar
/Applications/MaxMSP 4.6/Cycling ’74/java/lib/fourier.jar
/Applications/MaxMSP 4.6/Cycling ’74/java/lib/ftmjava.jar
/Applications/MaxMSP 4.6/Cycling ’74/java/lib/javazoom.jar
/Applications/MaxMSP 4.6/Cycling ’74/java/lib/jitter.jar
/Applications/MaxMSP 4.6/Cycling ’74/java/lib/jode-1.1.2-pre-embedded.jar
/Applications/MaxMSP 4.6/Cycling ’74/java/lib/loadedstring.jar
/Applications/MaxMSP 4.6/Cycling ’74/java/lib/max.jar
/Applications/MaxMSP 4.6/Cycling ’74/java/lib/physics.jar
MXJClassloader CLASSPATH:
/Applications/MaxMSP 4.6/Cycling ’74/java/classes/
/Applications/MaxMSP 4.6/Cycling ’74/java/classes
Jitter Java support installed
Lobjects for Max Β© Regents of the University of California.
matrix v4.6 OSX/i386: Β©2001,2003, 2006 by Panaiotis. All Rights Reserved
–> multictrl v5.0 float OSX PPC: Β©1994-2008 by Panaiotis All Rights Reserved
Β multijoin v4.2: PPC/OSX Β©2001-2004 by Panaiotis. All Rights Reserved
Copyright Β© 2006 Panpot Zorglub GMEM Marseille F

Rand: seedable random number generators (version 1.03)
Rand: Copyright Β© 1994-2004 by Gary Lee Nelson

Tap.Tools Pro – Welcome…
version 2.3.1
http://www.electrotap.com

vst~: can’t find plug-in, using default
The 1 parameter of Default is:
P1
β€’ error: java.lang.UnsupportedClassVersionError: Bad version number in .class file
β€’ error: at java.lang.ClassLoader.defineClass1(Native Method)
β€’ error: at java.lang.ClassLoader.defineClass(ClassLoader.java:676)
β€’ error: at com.cycling74.max.MXJClassLoaderImpl.doLoadClass(MXJClassLoaderImpl.java:119)
β€’ error: at com.cycling74.max.MXJClassLoader.loadClazz(MXJClassLoader.java:88)
β€’ error: Could not load class ‘tst_Shapes_01b’
β€’ error: java.lang.UnsupportedClassVersionError: Bad version number in .class file
β€’ error: at java.lang.ClassLoader.defineClass1(Native Method)
β€’ error: at java.lang.ClassLoader.defineClass(ClassLoader.java:676)
β€’ error: at com.cycling74.max.MXJClassLoaderImpl.doLoadClass(MXJClassLoaderImpl.java:119)
β€’ error: at com.cycling74.max.MXJClassLoader.loadClazz(MXJClassLoader.java:88)
β€’ error: Could not load class ‘tst_chua_03_rs’
β€’ error: java.lang.UnsupportedClassVersionError: Bad version number in .class file
β€’ error: at java.lang.ClassLoader.defineClass1(Native Method)
β€’ error: at java.lang.ClassLoader.defineClass(ClassLoader.java:676)
β€’ error: at com.cycling74.max.MXJClassLoaderImpl.doLoadClass(MXJClassLoaderImpl.java:119)
β€’ error: at com.cycling74.max.MXJClassLoader.loadClazz(MXJClassLoader.java:88)
β€’ error: Could not load class ‘tst_chua_03_rs’
β€’ error: java.lang.UnsupportedClassVersionError: Bad version number in .class file
β€’ error: at java.lang.ClassLoader.defineClass1(Native Method)
β€’ error: at java.lang.ClassLoader.defineClass(ClassLoader.java:676)
β€’ error: at com.cycling74.max.MXJClassLoaderImpl.doLoadClass(MXJClassLoaderImpl.java:119)
β€’ error: at com.cycling74.max.MXJClassLoader.loadClazz(MXJClassLoader.java:88)
β€’ error: Could not load class ‘tst_v_d_pol_mx_00l’
β€’ error: java.lang.UnsupportedClassVersionError: Bad version number in .class file
β€’ error: at java.lang.ClassLoader.defineClass1(Native Method)
β€’ error: at java.lang.ClassLoader.defineClass(ClassLoader.java:676)
β€’ error: at com.cycling74.max.MXJClassLoaderImpl.doLoadClass(MXJClassLoaderImpl.java:119)
β€’ error: at com.cycling74.max.MXJClassLoader.loadClazz(MXJClassLoader.java:88)
β€’ error: Could not load class ‘tst_v_d_pol_mx_00j’
β€’ error: java.lang.UnsupportedClassVersionError: Bad version number in .class file
β€’ error: at java.lang.ClassLoader.defineClass1(Native Method)
β€’ error: at java.lang.ClassLoader.defineClass(ClassLoader.java:676)
β€’ error: at com.cycling74.max.MXJClassLoaderImpl.doLoadClass(MXJClassLoaderImpl.java:119)
β€’ error: at com.cycling74.max.MXJClassLoader.loadClazz(MXJClassLoader.java:88)
β€’ error: Could not load class ‘tst_v_d_pol_mx_00i’
β€’ error: java.lang.UnsupportedClassVersionError: Bad version number in .class file
β€’ error: at java.lang.ClassLoader.defineClass1(Native Method)
β€’ error: at java.lang.ClassLoader.defineClass(ClassLoader.java:676)
β€’ error: at com.cycling74.max.MXJClassLoaderImpl.doLoadClass(MXJClassLoaderImpl.java:119)
β€’ error: at com.cycling74.max.MXJClassLoader.loadClazz(MXJClassLoader.java:88)
β€’ error: Could not load class ‘tst_v_d_pol_mx_00h’
β€’ error: java.lang.UnsupportedClassVersionError: Bad version number in .class file
β€’ error: at java.lang.ClassLoader.defineClass1(Native Method)
β€’ error: at java.lang.ClassLoader.defineClass(ClassLoader.java:676)
β€’ error: at com.cycling74.max.MXJClassLoaderImpl.doLoadClass(MXJClassLoaderImpl.java:119)
β€’ error: at com.cycling74.max.MXJClassLoader.loadClazz(MXJClassLoader.java:88)
β€’ error: Could not load class ‘tst_v_d_pol_mx_00g’
β€’ error: java.lang.UnsupportedClassVersionError: Bad version number in .class file
β€’ error: at java.lang.ClassLoader.defineClass1(Native Method)
β€’ error: at java.lang.ClassLoader.defineClass(ClassLoader.java:676)
β€’ error: at com.cycling74.max.MXJClassLoaderImpl.doLoadClass(MXJClassLoaderImpl.java:119)
β€’ error: at com.cycling74.max.MXJClassLoader.loadClazz(MXJClassLoader.java:88)
β€’ error: Could not load class ‘smc_v_d_pol_1′
β€’ error: java.lang.UnsupportedClassVersionError: Bad version number in .class file
β€’ error: at java.lang.ClassLoader.defineClass1(Native Method)
β€’ error: at java.lang.ClassLoader.defineClass(ClassLoader.java:676)
β€’ error: at com.cycling74.max.MXJClassLoaderImpl.doLoadClass(MXJClassLoaderImpl.java:119)
β€’ error: at com.cycling74.max.MXJClassLoader.loadClazz(MXJClassLoader.java:88)
β€’ error: Could not load class ‘musical_chua_01′
β€’ error: java.lang.UnsupportedClassVersionError: Bad version number in .class file
β€’ error: at java.lang.ClassLoader.defineClass1(Native Method)
β€’ error: at java.lang.ClassLoader.defineClass(ClassLoader.java:676)
β€’ error: at com.cycling74.max.MXJClassLoaderImpl.doLoadClass(MXJClassLoaderImpl.java:119)
β€’ error: at com.cycling74.max.MXJClassLoader.loadClazz(MXJClassLoader.java:88)
β€’ error: Could not load class ‘tst_MaxwellBloch_00e’
β€’ error: java.lang.UnsupportedClassVersionError: Bad version number in .class file
β€’ error: at java.lang.ClassLoader.defineClass1(Native Method)
β€’ error: at java.lang.ClassLoader.defineClass(ClassLoader.java:676)
β€’ error: at com.cycling74.max.MXJClassLoaderImpl.doLoadClass(MXJClassLoaderImpl.java:119)
β€’ error: at com.cycling74.max.MXJClassLoader.loadClazz(MXJClassLoader.java:88)
β€’ error: Could not load class ‘tst_MaxwellBloch_00g’
β€’ error: java.lang.UnsupportedClassVersionError: Bad version number in .class file
β€’ error: at java.lang.ClassLoader.defineClass1(Native Method)
β€’ error: at java.lang.ClassLoader.defineClass(ClassLoader.java:676)
β€’ error: at com.cycling74.max.MXJClassLoaderImpl.doLoadClass(MXJClassLoaderImpl.java:119)
β€’ error: at com.cycling74.max.MXJClassLoader.loadClazz(MXJClassLoader.java:88)
β€’ error: Could not load class ‘tst_MaxwellBloch_00h’
nth object V1.32 (UB) – s.lemouton – IRCAM – 23/01/96-19/11/2006
nth limitΓ© Γ  512 Γ©lΓ©ments
Aug 17 2006  03:00:58  00018aefd a-hv Β© a n d r Γ© s i e r 2 0 0 4 all rights reserved
A-Chaos Lib :: a-henon Jun 30 2006 00:46:47 Β© a n d r Γ© s i e r 2 0 0 4 all rights reserved
A-Chaos Lib :: a-henon_heilles Jun 30 2006 00:47:32 Β© a n d r Γ© s i e r 2 0 0 4 all rights reserved
A-Chaos Lib :: a-fibonacci Jun 30 2006 01:00:07 Β© a n d r Γ© s i e r 2 0 0 4 all rights reserved
β€’ warning: outlet_add: already in table
A-Chaos Lib :: a-duffing Jun 30 2006 00:44:32 Β© a n d r Γ© s i e r 2 0 0 4 all rights reserved
coll: finished, 8 lines
coll: finished, 10 lines
β€’ error: java.lang.UnsupportedClassVersionError: Bad version number in .class file
β€’ error: at java.lang.ClassLoader.defineClass1(Native Method)
β€’ error: at java.lang.ClassLoader.defineClass(ClassLoader.java:676)
β€’ error: at com.cycling74.max.MXJClassLoaderImpl.doLoadClass(MXJClassLoaderImpl.java:119)
β€’ error: at com.cycling74.max.MXJClassLoader.loadClazz(MXJClassLoader.java:88)
β€’ error: Could not load class ‘tst_chua_03_rs’
Β¬βˆ‘ bezier Β¬βˆ‘ jasch Β¬βˆ‘ May 8 2009 Β¬βˆ‘ © all rights reserved
Jul 4 2007  19:55:47  00019a84d a-lissa Β© a n d r Γ© s i e r 2 0 0 4 all rights reserved
series: 0 1 1.000000

Attachments:
  1. mxjpreferences.xml
Mar 15, 2013 at 12:46pm #199830