2 problems with the Jitter tutorials

Dec 19, 2007 at 5:07am

2 problems with the Jitter tutorials

I’m on an intel Mac OS X 10.4.11

First, I can’t run the flash tutorial 44. I read how starting with quicktime 7.1 you need to manually enable flash support in the quicktime system preferences. Problem is, I have no option to enable flash. I did some googling and found this:
http://docs.info.apple.com/article.html?artnum=307176
(see the last fix listed on the page).
There’s security vulnerability so they disable the entire feature. Nice. So… I can’t view flash in quicktime anymore, and therefore can’t use flash with jitter as demonstrated in this tutorial? Any workarounds?

Second, in tutorial patch 31jMoreRenderDestinations, drawing order is backwards. When I first start rendering I only see a blue circle. The tutorial pdf “Multiple Renderers and Drawing Order” (page 278-9) says that if I click the top B (blue circle) and then the bottom B (yellow circle) I should see a yellow circle over top of a blue circle. I only see the blue circle. I have to go backwards (click the bottom B and then the top B) to see what the tutorial describes. Can anyone explain that?

-Adam

#35058
Dec 19, 2007 at 2:36pm

About tutorial 31:

Seems to me like there is nothing that differentiates the order in which the objects are being drawn. Layers, depth etc. are all the same, so the only thing that makes it draw one shape in front of the other is the order in which they’re assigned to the drawing context.

As the blue circle is processed earlier than the yellow one (as it’s position in the file is earlier, in a text editor), it’s assigned to A first, and only then the yellow circle is assigned.

Looks like the one that was assigned most recently gets drawn first (and ends up behind the other). Add “@position 0.5 0. 0.” to the yellow circle to see that it also works the other way. Add “@layer #” to either to control them properly.

But you’re correct when you say this is not what the tutorial shows. Should be fixed…

#119077
Dec 19, 2007 at 5:32pm
#119078
Dec 19, 2007 at 5:54pm

On Dec 18, 2007, at 9:07 PM, Adam Murray wrote:

> I’m on an intel Mac OS X 10.4.11
>
> First, I can’t run the flash tutorial 44. I read how starting with
> quicktime 7.1 you need to manually enable flash support in the
> quicktime system preferences. Problem is, I have no option to
> enable flash. I did some googling and found this:
> http://docs.info.apple.com/article.html?artnum=307176
> (see the last fix listed on the page).
> There’s security vulnerability so they disable the entire feature.
> Nice. So… I can’t view flash in quicktime anymore, and therefore
> can’t use flash with jitter as demonstrated in this tutorial? Any
> workarounds?

In Max 5 there will be a patcher embedded web browser which could be
of use, but otherwise, the only simple solution to downgrade to an
earlier version of quicktime.

> Second, in tutorial patch 31jMoreRenderDestinations, drawing order
> is backwards. When I first start rendering I only see a blue
> circle. The tutorial pdf “Multiple Renderers and Drawing
> Order” (page 278-9) says that if I click the top B (blue circle)
> and then the bottom B (yellow circle) I should see a yellow circle
> over top of a blue circle. I only see the blue circle. I have to go
> backwards (click the bottom B and then the top B) to see what the
> tutorial describes. Can anyone explain that?

Sorry for this legacy documentation problem. The thread Derrick
posted should explain all the issues.

Thanks,
Joshua

#119079
Dec 20, 2007 at 9:12am

Quote: Kyred wrote on Wed, 19 December 2007 09:32
—————————————————-
> look at that :
>
> http://www.cycling74.com/forums/index.php?t=msg&goto=98932&rid=3975&S=65c965c26ba89318de848ff863687260#msg_98932
>
—————————————————-

Thanks!

-Adam

#119080
Jun 3, 2013 at 8:50am

Tutorial 31 : it’s 2013 and this problem is still here. What is worse is that adding the @layer attrtibute to the gridshape objects doesn’t change anything. I have a hard time trying to get a clear view of what’s going on in OpenGL and that doesn’t help !

#251526
Jun 3, 2013 at 9:15am
#251529
Jun 3, 2013 at 9:20am

Total confusion now : to make things work in tut31, I had to set depthbuffer attribute to 0 for the jitwindow objects. And in tut36, I can read this : “The name attribute allows the jit.pwindow object to be used as a drawing destination, although this was already done and saved with the tutorial patch in this case. The message depthbuffer 1 causes a depth buffer to be attached to the destination, so that automatic hidden-surface removal can be done.” ?????

#251530
Jun 3, 2013 at 11:10am

hi stephane.
apologies for the confusion, and for the missing forum post.
i’m sure we can clarify things for you.

the major opengl discrepancy with earlier versions is that as of Max 6, the jit.window depthbuffer is enabled by default. this causes the blue ball to conceal the yellow ball, regardless of layer settings.

the solution is to disable depth on the two gridshapes (@depth_enable 0).
draw order can then be controlled via the @layer attribute.

if anything is still unclear, please let us know.

#251544

You must be logged in to reply to this topic.