Forums > MaxMSP

About timing, the stupid


slx
April 6, 2013 | 12:43 pm

There a 1000 questions, e.g. clocksource and the transport object … but 1st things 1st.
i am working on a little sequencer to control a hardware synth module. For internal timing and metro control i use the transport object.
Next thing is to sync the sequencer to a daw. i use the sync object to calculate the bpm and let an internal metro do the rest.
Transport control is via the rtin object.
If i look at the midi data in a daw my max sequencer spits out, it is really out of sync.

I thought maybe the best way for synchronization is to use the rtin object and use the midi message 248. Here i encountered that the counter object is doing a really bad job when it comes to good timing. Maybe it is not a good idea to use the counter object for sequencing purposes.
Here is an example patch about using MIDI message 248 with a modulo object and with a counter object. Open a daw, make the midi setup that the patch recieves the transport and clock messages and the daw the midi notes the patch spits out …

– Pasted Max Patch, click to expand. –

What is your expierence with timing and synchronisation? What should i use?

Best,
sebastian


April 6, 2013 | 2:23 pm

In your patch, using [counter 11] instead of [counter 12] will do a better job ;)


April 6, 2013 | 6:00 pm

Or perhaps [counter 1 12]



slx
April 6, 2013 | 7:49 pm

Oh stupid me. Thank you broc and chris. But in my original patch I do have not this mistake.

Please, have a look at this patch. This is more like the original patch (in the original I use more than one metro, thats way I use transport). And i do not get the timing correct. Is transport not the right thing?
The first note is never really at the first measure …

(Same here: Open a daw, make the midi setup that the patch recieves the transport and clock messages and the daw the midi notes the patch spits out …)

– Pasted Max Patch, click to expand. –

`
Thanks all of you in advance.


April 6, 2013 | 9:11 pm

In my experience tempo (BPM) control with midi clock is problematic. So I wouldn’t use transport but simply trigger multiple metros directly with clock messages (248) as in your first patch.


April 6, 2013 | 9:33 pm

In your revised patch, you are counting from 1 to 32, yet you are resetting the counter to 0, which could cause problems. I think I might reset to 1, using the synchronous reset input instead.



slx
April 6, 2013 | 10:05 pm

chris, you mean like that:

– Pasted Max Patch, click to expand. –

It seems to help … sometimes. In the reference is written, that it is only useful if a time signature change is received, what is not the case here, isn’t it? And still i have to reset the counter if i would like the sequence to start at the beginning, or am i overlooking something?

broc, in my first example patch i used the 248 message, but still the first note is not at the first measure (looking at the recorded midi notes in my daw) …

any further hints?
thx,
sebastian


April 6, 2013 | 10:47 pm

Here is a quick test patch with picture of the recorded notes in Logic.

– Pasted Max Patch, click to expand. –

[attachment=220292,5380]

Attachments:
  1. Picture1.png


slx
April 7, 2013 | 9:03 am

Hi broc,

the midi data recording looks tight and perfect. If i run your patch and record the midi it looks like this:

F***K! can not upload a picture …

But i think you nailed it down. Here I have the broc mod1 patch:

– Pasted Max Patch, click to expand. –

and it looks like this:
S**T, how to upload these pictures?

almost perfect but the very first note is not super tight.

Thank you very much,
Sebastian



slx
April 9, 2013 | 5:46 pm

I found out that my USB Audio Interface seems to cause the most part of the timing problems. While having the Audio Interface as the audio out device in my daw to record the midi data the timing is off, if i choose as audio device the internal audio the timing is almost right.

My audio interface is a tascam us-600, the daw i use is ableton.

Stange …

p.s. and i cannot post pictures …


April 9, 2013 | 6:53 pm

Ableton Live by design introduces midi input latency to reduce jitter. The latency depends on the audio buffer size. Try setting it as small as possible (eg. 64 samples).

Re posting pictures:

1. Write some text in the ‘Reply’ field
2. Scroll down to ‘Upload Files…’
3. Press ‘Choose File’ (make sure the selected file has an allowed format)
4. Press ‘Upload’



slx
April 9, 2013 | 7:44 pm

Broc, thank you, that solved it. The Audio buffer of ableton was at 512 samples. With 259 the midi data sits perfect on the 16th measures.

Still only the first midi note is not placed tight at the measure.

P.S. thanks for the picture upload help, but that was exactly what i was doing and i get always the message:
"Error

You failed to complete the form correctly, please return to the previous page and try again."

Maybe because i am not a proved human …


Viewing 12 posts - 1 through 12 (of 12 total)