Forums > Max For Live

absolutely going mad! > osc udp

June 5, 2014 | 4:23 pm

hi folks,

i’m completely helpless and need an(y) advice by whoever has a clue.
i’ve been struggling with getting a two-way connection to the new behringer x32 digital mixing console
which states (and has proven) to be able to understand osc. the one way works very fine: i can control parameters via udp (on port 10023). the other way is: numb! no chance — i get nothing back from the mixer.
the osc documentation states that sending the console an "/xcontrol" command (other sources say "/xremote" is necessary) will dump out its current values. furthermore it is said that sending an empty path (without a value) will return the value for this given path (see patch). nothing (!) works.
anybody? am i doing something very basic wrong here?
i’d be so gracious!

this is not very helpful, for me at least:

http://www.behringer.com/assets/X32_OSC_Remote_Protocol.pdf

– Pasted Max Patch, click to expand. –
  • This topic was modified 2 months by  bennnzzz.
  • This topic was modified 2 months by  bennnzzz.

June 6, 2014 | 12:13 am

You can’t send and receive on the same port as far as I know, try changing your receive port to something else like 9000


June 6, 2014 | 2:23 am

several sources say, that it sends back on the same port as you request the dumpout (this sounds like a tongue-breaker! :))

if i use wireshark (mac application to "sniff" my connections), i get the impression that my computer *more or less randomly*
receives on some strange ports such as 60302 etc. i barely have an idea about networking.

got another hint? is there a chance that i need to convert my request-messages to binary or something? no idea :S


June 6, 2014 | 2:48 am

i think i’m not getting the whole port thing which i suppose is the actual problem.
my mixer runs (?) on port 10023. if i use it’s native mac-application/editor to connect to it and
change settings, my changes are sent out on this port, but received on another. how do i know (and furthermore set up)
max to receive on the port the console sends information back from (as this port seems to be different every time :S)


June 6, 2014 | 3:35 am

If I am using an OSC app on an iPad for example I will set it up like this, but I don’t know enough to say how that relates to your mixer:

iPad outgoing port: 8000
iPad incoming port: 9000

Max outgoing port: 9000
Max incoming port: 8000

I would have thought you have options to choose what input and output ports you use on your mixer, but I really don’t know. Does it have its own forum? Maybe look there?


June 6, 2014 | 3:42 am

thanks again, luke!
the mixer has some forums (as it’s pretty much boosted in popularity), but nothing’s of help,
cause (strangely.. or understandably) nobody seems to have attempted a connection with max.

unfortunately i can’t set up it’s outgoing port. it’s incoming port is 10023 as mentioned.

i think i don’t understand the udp-thing. what i suppose i’d need to find out is the port that max
receives information back when it sends them out. does that make sense? do you know anything about this?


June 6, 2014 | 5:40 am

You define the udp ports in the simplest way.
Send from Max (anything)
udpsend 9001 (send out of port 9001)
recieve into max
udpreceive 9002 (receive on port 9002)

Make a simple test.
Create a simulation in max with the right port numbers and just send a basic message through.
Once you have that working then try it with the mixer.
The tutorial for the object states it all very clearly.


June 6, 2014 | 5:50 am

i think i’ve gotten that far. sending and then receiving on one and the same port within max works fine. (udpsend 9000 -> udpreceive 9000).
the mixer’s osc manual says it receives on port 10023. works! furthermore it says, that it sends requests back on the senders port.
requests to the mixer are apparently stated by non-value path-messages (e.g. "/channel/01" instead of "/channel/01 1000") or the message "/xremote". but the port these messages "come back" at seems to be random. anyhow other (non-max) software is obviously able to receive changes within the mixers parameters.


June 6, 2014 | 6:16 am

I had a look at the x32 forum and there seem to be others having this problem, it seems to be a strange OSC implementation on Behringer’s part:

http://www.x32user.net/phpbb2/viewtopic.php?f=21&t=312&hilit=osc+ports&start=10

On the DAWOSC forum someone explains it well:

http://dawosc.forumotion.com/t72p15-connecting-to-hardware-mixer

I know Siska Adam has some UDP objects in the sadam library, maybe see if they can help.


June 6, 2014 | 6:34 am

thanks for all your effort, luke.

i think i might just need to give up :( i’ve looked into adam’s udp objects but they appear to be of no help -
it still seems necessary to (obviously) listen on one explicit port. to sum up what i’ve learned / suppose:

    1) i send a request to the behringer x32′s port 10023
    2) behringer gets my port (i am sending from) and sends the requested data back to this port
    3) i cant find out which port i am sending (receiving) through as it appears to be random.

is this correct? any last words :) ?

  • This reply was modified 2 months by  bennnzzz.

June 6, 2014 | 6:42 am

i’ve done some more wiretapping.. it appears, that max receives information back on *some* (own, randomly assigned) port.
this is most probably the port that the x32 sends the data back to – the port i would have to udpreceive to.
is there any way to read out max’s "source port" – in other words its own port? does that even make sense in terms of networking?

  • This reply was modified 2 months by  bennnzzz.
  • This reply was modified 2 months by  bennnzzz.

June 6, 2014 | 11:57 am

A computer sending to itself with UDP is always 127.0.0.1.
Eg udpsend 127.0.0.1. I use this to send from ableton max for live to another max patch. Hope that makes sense.
You have to define the port, max can’t do that randomly.
Maybe post a stripped down version of your patch with just the basic data flow and udp objects. maybe you made a simple error with defining the arguments.
Eg. udpreceive doesn’t need an ip address !


June 6, 2014 | 1:05 pm

@Andro, I read through some stuff on a couple of forums and this isn’t a normal OSC setup by the look of it. The x32 seems to do some weird stuff in the way it handles OSC as it won’t let you decide on an output port, I quote:

"x32 listens on port 10023 and responds to the port that requested /xremote command. That is what causes problem to all osc programs (both ios and android).

Let me try to explain the "random port" thing.

When you send a UDP message, it goes from IP1:PORT1 to IP2:PORT2. You specify IP2 and PORT2 (that is your outgoing setting). IP1 is your client’s IP. Now PORT1 is the problem. Normally you don’t care what it is and usually it is randomly assigned by OS or socket library."

So it seems this is the problem, it is sending back to an originating random port rather than letting you specify one so you don’t know what to set your UDPreceive to. Max won’t let you specify an outgoing port (you specify the host port on UDPsend) and it shouldn’t have to really as it works like every other OSC app.


June 6, 2014 | 1:09 pm

udpreceive doesn’t need an ip address

but it still needs a port number !
@op : what are the applications that are designed to communicate wiht the Behringer and which work naturally with it ? you could find by there which port number is the correct one. anyway don’t give up :) are you on osx ? there is "network utility.app" (or something called close to that) that might help you see what’s going on


June 9, 2014 | 7:42 am

luke got it pretty straight.
port and ip of the behringer are clear — the ip you define and the port is always (!) 10023.
to repeat: the problem is the senders (max’s) port.

sender –> states request from port x to port 10023
x32 –> send back to the senders port x.

software that works well:
> x32 sniffer (x32 scribbler — might even be opensource, so if anybody’d like to dig into that; i have no clue of "real" programming :))
> official behringer x32-edit software (mac and win)

i’m on a mac. i use wireshark to "sniff" my outgoing connections (port). this clearly displays, that my port (from which is send requests to the x32) is always random :/


June 9, 2014 | 12:27 pm

off-topic:
"mad! > osc udp"
i never saw this usage of ‘>’ before. it immediately clicked as ‘mad OVER osc udp’. so instinctual. yet i’d think for ‘over’ it might be:
"mad! / osc udp"
but then that might look like an ‘or’!
anyways, i learned something new today just from the title :)


Viewing 16 posts - 1 through 16 (of 16 total)