Forums > Max For Live

adc~ in a midi instrument

February 7, 2010 | 6:29 pm

I have a midi instrument in Max 5 which takes audio input from adc~. I am trying to port this to max4live, but adc~ is not working. How do I get audio into a max instrument?

Many thanks


February 7, 2010 | 8:23 pm

Not possible. M4L instruments can only have midi input.


February 8, 2010 | 9:06 pm

Thanks for that. It’s a shame.


February 9, 2010 | 4:24 pm

Not possible doesn’t exist in an inventors vocabulary…;-)
When beta testing I worked on some workarounds, basically you feed midi from a midi track to a max4live audio effect with send/receive.
Till we get universal tracks (audio of as many channels as you need and midi together) we need to create workarounds, its a bit annoying, but certainly possible…

Stefan


February 9, 2010 | 6:25 pm

Stefan,

please note that the OP wants to feed *audio*, not midi…
What’s your "possible" workaround in this case?


February 10, 2010 | 8:32 pm

Apologies if I was unclear, but see below for the patch. For the most part, it’s taken from Jean-Francois’ freeze patch. Sound from the adc~ is frozen and then "played" through midi input and gizmo. There’s a facility to cross fade between two jitter matrices. It basically works in Max5, but it’s quite flakey in the live port. Rather than using the adc~ I am loading two jxf files created with the Max 5 version. No doubt the patching is clumsy, as I don’t really know what I’m doing with the pfft and jitter stuff.

Any comments welcome.

Cheers

– Pasted Max Patch, click to expand. –

February 20, 2010 | 12:08 am

Am I missing something here, or can’t you just use the plugin~ object? That should route audio form a record enabled track to the patch on that track.

Sorry if I am misunderstanding or misreading.


February 27, 2010 | 12:15 pm

I know see what you mean – that midi in and plugin~ can’t work simultaneously. A frustrating limitation indeed.


February 28, 2010 | 10:41 pm

If you port it to a Max AUDIO device it will work. There you can have your audio insert and a midi control by accesing your midi controller from the patch.


March 1, 2010 | 10:46 am

Hi Crampe,

nice trick, but I’m not sure if it really works in practice. You’d need to load an instrument in front of the audio device which passes midi through from the track input to the audio device. But I believe that’s not possible..


March 1, 2010 | 2:54 pm

You don’t need to load an instrument in front of it, because you don’t need any midi track.
Think of it as an "audio instrument" instead of a midi one.
So, where would you load an audio instrument…
…into an Audio track.
As I said in my last post : "by accesing your midi controller from the patch";
i.e using the "path control_surfaces N"
It works, I’ve tried before posting.


March 1, 2010 | 3:06 pm

Ok, thanks for the clarification.


March 1, 2010 | 3:44 pm

Hmm, I’m still a bit confused about this work around. So you use an audio track with your audio effect on it, got it.

But then say you wanted to use a midi keyboard to control the pitch of the filter cutoff with midi note number, for instance – how can you do that on an audio track?


March 1, 2010 | 6:13 pm

Well, I think the proposed work around actually means using a different method, namely remote control instead of standard midi input..


March 1, 2010 | 6:41 pm

You need to access your midi controller from your patch.
You have to connect a [live.path control_surfaces N] (N is the "number" of your control surface -this have to be configured in LIve’s preferences-) to a live.observer, and send a "property value" message to it. Have a look at the Live.Api_explorer.amxd patch from (I forgot his name) I’ve attached. It will help you going to your control surface, find the right path and gives you information about what you can expect to do with it.
I’ve also attached a little patcher I’ve made in order to have the Launchpad matrix buttons coordinates informations to be translated into single numbers… perfect for midi note number. I can insert this patcher into a m4L audio device and have midi control.
You won’t be able to do something with if you don’t have a launchpad, but maybe it could be handy to look at it (the top half part of it).

… And I just realise that this will probably work only if you have a "Live-supported" controller; i.e the controllers that can be selected in Live’s preferences, midi sync tab, in the control surfaces part, not the "midi ports" one. But there’s a little chance you controller’s not, except if you bought it 20 years ago, or if you DIY it.

And, sorry my english.

Attachments:
  1. Max_files.zip

March 1, 2010 | 9:00 pm

Thanks, all. That looks like an interesting work-around, Crampe, but I don’t have a controller. I haven’t had time to look at Stefan’s suggestion, but I think that might be the nearest thing to what I need. I’ve read here that using send and receive between tracks can be a bit sluggish, so I’m not sure how it’ll work out in practice.

Cheers


March 1, 2010 | 10:03 pm

Thank you very much Crampe, and no worries, I understand you perfectly. This helps me understand the solution you are talking about. This does seem the best way to approach the problem for now.

Pretty sure at least one of my controllers is supported. Thanks again, good to be able to get back to work on porting my max devices!

Jeremy


March 1, 2010 | 10:22 pm

Tegid O, If you don’t have a midi keyboard, then… I have no solution :-)
Where do you want to grab the midi from?
If it’s not from an external midi source, then you can do everything in your patch.
I must be missing something.


March 3, 2010 | 10:39 pm

I think perhaps he means he would like to control the patch using a midi track in Live?


March 4, 2010 | 12:47 am

… so, I must be missing something! :-)


March 4, 2010 | 7:18 am

What you have to do is, put into a miditrack a Midi device, basically a [midiin]->[send MyWonderfullAudioEffect] and in the Audio device you place instead of a [midiin] a [receive MyWonderfullAudioEffect]. Now you can use the Midi track to route Midi to your Audio effect.

If you want it more universal, have a look at my MidiSend device
http://www.maxforlive.com/library/device.php?id=59
in combination with my Filter for example

http://www.maxforlive.com/library/device.php?id=60

Have fun…

Stefan


March 4, 2010 | 11:37 am

Hello Stefan. That is a very useful m4l device, does something very similar to what I want. I would like to modify it to send note on/off as well, but for some reason I cannot edit it in Max – "unlock patch" button is disabled.

Surely I am missing something basic, but is there a reason I cannot edit this device?

Jeremy


March 4, 2010 | 11:40 am

Oh dear, yes, the unfreeze button. sorry for the noise ;) Thank you for this device!


March 4, 2010 | 1:27 pm

The device is prepared to receive Midi via the MidiSend device. To send Midi doesn’t make too much sense, I’d look at the two keyboards just for displaying purposes. Within MidiSend, you could add a keyboard as well…

Anyway, modify it at your will, it comes with a cc sa-nc-by license…

A smile or a donation in an unspecified amount to my moneybookers account will give you also a commercial license…;-)
(But you can only pass on your changes with the sa-nc-by license. (I still need some cash to finally buy a Live license, after the beta phase I had been cut off from further device development for the lack of monetary resources…))


Viewing 24 posts - 1 through 24 (of 24 total)