Forums > MaxMSP

Aggregate devices

May 11, 2007 | 4:16 pm

hi all

I’ve created an aggregate device in OSX, hoping that I can use my
Firewire interface (Saffire Pro) and my Teabox via the laptop digital
in at the same time. (Saffire and Digital in selected, with Saffire
as the master clock).

In the DSP Status window in Max, I select Core Audio Pro 1010 (the
Saffire) as my driver, and then it looks like I can select _either_
the Saffire OR the digital in as the input source. (If I select
digital in, I get the Teabox signal oin ch1)

Should I be able to get both of these inputs simultaneously? How!?
There’s nothing called Aggregate Device showing up in the DSP Status
driver menu.

I can use the SPDIF in on the Saffire, but it’s slow switching, and
it would be neat if I could set it up sing the digital in on the
laptop as well.

Any ideas? Is this possible?

thanks

David


May 11, 2007 | 9:45 pm

well, where do you declare your aggregate device?

We have one running here – but it must be declared by the administrator – as Max always refers to – do not know – local setting and not user setting (for rewire, aggregate devices, etc.)

In Audio-MIDI-Setup you can name the aggregate and that name should show up in Max ….

hope that helps

best


May 11, 2007 | 10:11 pm

Well, there’s obviously a problem here!
I’m running the Mac as administrator (in fact that’s the only account).

If I set up an aggregate device, not only does it not show up in Max,
but it disappears if I quit AudioMidi Setup (ie it’s gone when I re-
open AMS). Surely that’s not right?

By"declare", do you mean anything other than creating a device in AMS
(and setting the devices and naming it)?

On 11 May 2007, at 22:45, Steff wrote:

>
> well, where do you declare your aggregate device?
>
> We have one running here – but it must be declared by the
> administrator – as Max always refers to – do not know – local
> setting and not user setting (for rewire, aggregate devices, etc.)
>
> In Audio-MIDI-Setup you can name the aggregate and that name should
> show up in Max ….
>
>
> hope that helps
>


May 12, 2007 | 7:19 am

hello,

>>
By"declare", do you mean anything other than creating a device in AMS
(and setting the devices and naming it)?
>>

I mean : go to A(udio)M(idi)S(etup) -> AUdio ->open device editor (or so) and there setup a aggregate device ….

We did tests with FieFace800 + internal and 2x FireFace and we use 2x FireFace all the time …..

It was important for Max that the administrator did that – cause under the user accounts if we setted up a AD Max would not see that …..

hope that helps

best


May 12, 2007 | 8:28 am

That’s exactly what I’ve been doing, to no avail!

Does anybody have any ideas about why this wouldn’t be working?

(And thanks for the input Steff)

David

On 12 May 2007, at 8:19, Steff wrote:

>
> hello,
>
>>>
> By"declare", do you mean anything other than creating a device in AMS
> (and setting the devices and naming it)?
>>>
>
> I mean : go to A(udio)M(idi)S(etup) -> AUdio ->open device editor
> (or so) and there setup a aggregate device ….
>
> We did tests with FieFace800 + internal and 2x FireFace and we use
> 2x FireFace all the time …..
>
> It was important for Max that the administrator did that – cause
> under the user accounts if we setted up a AD Max would not see
> that …..
>
> hope that helps
>
> best


Viewing 5 posts - 1 through 5 (of 5 total)