aka.wiiremote q's

Nov 26, 2007 at 9:57pm

aka.wiiremote q's

I’m currently working on a project that uses a couple of wiiremote
controllers
I scanned the max list archive but still not entirely clear on a
couple of things:

I’ve got the aka-wiiremote object (in the help patch) receiving data
from the motion and buttons output
these work fine

IR:
- but I’m not getting data from the IR outlet when I point a
wiiremote at a candle or a TV remote
[also not getting data from irraw outlet]
how are others testing the IR out from the aka.wiiremote object?
two candles? IR LED’s?

‘expansion 1′ message:
- does this turn on/off ‘nunchuck/classic_controller’ sensing when
attached to the wii-remote?

extraoutput:
- I get a dump of data from the motion_calibration outlet when I send
a ‘extraoutput 1′ message
but no continuous data
is this correct?

- how does one check and calibrate a wiiremote?

- when using multiple wiiremote controllers do I use the address for
each in a separate wiiremote object in a patch?
such as:
[aka.wiiremote 00-19-1d-3e-88-a1]

thanks in advance:

my config:
————–
OS X 10.4.11
G4 PB 1.67GHz
=========
Max/MSP 4.6.2
Jitter 1.6.2
Pluggo 3.6.0
Soundflower 1.2

#34768
Nov 27, 2007 at 2:55am

my students and i have been 100% unsuccessful in getting IR
information, expansion data or the rumble working on non-intel macs.

On Nov 26, 2007, at 4:57 PM, Kim Cascone wrote:

> I’m currently working on a project that uses a couple of wiiremote
> controllers
> I scanned the max list archive but still not entirely clear on a
> couple of things:
>
> I’ve got the aka-wiiremote object (in the help patch) receiving data
> from the motion and buttons output
> these work fine
>
> IR:
> – but I’m not getting data from the IR outlet when I point a
> wiiremote at a candle or a TV remote
> [also not getting data from irraw outlet]
> how are others testing the IR out from the aka.wiiremote object?
> two candles? IR LED’s?
>
>
> ‘expansion 1′ message:
> – does this turn on/off ‘nunchuck/classic_controller’ sensing when
> attached to the wii-remote?
>
> extraoutput:
> – I get a dump of data from the motion_calibration outlet when I
> send a ‘extraoutput 1′ message
> but no continuous data
> is this correct?
>
>
> – how does one check and calibrate a wiiremote?
>
>
> – when using multiple wiiremote controllers do I use the address for
> each in a separate wiiremote object in a patch?
> such as:
> [aka.wiiremote 00-19-1d-3e-88-a1]
>
> thanks in advance:
>
> my config:
> ————–
> OS X 10.4.11
> G4 PB 1.67GHz
> =========
> Max/MSP 4.6.2
> Jitter 1.6.2
> Pluggo 3.6.0
> Soundflower 1.2
>

#117819
Nov 27, 2007 at 3:10am

OK so I’m assuming that you have been successful in getting all this
info on Intel Macs?
does anyone happen to know the problem?
is it a Bluetooth chipset issue or an OS X services/framework issue?

On Nov 26, 2007, at 6:55 PM, joshua goldberg wrote:

> my students and i have been 100% unsuccessful in getting IR
> information, expansion data or the rumble working on non-intel macs.
>
> On Nov 26, 2007, at 4:57 PM, Kim Cascone wrote:
>
>> I’m currently working on a project that uses a couple of wiiremote
>> controllers
>> I scanned the max list archive but still not entirely clear on a
>> couple of things:
>>
>> I’ve got the aka-wiiremote object (in the help patch) receiving
>> data from the motion and buttons output
>> these work fine
>>
>> IR:
>> – but I’m not getting data from the IR outlet when I point a
>> wiiremote at a candle or a TV remote
>> [also not getting data from irraw outlet]
>> how are others testing the IR out from the aka.wiiremote object?
>> two candles? IR LED’s?
>>
>>
>> ‘expansion 1′ message:
>> – does this turn on/off ‘nunchuck/classic_controller’ sensing when
>> attached to the wii-remote?
>>
>> extraoutput:
>> – I get a dump of data from the motion_calibration outlet when I
>> send a ‘extraoutput 1′ message
>> but no continuous data
>> is this correct?
>>
>>
>> – how does one check and calibrate a wiiremote?
>>
>>
>> – when using multiple wiiremote controllers do I use the address
>> for each in a separate wiiremote object in a patch?
>> such as:
>> [aka.wiiremote 00-19-1d-3e-88-a1]
>>
>> thanks in advance:
>>
>> my config:
>> ————–
>> OS X 10.4.11
>> G4 PB 1.67GHz
>> =========
>> Max/MSP 4.6.2
>> Jitter 1.6.2
>> Pluggo 3.6.0
>> Soundflower 1.2
>>
>

#117820
Nov 27, 2007 at 9:25am

FWIW

I found that I had to use the red button on the Wii remote to sync
with the mac. If I just used the buttons on the top of the remote I
would get sync, but couldn’t use the IR or rumble. It’s a while since
I did this, but I seem to remember that I may also have had to do the
sync process twice in a row before I got the IR working. So it is do-
able, but it’s a bit flakey. This _is on an intel PowerBook, but
maybe the issue is the same.

David

On 27 Nov 2007, at 3:10, Kim Cascone wrote:

> OK so I’m assuming that you have been successful in getting all
> this info on Intel Macs?
> does anyone happen to know the problem?
> is it a Bluetooth chipset issue or an OS X services/framework issue?
>
>
> On Nov 26, 2007, at 6:55 PM, joshua goldberg wrote:
>
>> my students and i have been 100% unsuccessful in getting IR
>> information, expansion data or the rumble working on non-intel macs.
>>
>> On Nov 26, 2007, at 4:57 PM, Kim Cascone wrote:
>>
>>> I’m currently working on a project that uses a couple of
>>> wiiremote controllers
>>> I scanned the max list archive but still not entirely clear on a
>>> couple of things:
>>>
>>> I’ve got the aka-wiiremote object (in the help patch) receiving
>>> data from the motion and buttons output
>>> these work fine
>>>
>>> IR:
>>> – but I’m not getting data from the IR outlet when I point a
>>> wiiremote at a candle or a TV remote
>>> [also not getting data from irraw outlet]
>>> how are others testing the IR out from the aka.wiiremote object?
>>> two candles? IR LED’s?
>>>
>>>
>>> ‘expansion 1′ message:
>>> – does this turn on/off ‘nunchuck/classic_controller’ sensing
>>> when attached to the wii-remote?
>>>
>>> extraoutput:
>>> – I get a dump of data from the motion_calibration outlet when I
>>> send a ‘extraoutput 1′ message
>>> but no continuous data
>>> is this correct?
>>>
>>>
>>> – how does one check and calibrate a wiiremote?
>>>
>>>
>>> – when using multiple wiiremote controllers do I use the address
>>> for each in a separate wiiremote object in a patch?
>>> such as:
>>> [aka.wiiremote 00-19-1d-3e-88-a1]
>>>
>>> thanks in advance:
>>>
>>> my config:
>>> ————–
>>> OS X 10.4.11
>>> G4 PB 1.67GHz
>>> =========
>>> Max/MSP 4.6.2
>>> Jitter 1.6.2
>>> Pluggo 3.6.0
>>> Soundflower 1.2
>>>
>>
>

#117821

You must be logged in to reply to this topic.