Akai LPD8 Sampler

Sep 6, 2011 at 9:17am

Akai LPD8 Sampler

I’m trying to build a simple sampler controlled with an LDP8. What I’m after is:

1. Start samples with first press of pad, pause/stop with second press
2. Master level, individual sample level and perhaps delay/reverb (less important) with dials
3. All samples loaded when the patch is opened

I’m new to Max (six months or so), and I’m having a bit of trouble trying to figure out how to separate the data from the pads and the dials. At the moment, if I turn a dial and it goes past the values in the sel object (see below), it triggers the buttons, which would start a sample. This isn’t what I want. Can someone give me a couple of hints?

Thanks!

– Pasted Max Patch, click to expand. –
#58777
Sep 6, 2011 at 10:17am

as far as i know the lpd can send CC and note, you can set it via the free akai editor.

if the pads are set to send notes you just have to assign the note on -commands. you can use [notein] or [midiin] for that, see the example where you can switch between both ways. the notes here are 44-51, which may differ. if you´re using CC commands for the pads it´s all not that much different, the direct object would be [ctlin] instead of [notein], the value for routing the [midiin] would be 176 instead of 144.

and don´t forget to change the port from c to whatever you´re using.

– Pasted Max Patch, click to expand. –
#211279
Sep 6, 2011 at 7:27pm

Awesome, thanks! Although I have a new problem now. I’ve tried setting the cc numbers in the LPD8 editor, but when I click “Commit – Upload”, I don’t get the box that says upload successful. At the moment I’m trying to set the pads to 0-7 and the dials 8-15, but they won’t change from 1, 2, 3, 4, 5, 6, 8, 9 (pads) and 1-8 (dials). Any ideas how I can fix this?

#211280
Sep 6, 2011 at 10:19pm

maybe it´s due to a conflict caused by too many applications trying to access the device. just close anything but the editor and try again. otherwise you may have to ask the akai tech support people.

#211281
Sep 8, 2011 at 7:02pm

Thanks! Got that sorted.

I want to have audio files load when I open the patch. I’ve got some “loadmess filename.wav” objects connected to the sfplay~ objects but it’s not working. What am I doing wrong?

#211282
Sep 8, 2011 at 11:18pm
– Pasted Max Patch, click to expand. –
#211283
Sep 9, 2011 at 12:42pm

Ha, that simple huh? Added to my patch, works well. Thanks again!

#211284
Jan 25, 2013 at 2:59am

Hey, what you described is pretty much what I am looking for! Would you mind sharing so I have something to learn from? Thanks!

#211285

You must be logged in to reply to this topic.