Forums > MaxMSP

anamorphing

February 28, 2014 | 5:37 am

hi all ,

i’ll try to be clearer than last posts …

i’m trying to process some anamorphose of a picture .

here is a patch , a heavy-CPU-loading one .

i’ m  unable to manage jit.expr (working on it but it’s still too early) , gen codes or other GPU clever stuff , enough , to be fast and light .

so i’m going the bad way , but this is enough for what i want to do .

it doesn’t work good …

a picture , on a videoplane , is fullscreened in a jit.window .

a jit.gl.cornerpin is drawn on it (randomn points) , and the corner coordinates are being processed in order to produce a matrix that will be the "repos" matrix of a jit.repos .

jit.repos’ output is going to the jit.gl.cornerpin , as its texture .

i should get a flat image , on all the jit.window ,

but it’s not the case ,and i can’t figure out why .

is the process good ( i mean "good") , but the use of the videoplane , not ?

the process consists of a series of scale boxes , and  2 counters generating each pixel of the "repos matrix" , using these scaled values .

any ideas why it’s not working ?

…. render is on "ortho 2" , cornerpin is on "cornermode relative" ,i don’t know what else to say …

sorry for this quite messy patch , i have tried to make it the clearest i could .

 EDIT
sorry , previous patch had a bug , this one is ok (2 times)

<code>

– Pasted Max Patch, click to expand. –

</code>

cheers
Matthieu


March 1, 2014 | 12:00 pm

sorry to insist .
i have read , in the forum , about jit.gl.cornerpin’ s distortion .
would anybody tell me if this is the reason why my problem is happening ?

if i’m still not clear enough ,
please tell me , i’ll try to explain differently .

i have just realised that a note , in the patch , is not included ,
it was saying , at stage 3 "mapping pixels process" :
"PLEASE , WAIT FOR ~ 10 sec. , AFTER CLICKING THIS BANG" .

i’ m sorry it went away ….

Matthieu


March 3, 2014 | 8:05 am

i have it !
the distortions i’m getting are only happening between the videoplane (background) and the jit.gl.cornerpin instances.
as soon as i try to put several jit.gl.cornerpin together ,
and remove the videoplane from the view ,
the process is working good , the seams totally match !

it’s been working for approximatively 4 days now ,
and i couldn’ t see it , only looking at the distortion , compared with a videoplane …

so , that’s a good start .
i would now need to write a jit.expr formula ,in order to replace my so slow (but working) subpatch , that goes to the jit.repos right inlet .
maybe , the best would even be a jit.gen code …

cheers !
Matthieu

Attachments:
  1. d

Viewing 3 posts - 1 through 3 (of 3 total)