another gl morphing topic

Dec 27, 2012 at 1:44pm

another gl morphing topic

hi all ,
after many searches , without managing to understand what’s wrong , what i’m missing ,
here’s my question .

i’m trying to morph between two jit.gl.model , using xfade .
quite a classic on this forum , i know , but ….
here is a simple patch ,
at its simplest :

– Pasted Max Patch, click to expand. –

and i also join a zip file containing this same patch ,
and two simple objects made in blender .
first object is a basic cube , second object is this same cube , with a displacement applied to an edge .
it’s a very basic transform , done in one time , then export obj. file .
the 2 objects have the same amount of vetices, faces …

BUT ,
as you can see in the patch , they don’t morph like i would like they did .
faces are flying as we “xfade” , and land somewhere else on the destination mesh .

of course i would like them to stay in place ,
i woud like to see the modified edge growing , as we “xfade” ,
and only this . (hope i’m clearly explaining)

i think i have tried all settings i could on the render object , on the jit.gl.model objects ,on the xfade object , ….
i have tried many things in blender (format files , minimum editing on mesh, ..)
i have also tried to look at the obj. files in textedit (mac) ,
but still can’t find how to make this holy grail happen !

is the displacement the cause , even a so small and simple displacement ?

anyway ,
thanks to the many people here , who ‘ve already made me learn so much …

cheers
Matthieu

Attachments:
  1. morfolder.zip
#65826
Dec 27, 2012 at 6:17pm

PFFFFFFFF

so , after an other check ,( i think it must be the 250nth ),
things work just as i want .
i’m using the collada type of file (i’m sure i have tested it many times before ….) ,
but it’s working quite perfectly , just now !

as if i just had to post here to get it working …

so , now geometry is ok , the next step is the texture , …
i’m going on checks .
and i’m feeling there’s a kind of setting to control a “scale change” in one of the two (nearly) similar objects i’m using .
don’t know why , but as i xfade , the global scale seems to change .
makes me think of “bounding boxes related” problem …

thanks for reading
matthieu

#237052
Dec 28, 2012 at 6:54pm

is this possible to use jit.gl.model with matrixoutput 1, to render an anim ? Apparently it doesn’t work…

Anyone would have some tips to do that ? A morphing between two animations ?

+

#237053

You must be logged in to reply to this topic.