Anyone Have the .dmg for 5.0.6?

Aug 9, 2009 at 6:31pm

Anyone Have the .dmg for 5.0.6?

Hi, 5.0.7 crashes for me about every 15 minutes . I have found no reproducable pattern for the crashes, but know that they occur whenever the audio is turned on and I try to do something, like unlock the patch, adjust a GUI element, or create a new object. The crash report always gives the same first two lines for Thread 0 (the thread that crashes):

Thread 0 Crashed:
0 com.cycling74.MaxMSP 0×00029773 memoryheap_getbytes(_memoryheap*, short) + 115
1 com.cycling74.MaxMSP 0x000298d5 getbytes + 63

I have tried reinstalling, restarting, and rotating my computer’s log files. Nothing has helped. I am on a Macbook Pro OS X 10.4.11.

Until this bug is fixed, I was hoping I could use 5.0.6, since that version was quite stable for me.Unfortunately, I don’t have the .dmg for that version so I was seeing if anyone on here does, and if so, if they could post so me, or anyone else who wants to, would be able to download it.

Thanks.

#45054
Aug 10, 2009 at 2:32am

I’m not seeing this crash on my 10.4.11 Intel mini.

Unless we know what the problem is and it turns out that it is actually our problem we’re not going to be able to fix it.

Usually when I see these sorts of crashes it is due to some driver glitch. What happens if you change your audio driver hardware? What audio gear are you using? Has anything changed recently? I know it can be tricky, but we need to narrow the problem down more.

-A

#162346
Aug 10, 2009 at 6:13am

I am using the native Core Audio as a driver (going to invest in an external audio card soon). It could very well be my audio driver (that would make sense considering crashes happen only when the DAC is on).

I’m really not sure how to isolate this bug and would much rather spend time making music than trying to narrow down the possibilities for this bug. I was using 5.0.6 and things were fine, it’s only with 5.0.7 that this problem has arisen. If C74 has the .dmg for 5.0.6, could they please just post it? Thanks.

#162347
Aug 10, 2009 at 6:18am

In general, I would prefer to figure out why you are crashing now than give you a more buggy version of MaxMSP.This serves us both.

I see you have cross-posted this into support. Let’s resolve it there.

-A

#162348
Aug 10, 2009 at 4:37pm

have u tried deleting the max preference files?

#162349
Sep 2, 2009 at 7:05am

Hello there,

I’m also having regular crashes in various situations.

At the top of the logfile in the crashed thread I always get those two lines but the rest of it is in most cases different :

memoryheap_getbytes(_memoryheap*, short) + 115
getbytes + 63

I analyzed what situation could cause those various crashes and understood that it often happened after playing with pattrstorage.
(basically storing a preset with some name > updating a umenu with presets names > writing the storage file and then editing the patch or opening or closing a window)

Below a patch that crashes every time for me, can anyone reproduce it ?

Thanks

Léo

MacBook Pro 2.4GHz Intel Core 2 Duo 2Go
Mac Os 10.5.8 (also happened under 10.5.7)
Max/MSP 5.0.7 (also happened under 5.0.6) + Jitter

#162350
Sep 2, 2009 at 8:34am

Thanks, I can reproduce and will see about a fix for this.

Jeremy

#162352
Sep 3, 2009 at 5:36am

Hi Jeremy,

I know you’ll maybe won’t have any answer to my questions but anyway.

Will this get fixed in a not to far future ?
As I don’t understand correctly what happens – I suppose some kind of memory address trouble – I can’t really find a some kind of workaround.
Have you found / Is there one ?

Thanks

Léo

#162353
Sep 3, 2009 at 5:55am
Léopold Frey wrote on Thu, 03 September 2009 07:36
Hi Jeremy,

I know you’ll maybe won’t have any answer to my questions but anyway.

Will this get fixed in a not to far future ?
As I don’t understand correctly what happens – I suppose some kind of memory address trouble – I can’t really find a some kind of workaround.
Have you found / Is there one ?

It’s been fixed for the next release. For now, the workaround is to avoid ‘renumber’ and ‘remove’.

Jeremy

#162354
Sep 3, 2009 at 5:59am

Thanks

Léo

#162355
Sep 3, 2009 at 7:16am

Kyle : do your previous crashes involve [pattrstorage] with ‘remove’ or ‘renumber’ by any chance ?

I have had a lot of crashes involving memoryheap_getbytes this last six months but had no time to investigate further.
I hope this fix cover them all.

At least I can store datas now.

Leo

#162356

You must be logged in to reply to this topic.