Forums > MaxMSP

Anything I can do to make Max5 start faster?

February 9, 2009 | 4:00 pm

Hey,

Pure data starts almost instantly on my computer, If I have an Idea for something, I start pd, and seconds after im patching.

Max5 however, takes a couple of minutes…
So I dont start Max, if im not ready to do a serious patching session or something.

This often make me not use Max5.

What to do?


February 9, 2009 | 4:24 pm

Strange indeed, which OS you are working on? I am a Mac user and don’t have that problem. It takes only seconds to initalize.

When I was in PC with Max 4.2, I also didn’t have any difficulties as you did. Is your system suitable with the official reccomendations?


February 9, 2009 | 5:00 pm

Max5 (or max4, for that matter) itself doesn’t load especially slow for me on either Mac or PC. Without a patch, loading takes maybe 2-3 seconds. So there’s definitely something wrong with your setup.

It’s when you load a patch that the time starts ticking. At work, our old patch, <4mb in max4 (would load in <10 secs), now saved as 90mb with the new and improved json format. Loading takes something like 35 seconds... Good thing abstractions spare me having to save the entire thing every time.


February 9, 2009 | 5:51 pm

On Feb 9, 2009, at 8:00 AM, marlon brando wrote:
> Pure data starts almost instantly on my computer, If I have an Idea
> for something, I start pd, and seconds after im patching.
>
> Max5 however, takes a couple of minutes…
> So I dont start Max, if im not ready to do a serious patching
> session or something.
>
> This often make me not use Max5.
>
>
> What to do?

How many things are in your search path? I believe that Max looks at
objects in your search path when starting up, and if you have jillions
of objects/abstractions/patchers in your search path it can take a
while.

As an experiment, you might try launching just the stock search paths.

- C

Chris Muir
cbm@well.com

http://www.xfade.com


February 9, 2009 | 7:11 pm

my max5 takes a long time to load on both XP & VISTA. Takes a minute half to two minutes. The longest program to load up I have. Also it gives no indication of what it is doing. Ableton, Photoshop etc. have splash screens that tell you whats going on as it’s loading. You double click the MAX icon wait about 2 minutes during which time you begin to second guess whether or not you did in fact double click it and ask yourself if you should click it again. No splash screen to let you know that MAX is loading… the Max window just pops up after 2 minutes.

Not so much a hassle. I do have a few external packs in my search path and a lot of samples so maybe that’s it. No more than most I suppose.


February 9, 2009 | 7:20 pm

Thanks,

cleared the search path in file preferences, now it starts instant:)

Cheers


February 14, 2009 | 7:56 am


February 14, 2009 | 3:45 pm

do large search paths slow down max in general, or is it only for start up that this creates a problem?


February 14, 2009 | 5:30 pm

Quote: stefantiedje wrote on Sat, 14 February 2009 08:56
—————————————————-
> The official explanation for ditching the splash screen was, that Max 5
> now loads so fast, that its not worth to bother with a splash, which
> would just blink…

He he. That’s funny. I would love to see a splash screen again, as an indication that’s everything’s loading fine.


February 17, 2009 | 4:09 pm


Viewing 10 posts - 1 through 10 (of 10 total)