.app vs. .maxpat for runtime

Oct 18, 2012 at 1:36pm

.app vs. .maxpat for runtime

Hi,

I’m a performer using runtime to run a variety of patches. Recently a composer sent me standalone app for his piece. Something about this app overrode all of my .maxpat files; they try to open through the .app he sent. When I tried to open runtime first and then open the patches, or to “control-click” and “open with” , I got what seemed like the shell of a patch, but nothing usable. Also, opening runtime didn’t help, as it only gave me a “services” option. I then removed the new .app from my computer (I copied it first, of course). It took runtime with it. After re-loading the .app to my computer, I found runtime again, but not in my applications folder. By moving it back to my applications folder, I have remedied the most of the problem and am able to open the .maxpat files by control clicking and choosing “open with.” I am, however, unable to use “command-I” and “change all” .maxpat to open with runtime- the .app that was sent to me overrides this choice.

So, my question is, is there something about a .app (or perhaps this particular .app) that would cause this problem? I have run many .maxpat files in performance and have never had this problem before. I have also never received a stand alone application instead of a folder with .maxpat and supporting files. I am not comfortable posting the .app because it isn’t mine.

I am posting here because, after several back and forth emails, I don’t think this composer believes me. While I can make .maxpat files work by control-clicking and choosing “open with”, it isn’t an elegant solution, and I am worried about interruptions in what should be a seamless performance situation.

Thanks for your time and expertise!

#64824
Oct 18, 2012 at 1:55pm

Try “Open With/Other…” (context menu – use option-click on the file icon to show it), select Max (or MaxRuntime) and don’t miss the “Always open with” checkbox.

#233750
Oct 18, 2012 at 2:22pm

Thanks. I did this, but the new .app overrides my choice every time. That’s why I’m wondering if it is something in the application itself.

#233751
Oct 18, 2012 at 2:33pm

Argh… I face this problem a year or two ago. Every application made from max project was trying to open other max project as default application… But solution I mentioned was ok (even if all application made from max patches are still available from “Open With/Other…” menu).

Maybe some voodoo: try temporary remove the problematic project (eg. compress it to zip and delete noncompressed version). Try to open your max projects (max should return as default app), maybe use “Open With/Other…” again, and decompress the problematic application.

Hardcore version is to deinstall and install Max again. I did something like that, and it’s work. Hmmm… should make notes every time, when I’m fixing something. Anyway: good luck.

#233752
Oct 19, 2012 at 8:53am

I have a similar though less extreme issue. It sometimes occurs when I have a standalone Max app already open. When I double click a .pat or .maxpat file in Finder it opens in the standalone app instead of Max. Open With/Other… does work for me in such a case.

#233753
Oct 19, 2012 at 6:17pm

Correction: it’s my .maxhelp files that open in a standalone app

#233754

You must be logged in to reply to this topic.