Arduino2Max

Jan 14, 2009 at 12:17pm

Arduino2Max

Hi

Im using the Arduino2Max patch to drive the jit.pwindow visualization with an IR sensor.

The patch works fine when using one IR sensor, but I want to now add a further 2 sensors so that I have 3 in total. I have connected the 1st and 2nd sensors to my Arduino board via a breadboard, and have independant readings from each sensor on pins 2 and 3.

I then copied the whole of the original patch, and replaced the pin 2 input reading to the pin 3 input reading, expecting the new visualization to react to the 2nd sensor.

The problem is that now both patches react to the inputs from both sensors, so they look exactly the same, and obviously I want each visualization to react only to its corresponding sensor.

Any ideas?

Thanks alot

Rich

#41676
Jan 14, 2009 at 12:19pm

(here is the patch)

#148542
Jan 14, 2009 at 1:22pm

this might be a question for the arduino forum… it sounds like you need to
change the ‘output’ part of your program in the arduino code.

although it is hard to say if you don’t put up your patch to look at

Cheers,

Carey

On Wed, Jan 14, 2009 at 7:17 AM, Richard Almond wrote:

>
> Hi
>
> Im using the Arduino2Max patch to drive the jit.pwindow visualization with
> an IR sensor.
>
> The patch works fine when using one IR sensor, but I want to now add a
> further 2 sensors so that I have 3 in total. I have connected the 1st and
> 2nd sensors to my Arduino board via a breadboard, and have independant
> readings from each sensor on pins 2 and 3.
>
> I then copied the whole of the original patch, and replaced the pin 2 input
> reading to the pin 3 input reading, expecting the new visualization to react
> to the 2nd sensor.
>
> The problem is that now both patches react to the inputs from both sensors,
> so they look exactly the same, and obviously I want each visualization to
> react only to its corresponding sensor.
>
> Any ideas?
>
> Thanks alot
>
> Rich
>

#148543
Jan 14, 2009 at 1:33pm

Thanks Carey,

I did upload my patch tho, just below my first post, does it not appear?

#148544
Jan 14, 2009 at 3:45pm

i only see one post

On Wed, Jan 14, 2009 at 8:33 AM, Richard Almond wrote:

>
> Thanks Carey,
>
> I did upload my patch tho, just below my first post, does it not appear?
>

#148545
Jan 14, 2009 at 6:54pm

Strange, what about now?

#148546

You must be logged in to reply to this topic.