Forums > MaxMSP

Arduino2Max

January 14, 2009 | 12:17 pm

Hi

Im using the Arduino2Max patch to drive the jit.pwindow visualization with an IR sensor.

The patch works fine when using one IR sensor, but I want to now add a further 2 sensors so that I have 3 in total. I have connected the 1st and 2nd sensors to my Arduino board via a breadboard, and have independant readings from each sensor on pins 2 and 3.

I then copied the whole of the original patch, and replaced the pin 2 input reading to the pin 3 input reading, expecting the new visualization to react to the 2nd sensor.

The problem is that now both patches react to the inputs from both sensors, so they look exactly the same, and obviously I want each visualization to react only to its corresponding sensor.

Any ideas?

Thanks alot

Rich


January 14, 2009 | 12:19 pm

(here is the patch)


January 14, 2009 | 1:22 pm

this might be a question for the arduino forum… it sounds like you need to
change the ‘output’ part of your program in the arduino code.

although it is hard to say if you don’t put up your patch to look at

Cheers,

Carey

On Wed, Jan 14, 2009 at 7:17 AM, Richard Almond wrote:

>
> Hi
>
> Im using the Arduino2Max patch to drive the jit.pwindow visualization with
> an IR sensor.
>
> The patch works fine when using one IR sensor, but I want to now add a
> further 2 sensors so that I have 3 in total. I have connected the 1st and
> 2nd sensors to my Arduino board via a breadboard, and have independant
> readings from each sensor on pins 2 and 3.
>
> I then copied the whole of the original patch, and replaced the pin 2 input
> reading to the pin 3 input reading, expecting the new visualization to react
> to the 2nd sensor.
>
> The problem is that now both patches react to the inputs from both sensors,
> so they look exactly the same, and obviously I want each visualization to
> react only to its corresponding sensor.
>
> Any ideas?
>
> Thanks alot
>
> Rich
>


January 14, 2009 | 1:33 pm

Thanks Carey,

I did upload my patch tho, just below my first post, does it not appear?


January 14, 2009 | 3:45 pm

i only see one post

On Wed, Jan 14, 2009 at 8:33 AM, Richard Almond wrote:

>
> Thanks Carey,
>
> I did upload my patch tho, just below my first post, does it not appear?
>


January 14, 2009 | 6:54 pm

Strange, what about now?


Viewing 6 posts - 1 through 6 (of 6 total)