Artifacts in Jitter when videoplanes overlap in Z space

Mar 27, 2009 at 3:12pm

Artifacts in Jitter when videoplanes overlap in Z space

So, I have a Jitter piece that I’m working on that has 30 videoplanes floating in space with automated camera movement (using line objects) panning through the space…. Things were fine when I was just using “pak position” to control the camera but I want the camera behavior to be more nuanced and had started using a “pak lookat”. Unfortunately now that I’ve started using “pak lookat” I am noticing white flickering horizontal lines and pixels flickering through the videoplane closest to the camera…. I’ve noticed this problem in the past when I was butting videoplanes up against one another, but these planes are definitely more than separated in this version and can’t figure out what’s causing this to come up…. Is there a different object/option that will eliminate this?

J

#43052
Mar 27, 2009 at 3:36pm

try increasing the polygon count with a “dim 40 40″ message to the videoplanes, or higher if you need

and enabling the depth buffer in the render object I think

#154262
Mar 27, 2009 at 4:26pm

i don’t think changing the dim will help this situation. sounds to me like you need to adjust your near_clip attribute to gl.render. but hard to say without seeing patch.

#154263
Mar 31, 2009 at 6:08pm

Thanks… it did end up being an issue with my near_clip settings… I’ve adjusted those and the issue has ceased… Thanks for the feedback, I thought that I’d left those settings in my patch, but had obviously deleted them at some point in my various iterations.

#154264

You must be logged in to reply to this topic.