Forums > MaxMSP

Artnet to E-Node 8 (Eletion)

July 6, 2012 | 3:21 pm

Hi there,
I try to control RGB LED stripes via MAX/MSP. The setup is: MacPro, MaxMsp 6, imp.artnet.controller v0.8, Ethernet to E-Node 8 (elation), via DMX to DMX512 Decoder with connected LEDs. The problem is, i can’t send any DMX messages to the e-node via artnet. I use the help-patcher and set the address of the e-node to: 2.0.0.250 (Subnet== 0, Universe == 0 and in the back there are three dials set on 2, 5, and 0)
The DMX512 is set to receive DMX, the address is 0.

I tried to address unicast 2.0.0.250 and to broadcast.
Is there anyone with some experience with a similar setup? In theory it should work. With my DMX Lightingdesk connected to the DMX-converter it works. So the problem is in the artnet part of my setup. Thnx 4 your help.
d


July 6, 2012 | 5:19 pm

Looking at the back of the unit here (http://www.elationlighting.eu/default/e-node-8-artnet-dmx-node.html), it seems to indicate the IP is 172.16.0.xxx (part of the private network 172.16 range), and the dials let you set the last byte of the IP. This is interesting as Art-Net devices should have addresses in the 2.x.x.x or 10.x.x.x range. Check your unit and try unicasting to 172.16.0.250 (if you’ve set the last byte to 250).


July 8, 2012 | 1:54 pm

Thanx David for your fast reply! I did exactly like you sugessted, but without any success.
The manual says, "For Artnet set the PCs IP to: 2.16.0.3 and Subnet Mask to 255.0.0.0"
I set the unicast_ip 2.16.0.250. How is net, subnet and universe influencing the setup? Everything is set to 0 in Max. The dials Subnet and Universe are set to 0 on the elation.


July 2, 2013 | 1:25 pm

Hi Dorneo,
did you solve the problem? I have the same problem.
thanks


Viewing 4 posts - 1 through 4 (of 4 total)