At long last: cv.jit 1.7.0 is out!

Jun 7, 2010 at 1:58pm

At long last: cv.jit 1.7.0 is out!

Hi all, this is to let you know that the latest release of the cv.jit object collection is out. I completely re-wrote the help files (all 54 of them) in Max 5. Comments were not showing properly due to some issue with double-byte characters.

I also managed to find the time to fix a few bugs (it turns out cv.jit.blobs.recon was partly broken), improve the performance of some objects (cv.jit.ravg, etc.) and even added a few new ones.

There is now a single external, cv.jit.opticalflow, that encapsulates not two, but four algorithms for estimating optical flow – including a bleeding-edge method by Gunnar Farnebäck.

There is also an object, cv.jit.touches, for tracking multiple similar-sized, non-overlapping greyscale/binary regions that was packaged with multi-touch interfaces in mind.

Lastly, I moved the main cv.jit site to my own domain, so please update your links!

For downloads and everything:

http://jmpelletier.com/cvjit/

(It appears that my site is blocked in China. If you’re in China and want to download cv.jit, try heading straight to sourceforge: https://sourceforge.net/projects/cvjit/ )

Cheers,

Jean-Marc Pelletier

#50781
Jun 7, 2010 at 3:51pm

Sorry ,but where is the cv.jit.flow.draw in the library?
thx

#182229
Jun 7, 2010 at 4:07pm

thanks alot!!

#182230
Jun 7, 2010 at 4:30pm

thanks)!

#182231
Jun 7, 2010 at 7:00pm

WOWZAAA thank youu Jean-Marc

#182232
Jun 7, 2010 at 7:51pm

wow, thanks for all your work on this. I think cv.jit.touches is exactly what I need for an IR LED camera-tracking project. Looks like this new object should do the trick, am very excited to try it out.

One problem though, when I open the cv.jit.touches help file, I get this error:

Error 14001 loading external cv.jit.shift

I’m on XP, Max 5.1.3, with the new 1.7.0 version of cv.jit. The cv.jit.shift.mxe is in the proper folder. Maybe it has a bad attribute argument? In the [p shift_boxes] it uses the object with the attribute @maxiters 1, if that helps.

Again, THANK YOU for all your work on this. It adds so much to the Max environment!

#182233
Jun 7, 2010 at 7:57pm

Great. Can’t wait to try it!!!

#182234
Jun 7, 2010 at 9:29pm

More testing, on my other machine I don’t get the cv.jit.shift loading error. Maybe my laptop is being cranky.

#182235
Jun 7, 2010 at 10:42pm

Thanks, Jean. One thing. I opened the optical flow help patch and it is saying that cv.jit.flow.draw doesn’t exist. cant seem to find it in the download package either. ??

#182236
Jun 8, 2010 at 2:00am

Okay, terribly sorry about that, but for those who can’t find cv.jit.flow.draw, please try downloading the files again. I just checked to make sure it’s there now.

Jean-Marc

#182237
Jun 11, 2010 at 4:45am

very awesome!

Just curious…why the change of visualization for things like the optical flow visualizers…the old method was a very easy way to demonstrate to student’s exactly what was going on but the hue/saturation method seems a little bit less intuitive..maybe it just takes some getting used to though..and I can always use my old help files if I need the old visualizer of course

#182238
Jun 13, 2010 at 1:25am

HI,

I think you may be right that showing each field separately may help explaining the output format to students. Personally, though, I came to prefer the new method a bit better. For one, it takes less space in your patch. For two, separating the fields tends to emphasize strictly horizontal and vertical movements, whereas hue+saturation shows clearly movement in all directions. It’s a method that crops up from time to time in the literature.

I think in the next update I might put back in something that does things the way of the old help patches.

Jean-Marc

#182239
Jun 14, 2010 at 1:33pm

Thanks so much for this. The garbled help patches were driving me squirrelly. :)

#182240
Jul 7, 2010 at 3:07pm

Hi seejayjames,

Did you ever figure out the problem? I’m having the same problem. Max finds the cv.jit abstractions and the cv.jit externals, but is unable to load the externals.

All cv.jit externals are giving me a “Error 14001 loading external cv.jit.xxxx”. Max finds the objects because it would say “cv.jit.xxx: No such object” otherwise. How come it is unable to load them?

I’m running Max 5.1.4 (demo mode for now) with cv.jit 1.7 on Windows XP.

#182241
Jul 8, 2010 at 1:53am

Hi,

I can’t reproduce the problem here. Error 14001 means that a DLL cannot be loaded. I’ll try to get my XP machine up and running to see if that’s where the problem is. Vista and 7 seem to work fine. Have other people had problems with XP?

#182242
Jul 12, 2010 at 5:27am

Hm, it was weird that my main machine loaded it OK but not my laptop. My laptop has later versions of Max and of the XP updates too… maybe something with that, but I’d have no clue where to look…

#182243
Jul 14, 2010 at 5:22pm

I solved my problem.

The computer I’m working on has quite a dirty state (used by a few research assistants), and it hasn’t been cleaned or installed for a while. I removed the older installed versions of Visual Studio and of .NET frameworks.

I’m assuming the problem was a simple DLL conflict with an older versions.

Thanks!

#182244
Jul 15, 2010 at 8:18pm

Ah, that’s probably what’s happening on my machine too. I know my laptop has a different .NET version than my main machine. So I’m assuming the cv.jit objects reference some DLL’s that are included in the .NET? Interesting to know some of the low-level details of all this… trying to wrap brain around…

#182245
Jul 19, 2010 at 8:46pm

nope… I didn’t find the problem after all.

I installed Max 5 and cv.jit on a friend’s XP machine and the same problem occured. He doesn’t have any Visual Studio installation, so it cannot be a DLL conflict caused by Visual Studio as I thought.

Which DLL could be problematic? Any hints would be helpful.

#182247
Aug 12, 2010 at 4:30pm

thanks a lot for the cv.jit package !

i also had the “Error 14001″ on one machine, installing the “Microsoft Visual C++ 2008 Redistributable Package” solved it for me ..

#182248

You must be logged in to reply to this topic.