Forums > Jitter

Atomos Ninja Star won’t capture video from Jitter or Isadora

August 8, 2014 | 11:57 am

I just purchased an ATOMOS NINJA STAR with hopes of capturing/documenting my video generated with Isadora and Jitter.

I am running Isadora on a 3.06 GHz Intel Core i3 with 8gb ram. The device takes a micro hdmi input, so I go from Thunderbolt-to-HDMI-to-micro HDMI via an adapter.

At best, I can capture 20 second clips before the Ninja Star loses it’s "lock" on the video stream. A tech support representative from Atomos told me that The Ninja Star (as well as other Atomos products) require a certain quality or consistency of video signal in order to capture properly. Isadora and Jitter do not output a signal that meets these requirements. The Atomos representative wasn’t well-versed in Isadora or max/msp/jitter, so I figured I’d put this up here and see what people have to say.

A couple interesting points/concerns:

1- The tech support representative said that ALL Atomos products essentially function in the same way. Has anyone successfully captured video from Isadora with a different Atomos product such as the Ninja Blade or Ninja 2?

2- The Ninja Star has no problem capturing my display in other instances. As I type this, I can record my display fine.

3- The Ninja Star did not properly capture from Jitter or Isadora, but failed with each in DIFFERENT ways. With Isadora, I would capture a maximum of 20 second clips. I noticed the "lock" would fail almost immediately after I full screen my video stage. The video on my display would not be affected. With Jitter, the Ninja Star negatively affects the quality and behavior of the imagery I am generating. The clips I capture will also be broken into chunks of generally 20 seconds or less. The quality of these clips is more varied than those from Isadora.

4- Can anyone recommend a method for capturing live video from Isadora and Jitter that will work, look as good as it does on my display, and not cost me over $1000? The only method I’ve tried that works is a Blackmagic Hyperdeck Shuttle with a DVI extender and an SSD. That’s more $$$ than I can spring for.

Thank you in advance to anyone who may offer any insight into this. (I also posted this on the Troika Forum)


August 8, 2014 | 8:42 pm

I own a first generation Atomos Ninja and have recorded 50+ hours of Jitter output at 720p60. I’m not sure what the rep was talking about, but there is no reason that your Ninja Star should have a problem with this. The issue has nothing to do with the "quality" of the Jitter or Isadora output, because the Ninja is syncing with the output raster of the graphics card itself.

That being said, I did have some issues with finding the right mini-Displayport to HDMI adapter that would form a stable lock with my Ninja at 720p60. I tried out three of them before I found this one, which has never caused me any trouble:

http://www.monoprice.com/Product?c_id=104&cp_id=10428&cs_id=1042802&p_id=5969&seq=1&format=2

This adapter gets power and also embeds audio in the HDMI stream via the USB cable, and therefore requires a free USB port on your computer. Once you select 720p at 60Hz in the Display settings panel you should see a lock on the Ninja.

One important caveat that you should know — if you’ll be recording audio as well as video, you will need to make sure that the USB audio output is set to 48kHz in your Mac’s Audio/MIDI setup, even if you are recording audio via the analog input jack. The Atomos tech I spoke with explained that the Ninja does not have an internal clock (or scaler), and therefore slaves to the video frame rate and that is embedded in the HDMI signal. On my Mac laptop the USB output defaults to 44.1kHz, which caused all kinds of havoc with my audio recordings. The Ninja expects 48kHz audio only, so it recorded audio files that effectively had the wrong sample rate header.

This was a huge annoyance, but ultimately it’s simple to prevent this by setting the USB port audio output sample rate to 48kHz. This has to be done for individual USB ports on your computer, you can’t just set it once and expect that it will always default to 48kHz.


Viewing 2 posts - 1 through 2 (of 2 total)