Forums > MaxMSP

AU DLS Synth, MaxMSP 5.08 and Snow Leopard

October 20, 2009 | 8:23 pm

hi,

I think I saw a post that whatever problem was with AU DLS Synth under Snow Leopard was fixed in 5.08.

In my system, midi (or at least output to the DLS Synth) stops working as soon as I insert an audio object in the patch:

– Pasted Max Patch, click to expand. –

(he! this looks cool…)

I am running OSX 10.6.1 on a 2.33 dual core Macbook and maxmsp 5.08

is it me?

thanks
Alex


October 20, 2009 | 9:51 pm

Works fine here, running the exact same config. Are you using a specific sound card?


October 20, 2009 | 9:54 pm

no, just what the laptop comes with.
did you try my patch?

thanks,
alex


October 20, 2009 | 10:11 pm

of course I tried the patch… but still, I can’t reproduce…


October 20, 2009 | 10:14 pm

well, then it’s me…

thank you for your support, Emmanuel
alex


October 21, 2009 | 12:16 am

I rebember in the old version you had to
make a trip first to the Midi setup dialog and assign letters to ports, but now this doesn’t seem to count anymore? No matter what letter I assign, even none, I’m still getting sound off of the internal synth… Is this normal?

Alex


October 29, 2009 | 2:53 pm

mystery solved…

if the I/O buffer suze in the DSP Status window is over 1024 then MIDI stops working. And it’s not osx 10.6 related, same thing happens in 10.5

alex


January 7, 2010 | 4:32 am

I’m running a G4 ppc 1.5ghz Max/MSP 5.1.1 O.S. X 10.5.8 and I’ve been dealing with this same problem for at least three weeks now and it’s been driving me crazy and max isn’t like standard apps where you can trash the preferences, this thread defiantly helped me out in figure out the problem even though there is no solution posted I know the problem, anyone please post the solution if you know one, i asked a few people I worked with but most don’t deal with MIDI in Max lol…. makes me feel like a dinosaur, but actually just lets me know how deep Max/Msp is you can swim on one side of the pool and never go to the other end to check the depth.

Thanks again alex


January 11, 2010 | 3:49 am

Doesn’t work for me either… this is a very weird bug. Why we can not play a MIDI note after all this great and advanced soft improvements?

MaxMSP 5.0.7 (38325)

Mac OS X 10.6.2
MacBook Pro
MacBookPro5,2
Intel Core 2 Duo
2,8 GHz

no errors in Max window.

Jordi


January 18, 2010 | 3:34 am

I am having the same problem for months now, but have not tried to solve it until now.. I see I have company..

Is this something that will be fixed ? I don’t use MIDI sounds often, but it is handy at times..

(OS X 10.5.8 running on a 2.16GHz Intel Core 2 Duo with 2 GB RAM)


March 4, 2010 | 2:37 am

O.k. here’s an update to the solution that’s been working pretty consistently for me, trash the Max/Msp audio preferences and throwing away preference folders from older versions won’t hurt either.

~user/library/preferences/Max 5 Preferences Folder/audioprefs.txt/CoreAudio@Built-in Aud.txt

the two preferences at the end are the one’s to delete to get the au player working again.

you guys let me know if it works for you also.


April 12, 2010 | 12:05 am

I can’t get this to fix, no matter how many threads I read with solutions.

One of my issues is that the files that people are saying are best to delete, are not even within my preferences folder. I believe that this would make the situation not even occur, but my mental logic to these kinds of situations has been known to be off.

Has anybody directly found the issue?


April 12, 2010 | 1:41 am

What version of Max and OS?
All works fine here – Max 5.1.3 , OS 10.5.8, 1.42GHz G4
Remember to stay up to date . . . Even though I’m not with my machine ;-}


April 12, 2010 | 4:46 am

Thanks, I had just found a thread saying that if you are running Mac OS X 10.6 or higher (Snow Leopard), than you need Max Msp 5.08 or higher to use AU DLS Synth. Which, I just realized it says at the top of this thread. I appreciate your help.


Viewing 14 posts - 1 through 14 (of 14 total)