audio + arduino in max

Dec 28, 2009 at 11:01am

audio + arduino in max

Heya,

Does anyone know why when you turn on the audio symbol it only produces a sine wave sound?? the test file [a music track] is in the same folder etc. It is an aiff.

Also does anybody have any idea how to get the arduino’s force sensitive resistor to activate the audio file using the serial object, or [I am guessing] the HI object may do the same job as serial?? Could be wrong there!

Any pointers?

Many thanks

A.

#47447
Dec 28, 2009 at 2:11pm

hi,

can you copy compressed and past your patch here ?
i could take a look at it

concerning the arduino, I never use it but I’ve see there are some externals and patches on maxobjects.com
moreover, arduino works well with Processing and it’s easy to send OSC between Processing and Max, so might be a solution

+
a.

#170718
Dec 28, 2009 at 4:32pm

heya heres the out put :

– Pasted Max Patch, click to expand. –
#170719
Dec 28, 2009 at 4:32pm

here is the aiff player

– Pasted Max Patch, click to expand. –
#170720
Dec 28, 2009 at 4:33pm

just so you know need to be open and with the dac on on the output

#170721
Dec 28, 2009 at 5:05pm

it works for me

did you check your DSP settings (valid driver, inputs and outputs) ?

#170722
Dec 28, 2009 at 5:16pm

it has picked up the audio interface I used and i re-set the output channels to 5&6 which is what the speakers come out of the interface and set them to the computers default output still nothing :S.

#170723
Dec 28, 2009 at 10:58pm

does your meters display some signal ?

try to track the issue from source to destination :
-start the DSP
-are your players sending some audio ?
to see that put a meter~ just after a player, load a file with “open” and start it with “1″
if you don’t see anything, your DSP might be OFF
– test the DSP with Audiotest in the extra menu
or your sfplay~ doesn’t output anything
– test with another file (a long and full one to see the modulation, meter~ are not very sensitive in their default settings)

if this works try, assume that your DSP is OK and your sfplay~ too, so the issue might be in the send~/receive~
- does your meter~ in the output patch display something ?
if no, try to make an abstraction, replace your send~ with an outlet and load your patch by typing its name in an object box (assume that the 2 patches are in the same folder), and don’t forget to plug your aiffplayer output to the meter~ and dac~.

if your master meter~ display some modulation, your patch works, but your sound card doesn’t, so recheck it another time and have in your mind that you can use [dac~ 5 6] to output on channels 5 and 6 and check the output channel patch

good luck

#170724

You must be logged in to reply to this topic.