Audio file pops

Dec 12, 2008 at 2:25am

Audio file pops

Why might fairly short (~350ms) audio files might snap/crackle/pop in a one-off playback situation? This isn’t necessarily in a MSP environment, but anywhere they’re played. I’ve checked the files–no distortion. I’m not looping and having an interpolation or bad loop point problem. I’m not overmodulating. Sometimes they playback just fine, other times not. Any ideas?

#41309
Dec 12, 2008 at 2:39am

On Dec 11, 2008, at 6:25 PM, Brennon Bortz wrote:
> Sometimes they playback just fine, other times not. Any ideas?

Are they all the same sample rate?

-C

Chris Muir
cbm@well.com

http://www.xfade.com

#146996
Dec 12, 2008 at 3:28am

Quote: Chris Muir wrote on Fri, 12 December 2008 02:39
—————————————————-

> Are they all the same sample rate?

Yep, all 44.1kHz. To clarify, sometimes one file cracks on playback, and at other times the SAME file doesn’t…

#146997
Dec 12, 2008 at 7:56am

#146998
Dec 12, 2008 at 8:09am

That’s what I’d assumed, Stefan. Any thoughts on where I might be able to
dig a bit deeper and find THE source of the problem, so that I can fix it??

#146999
Dec 12, 2008 at 9:32am

It could as well be a DC offset at the very end of your samples, or generally non zero crossing situations either or both at the beginning and end of the samples. check in peak.

jrp

#147000
Dec 12, 2008 at 10:02am

Unfortunately, that’s not it, either…

#147001
Dec 12, 2008 at 10:03am

I agree that it is a system-related issue somewhere…just not sure where to
check.

#147002
Dec 12, 2008 at 6:29pm

#147003

You must be logged in to reply to this topic.