audiounit~ public beta 3

Dec 6, 2010 at 1:22pm

audiounit~ public beta 3

This version of the audiounit~ object should fix the crashes reported when changing plug-ins. As before, this object requires at least Max 5.1.5 (though Max 5.1.7 is now recommended).

http://cycling74.com/download/audiounit~-20101206.zip

Cheers,
Tim

#53743
Dec 6, 2010 at 6:08pm

I just installed both Max 5.1.7 and the new audiounit~

Only 2 plugins work – AUPitch (Apple) and Fire.

All of the others just freeze some of the audio file playing through (or with the original help file, play the tone, un-pulsed from the tri~ 220 object in the [p pulse-generator]). Bypass has no effect.

I removed everything from the Components folder & restarted Max so only the Apple AUs appeared (where are they stored, btw?) – same thing. Only AUPitch works. I put the components back again. Same again.

Any suggestions? Thanks

Alistair
OS X.6.5, MacBook Pro late 2008

#193288
Dec 7, 2010 at 11:50am

fixed (trashed Max 5 Prefs folder)
apologies for wasted bandwith
A

#193289
Dec 7, 2010 at 6:46pm

Thanks for the follow-up, Alistair. Glad you got it working…

Seems like there should be some way of providing better feedback from audiounit~ when the plug-ins need to be re-scanned. I’ll have to think about that some more…

#193290
Dec 7, 2010 at 9:05pm

That confused me – the re-scanning seemed to be working (when I removed the contents of the Components folder, only the System (?) Apple AU plugs appeared in the list)…

#193291
Dec 9, 2010 at 10:52pm

WOW, you’ve cerainly improved AU for me…

Scanned 25 AUs that answer to the definition, but your “getpluginnames” command won’t get recognition of randomly chosen AU. Why?

I”m using 5.1.7, on OS 10.6.5.

Sometimes can’t get patch names of a synth I can bring up – but it makes sound!!

Didn’t crash.

#193292
Dec 10, 2010 at 3:36pm

Hi Ron,

I don’t think I understand. The “getpluginnames” message should return all of the plug-ins available for a given channel configuration. While the plug-in scan is running this list may be incomplete. Perhaps this what you are seeing?

If you have a particular synth plug-in that is not providing you with preset names, then please let me know what plug-in it is and we can try to follow-up from there.

Thanks

#193293

You must be logged in to reply to this topic.