auto-completion problem for standard max/msp objects

Nov 10, 2009 at 11:58am

auto-completion problem for standard max/msp objects

Hi,

I have had this problem for a while, thought it wouldn’t bother me but it has starting niggling away and slowing down my workflow Smile I am confused as to why I can’t see some standard max and msp object names appearing in the drop down menu when I start typing in the object box?? Things like cycle~, line~, metro and a host of other standard objects don’t drop down – I need to type them in fully. There is no problem with max finding these objects once they are typed correctly – however I did like having to only type one or two letters to get to the drop down menu.

Any ideas? I have set the file preferences correctly – with the application folder in there as well as other folders in which I have externals stored.

Thanks in advance,

Ben

#46379
Nov 10, 2009 at 2:10pm

Do try to harvest metadata again. Paste this into a max window and click it. I had some trouble with the autocomplete menu when I ran a second instance of Max before. The documents that contain these are in Cycling ’74/init in your Max folder.

– Pasted Max Patch, click to expand. –
#166970
Nov 10, 2009 at 9:21pm

Perfect, that fixed the problem immediately – thanks for this!!

#166971
Feb 5, 2011 at 9:57am

yeah !!!!!

#166972
Mar 26, 2011 at 10:32am

Thanks for this Bas, I was running into exactly this problem and your solution worked.

#166973
Apr 22, 2011 at 7:05pm

Hi,

I still have the same problems after using this db.reset method. I cannot see any autocompletion, although it had worked before. The “Object box autocompletion” is activated. What else do I have to consider?

Thank you!

#166974
May 22, 2011 at 10:44pm

Hi, I remember coming across this post a month ago, and I am now having the same problem.

The only change I’ve made to Max is setting the default grid size to a smaller grid for unlocked patches. Next thing I know, Max doesn’t auto-complete for new objects!

I hadn’t upgraded to 5.1.8 yet, so I was hoping that would help, but no luck.

I’ve tried the reset that Bas van der Graaff posted, but this still doesn’t solve the problem.

Do I need to delete a preference file maybe?

Thanks!

#166975
Jan 15, 2012 at 9:33pm

omg Bas thank you!!!!

#166976
Jan 15, 2012 at 10:07pm

Hi,

At first Bas’ reset didn’t work for me, but after restarting Max, i disabled and enabled autocompletion and now everything works again.

So anyhow, thanks Bas!

#166977
Jun 23, 2012 at 6:01pm

Great tip, thanks!

#166978
Sep 26, 2012 at 7:15am

Auto-completion fail strikes back. Neither the ; max db.reset nor the disable/enable tricks worked…

#166979
Sep 26, 2012 at 12:00pm

Fours hours later, after restarting quitting, etc and opening and working with max 5 (?) this finally works. But the behaviour seems a bit erratic. Let’s see if other users get the same problem. Does the database rest message need time to operate ?

#166980

You must be logged in to reply to this topic.