automating camera

May 16, 2008 at 3:50pm

automating camera

hi all, i tried passing camera & lookat values to jit.gl.render but get
jumpy motion.
i used a coll stuffed with those vlaues and banged in between erase and bang
to render.

#P window setfont “Sans Serif” 9.;
#P window linecount 1;
#P newex 17 209 33 9109513 r draw;
#P newex 21 172 66 9109513 jit.window test;
#P newex 19 235 222 9109513 jit.gl.gridshape test @automatic 0 @poly_mode 1
1;
#P flonum 329 96 35 9 0 0 0 139 0 0 0 221 221 221 222 222 222 0 0 0;
#P flonum 289 96 35 9 0 0 0 139 0 0 0 221 221 221 222 222 222 0 0 0;
#P newex 52 127 35 9109513 s draw;
#P toggle 156 71 15 0;
#P newex 157 92 27 9109513 gate;
#P flonum 251 96 35 9 0 0 0 139 0 0 0 221 221 221 222 222 222 0 0 0;
#P newex 228 112 84 9109513 pak lookat 0. 0. 0.;
#P newex 175 45 33 9109513 r draw;
#N coll cam;
#P newobj 175 70 53 9109513 coll cam;
#P button 306 134 15 0;
#P newex 307 153 42 9109513 t 0 clear;
#P newex 228 133 54 9109513 t b 1 l;
#P newex 228 203 27 9109513 int 0;
#P newex 256 231 77 9109513 pack 0 s 0. 0. 0.;
#P newex 250 179 27 9109513 + 0;
#N coll cam;
#P newobj 256 260 53 9109513 coll cam;
#P newex 22 150 140 9109513 jit.gl.render test @camera 0 0 6;
#P newex 22 97 70 9109513 t b b erase;
#P toggle 22 56 15 0;
#P newex 22 74 50 9109513 qmetro 40;
#P comment 323 134 100 9109513 reset writer;
#P connect 9 0 8 0;
#P fasten 8 0 6 1 233 226 305 226 305 177 272 177;
#P connect 6 0 8 1;
#P connect 6 0 7 0;
#P fasten 10 0 8 1 312 202 250 202;
#P fasten 10 0 6 1 312 175 272 175;
#P connect 14 0 4 0;
#P connect 14 0 9 0;
#P fasten 9 2 7 1 277 227 277 227;
#P connect 7 0 5 0;
#P connect 20 0 14 3;
#P connect 19 0 14 2;
#P connect 15 0 14 1;
#P connect 16 0 4 0;
#P fasten 3 2 4 0 87 122 27 122;
#P connect 3 0 4 0;
#P connect 23 0 21 0;
#P fasten 10 1 5 0 344 256 261 256;
#P connect 11 0 10 0;
#P connect 3 1 18 0;
#P connect 17 0 16 0;
#P connect 12 0 16 1;
#P connect 1 0 3 0;
#P connect 2 0 1 0;
#P fasten 9 1 6 0 255 169 255 169;
#P connect 13 0 12 0;
#P window clipboard copycount 24;

#37832
May 16, 2008 at 4:39pm

slide?
sorry if i’m missing something.

#130939
May 16, 2008 at 4:57pm

ye, i was lazy and tried a slidelist with default value of one which is not
enough.

thanks
may lolcats rain on your doorstep

On Fri, May 16, 2008 at 7:39 PM, Robert Ramirez wrote:

>
> slide?
> sorry if i’m missing something.
>

#130940

You must be logged in to reply to this topic.