Bad performance of key and keyup objects

Sep 21, 2010 at 11:42pm

Bad performance of key and keyup objects

Hey whats up.
I´m working on a patcher that interacts with my keyboard entries via the “key” and “keyup” objects. The thing is that when I press 2 or more keys at the same time, they get stuck. For example, I press the “Y” and “U” keys toghether and when I release them “Y” is still pressed for MAX.
Is there any solution to get a better performance?

#52416
Sep 22, 2010 at 12:04am

Could you send along a simple patch to show us what you mean? Also, always good to have your OS, computer model and version of Max…

-Ben

#188474
Sep 22, 2010 at 12:51am

I dont have the file with me right now, but i will be posting it soon.
I´m running MAX 5 (i dont remember wich exact version) on windows XP. My computer is a Dell Studio 1535 Laptop, 3GB RAM (and dont remember the CPU, but will be posting the missing info).

#188475
Sep 22, 2010 at 12:55am

Does it happen with all keys (any combo of 2 or more at once)? I remember having issues with the X and Y keys when Max Toolbox was running, as it uses them for object distribution in your patch. If you have it running, try it with it turned off and see if it makes a difference.

otherwise, the C74 folks will have to take it from there…

#188476
Sep 22, 2010 at 6:19pm

are you using one keyup object per key?

#188477
Sep 23, 2010 at 2:02am

ok, this is the patcher:

– Pasted Max Patch, click to expand. –

im gonna look for key and keyup references in max help to see if is there any way to put one object per key as Roman says.

#188478
Sep 23, 2010 at 2:12am

i´ve tryed this:

– Pasted Max Patch, click to expand. –

…and doesnt make any diference.

#188479
Sep 23, 2010 at 11:40am

any ideas?
no one with the same issue?

#188480
Sep 23, 2010 at 2:17pm

Hello chouhy,

both patches works fine on my macbook OS 10.4.11 / max 5.1.5 ;

#188481
Sep 23, 2010 at 2:43pm

could it be a problem on my computer only?
im running max 5.0.7 in windos XP

#188482
Sep 23, 2010 at 3:52pm

Hello chouhy,

don’t know ; but it should be a good idea to keep max upgrade to last version (5.1.5) to benefit from last fixes …

#188483
Sep 23, 2010 at 4:33pm

Works fine here too, so definitely update to 5.1.5:

http://cycling74.com/downloads/

-Ben

#188484
Sep 23, 2010 at 9:45pm

Ok, i’ll be upgrading but i don’t think it’ll solve anything.

Ben, are you running max in a mac?

#188485
Sep 23, 2010 at 10:16pm

I run it all. Its like an OS museum over here.

-Ben

#188486
Sep 23, 2010 at 10:25pm

It could be that your keyboard has a crappy n-key rollover algorithm. Is there another USB keyboard you could try to see if the behavior is any different?

#188487
Sep 23, 2010 at 11:04pm

> “It could be that your keyboard has a crappy n-key rollover algorithm. “
> “Is there another USB keyboard you could try to see if the behavior is any different?”

I second this possibility. I tried few keyboards when i wanted to make polyphony on piezo-mic augmented computer keyboards, a while ago. Not a good idea, thru it can depend about the keyboard. On some keys/keyboards i had 5 voices of polyphony, on some others, it was weird, two special keys where not working together.

> ” Its like an OS museum over here. “

Wow, can we visit it ?

#188488

You must be logged in to reply to this topic.