Bang single letters out of textedit box, a la typewriter

Apr 18, 2009 at 4:46pm

Bang single letters out of textedit box, a la typewriter

I’m working on a project in which I’d like to enter a body of text in one textedit box.

After starting a metro, I’d like each letter of the body of text to flow into another textedit box. This way, I can get the ASCII numbers of each letter sequentially out of the second box to control some other stuff.

Basically…. I kind of need a typewriter “effect” – any thoughts?

Thanks!!

#43431
Apr 18, 2009 at 6:19pm

Would something like this work?

– Pasted Max Patch, click to expand. –
#155823
Apr 19, 2009 at 3:53am

Don’t forget [zl queue].

lh

– Pasted Max Patch, click to expand. –
#155824
Apr 19, 2009 at 5:26pm

Thanks for the reminder about [zl queue]. With the right output of that object counting down, you can even streamline it a bit further.

– Pasted Max Patch, click to expand. –
#155825
Apr 21, 2009 at 10:49am

This is my version of a type writer

– Pasted Max Patch, click to expand. –
#155826
Apr 21, 2009 at 2:32pm

These are all fantastic! Thanks so much for your replies – These should work perfectly.

Thanks again!

#155827
Apr 21, 2009 at 5:22pm
stefantiedje wrote on Tue, 21 April 2009 03:49
This is my version of a type writer

Leroy Anderson would be proud! Smile

#155828
Sep 15, 2012 at 9:22am

Know this is an old thread but I’ve tried stefan patch and get a problem with it. If I type a new text, the first time I bang it out, the first lettre is repeated, and I don’t find where this comes from.

#155829
Sep 17, 2012 at 8:38am

Anyone ?

#155830
Sep 17, 2012 at 11:32am

For me it works perfect.
I think you send two bangs to textedit.
how do you trigger it? try to trigger manually and see what happens.

best

#155831
Sep 17, 2012 at 4:20pm

Ok, so I’ve tried it again. It works perfectly in max 5 but in max 6, it exhibits the behaviour I describe. Can someone please confirm this please ? If I type a new text, the first time I bang it out, the first letter is repeated. From the second time on, it works ok.

#155832
Sep 17, 2012 at 5:30pm

I see the same behavior with Max6 on a PC. The first character is repeated for next text.

Best regards,
Michael

#155833
Sep 17, 2012 at 5:31pm

Whoops, I meant to type “new text.”

Best regards,
Michael

#155834
Sep 18, 2012 at 6:21am

Michael, please what is you version exactly ? I’ve sent a bug report to Cycling but they can’t reproduce this with 6.07. Which I can’t install because the installer doesn’t work for my os.

#155835

You must be logged in to reply to this topic.