Forums > Max For Live

Best method for tight syncing to Live transport in M4L

November 16, 2012 | 6:45 pm

Hello.

I have tried a few methods for syncing to lives transport but they all seem to have timing problems. Locked Phasor toedge, metro at 16n or ticks, reading the ticks from an observed transport but all seem to be very loose when connected to a counter. It always seems to need a few restarts in order to lock in. Once it is locked it is usually okay but then when I restart I have to do it again.

Does anybody have a sure fire way for tight sync to Live transport. Just something simple that I can re-use.

Thanks


November 17, 2012 | 6:11 am

you want ableton to be the master? what are you syncing?


November 17, 2012 | 12:20 pm

plugsync~ ?


November 18, 2012 | 1:11 am

I want Ableton to be the master. I am creating sequencers in M4L and sending it out but I seem to have a lot of problems with timing. It just seems sloppy. I was wondering if somebody could post a method of slaving M4L’s [counter] to lives transport. I can do it but it tends to be sloppy. I wonder what other people do to get tight timing.

Alfonso I’ll try plugsync~.


November 18, 2012 | 1:13 pm

Basically, plugsync~ allows sample accurate synchronization.
I’m using it to build counters for any bar division in the range 1-128.

– Pasted Max Patch, click to expand. –

November 19, 2012 | 7:40 pm

Thanks for the patch Broc… I’ll check it out later when I am on my computer. I am using it to make a Lemur controlled sequencer/processing device for the AcidLab Miami 808 clone… so tight timing is important.


November 20, 2012 | 12:39 am

I made the guts of the drum sequencer (patterns from a list, accents, repeats with vel sen). The timing is a lot better. Cheers.

I wonder would anybody have any idea’s how to get swing on to it. I usually use the old delay bang trick, it’s simple but it’s never great.

– Pasted Max Patch, click to expand. –

December 11, 2013 | 3:33 pm

hey, i’m trying to achieve about the same thing with a ‘metro 16n @active 1 @quantize 16n’ together with a counter object to create a sequencer.

I’m running into the same sync problems when the counter is enabled. Did you ever got it right?


February 27, 2014 | 6:40 am

I think this is a Ableton Live bug. And in my opinion very critical.
It seems by default everything is instantiated in 4/4, if the music is always in this time signature no one will ever notice this problem. But there is very easy steps to recreate this problem, and all objects that lock to the transport seems to fail: plugsync~, transport, phasor~, etc, etc.

1) Changing time signature somewhere in the middle of the bar (with markers or manually);
2) Dropping your device at some point in the middle of the sequence/bar with a time signature different from 4/4;
3) start playing in the middle of a bar after dropping the device, more or less the same as previous;
*Usually everything resets when the playhead crosses a time signature marker.
**property resetbarcount from transport turns always off in M4L environment.

The problem seems to be internal to the timing system of Ableton, I don’t think there’s anything we can do with max patches to solve it.
I hope they address this issue ASAP.


Viewing 9 posts - 1 through 9 (of 9 total)