Big problems with graphics on dual-card laptop

Mar 20, 2009 at 3:51am

Big problems with graphics on dual-card laptop

I’d been having persistent problems with low frame rates in Jitter 1.7, esp compared to what I could manage in Max 4.6 and Jitter 1.6

I am using a Lenovo W500, which has Intel graphics (Mobile Intel 4 series) AND ATI graphics (FireGL 5700), hot switchable. OS is Vista Ultimate. It’s kind of annoying that I can’t get Jitter working to its full potential, given that I bought this laptop especially for video processing!

I would very much like for this work!

With most of my patches I get an error along the lines of “jit_gl_support_init: float pixel formats: GL Error: Invalid enumeration”

I decided to test both ATI and Intel modes, using Vade’s Jitter Optimization patches (http://abstrakt.vade.info/?p=147), and here are my results. Basically, only the Basic patch using Intel graphics was free of errors.

Using ATI graphics

1 – Basic, 22 fps, jit_gl_support_init: float pixel formats: GL Error: Invalid enumeration and weird black stripes (http://www.villamil.org/images/ATI%20-%201%20-%20basic.jpg)
2 – Direct to Window, no motion
3 – CPU side UYVY, 22 fps, jit_gl_support_init: float pixel formats: GL Error: Invalid enumeration
4 – GPU Basic, 60 fps, jit_gl_support_init: float pixel formats: GL Error: Invalid enumeration
5 – GPU UYVY, 60 fps, jit_gl_support_init: float pixel formats: GL Error: Invalid enumeration
6 – GPU – Synced with Movie, 24 fps, jit_gl_support_init: float pixel formats: GL Error: Invalid enumeration

Using Intel graphics

1 – Basic, 22 fps
2 – Direct to Window, black screen
3 – CPU side UYVY, 22 fps, jit.gl.texture: setting texture wrap mode s: GL Error: Invalid enumeration (repeated)
4 – GPU Basic, 60 fps,

jit.gl.render: warning: OpenGL version 1.2 or higher is required.
jit.gl.render: Some rendering functions may be impaired.
jit.gl.render: Please consult your graphics card manufacturer for upgrade info.
jit.gl.texture: setting texture wrap mode s: GL Error: Invalid enumeration
jit.gl.texture: setting texture wrap mode t: GL Error: Invalid enumeration
jit.gl.texture: setting texture wrap mode s: GL Error: Invalid enumeration
jit.gl.texture: setting texture wrap mode t: GL Error: Invalid enumeration

5 – GPU UYVY, 28 fps,

jit.gl.render: warning: OpenGL version 1.2 or higher is required.
jit.gl.render: Some rendering functions may be impaired.
jit.gl.render: Please consult your graphics card manufacturer for upgrade info.
jit.gl.readback: unable to create framebuffer: pbuffers not supported!!
jit.gl.readback: error initializing framebuffer: framebuffer objects not supported!
jit.gl.readback: unable to create framebuffer: pbuffers not supported!!
jit.gl.readback: unable to create framebuffer: pbuffers not supported!!
jit.gl.texture: error creating readback mechanism for capture!
jit.gl.texture: setting texture wrap mode s: GL Error: Invalid enumeration
jit.gl.texture: setting texture wrap mode t: GL Error: Invalid enumeration
jit.gl.shader: graphics hardware is not capable of running CG vertex programs.
jit.gl.shader: graphics hardware is not capable of running CG fragment programs.
jit.gl.shader: CG not supported for current hardware config.
jit.gl.shader: unable to load program!
jit.gl.shader: unable to find usable language implementation.
jit.gl.shader: error loading shader!
jit.gl: invalid extension called
jit.gl: invalid extension called
jit.gl: invalid extension called
jit.gl: invalid extension called

6 – GPU – Synced with Movie, 24 fps

jit.gl.render: warning: OpenGL version 1.2 or higher is required.
jit.gl.render: Some rendering functions may be impaired.
jit.gl.render: Please consult your graphics card manufacturer for upgrade info.
jit.gl.readback: unable to create framebuffer: pbuffers not supported!!
jit.gl.readback: error initializing framebuffer: framebuffer objects not supported!
jit.gl.readback: unable to create framebuffer: pbuffers not supported!!
jit.gl.readback: unable to create framebuffer: pbuffers not supported!!
jit.gl.texture: error creating readback mechanism for capture!
jit.gl.texture: setting texture wrap mode s: GL Error: Invalid enumeration
jit.gl.texture: setting texture wrap mode t: GL Error: Invalid enumeration
jit.gl.shader: graphics hardware is not capable of running CG vertex programs.
jit.gl.shader: graphics hardware is not capable of running CG fragment programs.
jit.gl.shader: CG not supported for current hardware config.
jit.gl.shader: unable to load program!
jit.gl.shader: unable to find usable language implementation.
jit.gl.shader: error loading shader!
jit.gl: invalid extension called
jit.gl: invalid extension called
jit.gl: invalid extension called
jit.gl: invalid extension called

#42934
Mar 20, 2009 at 4:34pm

Seems like either your driver is not supporting recent OpenGL versions or somehow Jitter is not appropriately detecting it. To find out what you have, you can use some apps form GLEW:

http://glew.sourceforge.net/index.html

It will tell you driver, OpenGL version, extensions supported etc. If it says you in fact do have an opengl version > 1.2, then something is amiss and you should contact support@cycling74.com

wes

#153805
Mar 20, 2009 at 5:54pm

Thanks for your reply!

I’ve checked with OpenGL extension viewer, and OpenGL2.1 is fully supported. See: http://www.villamil.org/images/openglver.jpg

After all the, the GL in FireGL stands for something…

I’ve sent a message to support.

#153806
Mar 22, 2009 at 10:23am

I have a feeling that they screwed up with openGL in max5, i also get no hardware acceleration and the same errors on the secondary monitor on both my laptop and desktop. Respectively Nvidia GeForce Go 7700 and Nvidia GeForce 7950 GT. Both in max 4.6 worked fine.

Please GPVillamil forward here if you get feedback from the support. TY

#153807
Mar 22, 2009 at 10:52am

Wait, i fiddled with my graphics card control panel and managed to get acceleration, on nvidia control panel the setting is called MULTI-DISPLAY/ MIXED-GPU ACCELERATION -> set to Compatibility performance mode. Dunno for ATI cards.

#153808

You must be logged in to reply to this topic.