Forums > MaxMSP

Birectional communication with Max/msp and Lemur (ipad)

November 25, 2012 | 7:25 am

Hopefully this is just something obvious I’m missing, seems to always take me a couple of goes to get bidirectional data flows working (started with a monome).

I’ve got data flowing fine from Lemur into max/msp, but I’m having trouble getting data back to Lemur. I’m using a fader in lemur to send data values into max. Now all I’d like to be able to do is send data values back to the fader from max/msp, but I’m not having any luck.

I assume that I’ve got issues with IP addresses and port numbers, and this is where I get a little confused. I’ve never really had this process explained to me :)

I’m using port 8000, as it was recommended in the lemur manual. I’ve set up a wireless network on my laptop called ‘ToddAK’ on channel 11 (very imaginatively named, I know).

I’ve attached the brief patch below to show how its set up at the moment. When I move the slider in Lemur, the number box on the left moves. When I press the message boxes on the right hand side, the number box on the left changes values, but lemur doesn’t move. I assume this is because I’m not actually sending data to the lemur at all, and that I’m just sending it back into the patch again. Is that right?

And if so, where do I send the data to? Does Lemur listen and receive on different ports?

Many thanks in advance :)

– Pasted Max Patch, click to expand. –

November 25, 2012 | 12:56 pm

Can you ping your ipad?
I think it should be the Ip thats wrong, you are using Toddak.local wich is as you said your router right? not your ipad.
To try out if it works you could do the following:
In the lemur Editor, if you press the button Lemur connect, a little window opens showing your Ipad + IP and port, right?
Use this IP and the port 8000. (not 8001)
for the future i recommend setting up a static IP both for your Ipad and your host computer. Makes life easier.
Cheers


November 30, 2012 | 2:09 am

Aaah. Thanks woyteg.
I was experimenting using IP address, but it kept changing… makes sense as to setting up a static IP.
So, I assume I’d set up the lemur to send to the Mac’s IP, and vice versa, all on port 8000 then?


Viewing 3 posts - 1 through 3 (of 3 total)