Forums > Jitter

bitmap raster doesn't load correctly in jit.qt.movie

September 9, 2006 | 10:50 am

Hello,

I’ve got a spot of trouble using a bitmap for jit.op manipulations.

I’ve started trying to make use of a bitmapraster(bmp) which is in a
sense a large checkerboard black and white. I wanted to use jit.op to
multiply the raster with a movie to get a checked output.

When i read the file I get only vertical black and white lines and not
the checked pattern. Is this a feature of qt.movie? :)

Thanks for tips how to solve this.


September 9, 2006 | 10:54 am

Send more information, like a link to the file you’re having problems
with, the versions of Max and Jitter you’re using and your OS? Even
better:

BUG REPORTING GUIDELINES

Please report any problems you experience with clear and complete
information, including steps to reproduce, software and system
information, and where possible, an isolated example patch and crash
log. Something like the following would be ideal. This makes it
easier for us to find and fix the problems you experience. Without
such clear and complete information, it is less likely we will be
able to.

Summary:
Provide a descriptive summary of the issue.

Steps to Reproduce:
In numbered format, detail the exact steps taken to produce the bug.

Expected Results:
Describe what you expected to happen when you executed the steps above.

Actual Results:
Please explain what actually occurred when steps above are executed.

Regression:
Describe circumstances where the problem occurs or does not occur,
such as software versions and/or hardware configurations.

Notes:
Provide additional information, such as references to related
problems, workarounds and relevant attachments.

jb

Am 09.09.2006 um 12:50 schrieb Maarten Zeinstra:

> Hello,
>
> I’ve got a spot of trouble using a bitmap for jit.op manipulations.
>
> I’ve started trying to make use of a bitmapraster(bmp) which is in a
> sense a large checkerboard black and white. I wanted to use jit.op to
> multiply the raster with a movie to get a checked output.
>
> When i read the file I get only vertical black and white lines and not
> the checked pattern. Is this a feature of qt.movie? :)
>
> Thanks for tips how to solve this.


September 9, 2006 | 11:38 am

Steps to reproduce (I use a powerbook g4 10.4.7)
Use the included file.
Open jit.qt.movie and read the file.
Watch the result in pwindow.

Look at the file in preview/photoshop

See the difference.

The file is a checkerboard but only vertical stripes appear in the qt.movie.


September 9, 2006 | 11:48 am

Forget some more specs

jitter 1.5.2
maxmsp 4.5.5
QT installed 7.1.2


September 9, 2006 | 11:49 am

The only problem here is that you aren’t setting the dimensions of
the jit.qt.movie / pwindow objects to match that of your bitmap.
"jit.qt.movie 720 480" + a pwindow at 720×480 demonstrates that the
file is being read properly. You can also use jit.qt.movie’s @adapt
to auto-adapt the object dims to the data being read.

jb

Am 09.09.2006 um 13:38 schrieb Maarten Zeinstra:

> Steps to reproduce (I use a powerbook g4 10.4.7)
> Use the included file.
> Open jit.qt.movie and read the file.
> Watch the result in pwindow.
>
> Look at the file in preview/photoshop
>
> See the difference.
>
> The file is a checkerboard but only vertical stripes appear in the
> qt.movie.
>
>
>


September 9, 2006 | 11:54 am

Now I feel a bit silly :) Should have thought about that

Thanks


Viewing 6 posts - 1 through 6 (of 6 total)