@blend_enable and windows 7

Feb 5, 2010 at 6:37pm

@blend_enable and windows 7

hi all.

i’m porting an older patch to windows 7 for the first time and i’m having some trouble.

toggling blend_enable on the two videoplanes in the patch below makes them vanish. is there a known workaround to this?

max 5.1.2, windows 7, newest quicktime, running on a macbook pro in bootcamp with an nvidia card.

many thanks in advance.

– Pasted Max Patch, click to expand. –
#48261
Feb 5, 2010 at 7:29pm

First suggestion: disable depth testing in your jit.gl.videoplane objects.

As mentioned before, depth buffers are not necessarily up to our control on windows, as under many circustances, they are always created by the driver regardless of our request. Whenever you want to do transparent, composited videoplanes, I’d recommend @depth_enable 0

#173569
Feb 5, 2010 at 7:48pm

both of the videoplanes in that example have @depth_enable 0 set. it’s still not working. setting it explicitly on the render object still doesn’t make it work. as soon as i set @blend_enable 1 on a videoplane, it vanishes.

#173570
Feb 5, 2010 at 8:11pm

aha. thank you luke. it would appear that jit.dx.grab on windows 7 outputs a blank alpha channel instead of a white one. using a jit.op @op ~ pass pass pass after the jit.dx.grab solves the problem in this patch.

#173571
Feb 5, 2010 at 8:21pm

Thanks for tracking down. We’ll look at enforcing a white alpha in a future update.

#173572

You must be logged in to reply to this topic.