Forums > Max For Live

bpatcher and live UI controls bug?

February 27, 2014 | 9:29 pm

Is there a limitation using Live UI controls in a bpatcher? I first noticed using a bpatcher with live.numbox. Loading a second instance of the bpatcher caused the patcher file and arguments fields to be greyed out. Sometimes Max will crash. I also get the same result with a live dial. I haven’t tested any others yet. Anyone else experience this? I’m really bummed as I need this to work for a patcher I’ve put a lot of time into.

BTW, should I post here or to the main Max forum? Not sure that this is a M4L specific problem.

Thanks!

 

 

Attachments:
  1. Screen-Shot-2014-02-27-at-9.17.07-PM

February 28, 2014 | 12:12 am

I’m not aware of such a bug – could post an example patch?


February 28, 2014 | 2:47 am

Sure. Save thebpatcher.maxpat somewhere in your path. (It’s only a live.dial and an outlet.) Then paste the following. You should see that instance 2 of the bpatcher has the patcher file and arguments attributes greyed out. At least I do (Max 6.1.6, 32-bit, OS 10.7.5).

– Pasted Max Patch, click to expand. –
Attachments:
  1. thebpatcher.maxpat

March 3, 2014 | 10:34 pm

Anyone have a chance to verify?


March 4, 2014 | 12:49 am

Hello,

Yes, i can reproduce this – but if you save the main patcher as a project, all is well again – still it seems odd.

Best,
Christian


March 5, 2014 | 7:55 am

Thanks for checking it out. Saving as a project does fix it. But AFAIK, you can’t do that for a Max for Live device, right?


March 5, 2014 | 8:00 am

Oh, you mean "Collect All and Save?" That did the trick. Thanks! Still would like to have it work correctly out of the gate…


April 20, 2014 | 7:23 am

Reproducible here – at least it appears to be the same problem. I am using Live UI devices (specifically faders) but I am not using this patch in M4Live. I have a number of instances of the same bpatcher already (and getting them in in was an issue to but I somehow managed it) but trying to add more, the grgument field is greyed out. There doesn’t seem to be any obvious reason or any easy way to ‘trick’ MAx in to accepting a new instance (which I vaguely recall doing last time). And FYI Saving as a Project did not resolve the issue… Unfortunate timing to be wrestling with this right now, but I guess there is never ‘a good time’…


Viewing 8 posts - 1 through 8 (of 8 total)