Forums > MaxMSP

Buffer~ issues

May 28, 2013 | 5:23 pm

I own Max/MSP Jitter 6 on a Mid Summer 2010 Macbook Pro. I am very new to Max/MSP. I am trying to get the Buffer~ to read a wav/aiff file, but am having trouble so far. I have tried messages like Read, Replace and I have also tried the OpenDialog object. Nothing has worked. I am lucky enough to get sound to play in sfplay~, but no luck with buffer~ Can anyone help me?

 


May 28, 2013 | 5:58 pm

Hi,

you can’t output any sound from the buffer~ object itself, you need to bind its name to another object to play samples it contains (play~, groove~…).


May 28, 2013 | 6:03 pm

Hi Elliot,

 

I understand you can’t output audio from the buffer itself. I am trying to get the buffer to read an audio file so that it can give me a waveform representation of it so that I can get the groove~ object to play it. Currently I am getting the error message  "buffer~: cannot open parser for this file" I don’t know what this means.

 


October 19, 2013 | 3:43 pm

Well i was just doing a very basic and simple little ‘sampler’ just to record a few ms of sound. Writing what’s stored in the buffer works, but when i want to load back what i wrote, it doesn’t, and i get ‘Buffer~ cannot open parser for this file’ error…
Tutor did exactly the same thing in the lecture and it worked just fine…


November 7, 2013 | 7:26 am

Could you post your code / patcher file. It would help us troubleshoot your problem.


Viewing 5 posts - 1 through 5 (of 5 total)