Buffer~'s number of channels not updated

Sep 3, 2013 at 7:32am

Buffer~'s number of channels not updated

With Max613 (OSX) when loading a mono or stereo file in the following patch, the number of channels of the buffer remains 4. This was not the case with Max6.0.8 and before (OSX). Can someone confirm this bug? I already contacted c74′s support twice but surprisingly never got any answer.

Thanks

<code>

– Pasted Max Patch, click to expand. –

</code>

#264104
Sep 5, 2013 at 7:44am

Nobody??!

#264369
Sep 10, 2013 at 9:18am

i can confirm that. It goes along other buffer deprecations of buffer since 608 : an other one i know is that it won’t read at startup an audio file drom disk which doesn’t have an extension and which name has been given to buffer~ as an argument.
I should provide an example of that..;

#264868
Sep 10, 2013 at 9:24am

<code>

– Pasted Max Patch, click to expand. –

</code>
test with 608 and 613. You’ll need the attached hanningaiff audiofile.

Edit : well even this forum isn’t happy with audio without extensions (file nor permitted “for security reasons”.) then just rename that hanning.aiff to hanningaiff and state your freedom of consciousness in front of the machine in affirming that yes, you want to get rid of the extension.

edit 2 – he not even wants an aiff file – damn informatic – zipped it.

Attachments:
  1. hanning.aiff_.zip
#264870
Sep 10, 2013 at 11:59pm

Vichung, thanks for confirming!

I can confirm your problem too (under OSX.6.8). Did you contact support? Did they answer back?

p

#264933
Sep 11, 2013 at 3:42am

hm, i don’t remember contacting support directly, though i had some feedback from c74 people on this forum ; but you’re right : it’s time for e-mail !

#264956
Sep 11, 2013 at 3:43am

(and, ehm, er, it’s vichug. Though that ‘n’ is quite fun.)

#264957

You must be logged in to reply to this topic.