Forums > MaxMSP

Buffir DryWet?

March 31, 2013 | 8:16 pm

Hy,

Im working on a buffir based filter, and it works.
I’ve tried to add my simepl dry-wet control to the end of the plug, but there are some problems.
The sound on 50% drywet sounds like flange/phase stuff. (I think its came from the delay beetwen the dry and the wet signal.)

Is there a way to adjust the convolution amount?


April 1, 2013 | 6:45 am

Thete is no way?


April 1, 2013 | 7:18 am

Delay the dry slightly to minimize the phase cancellation before the wet/dry mix.


April 1, 2013 | 10:22 am

I see.
So if the budder size is (for example) 300 samples, then I have to delay the dry signal with 300 samples?
That means that this (Ableton Live) device will make a 300 samples latency. Will Ableton compensate this automitacally?


April 1, 2013 | 8:21 pm

I’v tried it, delay with 200 samples, still flangin’, then a its almost good on around 50 samples…

Is there any way to make the two signals pefectly syncronized?


April 1, 2013 | 8:33 pm

Is there an object what measures the latency beetwen two signals? That could help me…


April 2, 2013 | 5:56 am

I’ve just noticed that a constant delay is not enough, cause the latency of the buffir~ depends on the CPU power, so I have to measure the latency and then delay the signal.


April 2, 2013 | 10:48 am

Nobody?
Maybe I have to think this in a different way.

Is there any way to control the efficiency of the IR in buffir~?


April 2, 2013 | 6:56 pm

Try posting your patch, maybe.


April 2, 2013 | 8:10 pm

You’re right!
Here is it!

Anyway. I’ve tried to put a "dry" IR with buffir to to the dry signal, but the phase is still exist :(

Attachments:
  1. IRTester.maxpat

Viewing 10 posts - 1 through 10 (of 10 total)