Bug in waveform~ ruler values.

Jul 14, 2008 at 10:23am

Bug in waveform~ ruler values.

Hi all.

I am desperate. I am 99% sure there is a major bug in the waveform~ object ruler. Look at the attached pics and you can see they numbers make no sense at all. I have put a lot of work into this software and it is totally useless if the waveform~ ruler is incorrect.

Any suggestions? Has anybody else noticed this?

Best,

Tim

[img]index.php?t=getfile&id=1802&private=0[/img]
[img]index.php?t=getfile&id=1803&private=0[/img]

#38875
Jul 15, 2008 at 12:57am

Hi Tim,

Can you isolate and send along a simple example patch that just displays the issue?

-Ben

#136023
Jul 15, 2008 at 9:18am

Hi Ben thanks for the speedy response.

Here is a simple patch and some screenshots of the bug using the same patch.

Hope it helps!

Best,

Tim

– Pasted Max Patch, click to expand. –

[img]index.php?t=getfile&id=1806&private=0[/img]
[img]index.php?t=getfile&id=1807&private=0[/img]

#136024
Jul 15, 2008 at 5:30pm

Hi Tim,

I can’t reproduce what your images indicate.

On my machine, waveform is accurately representing the values of the attributes you have set. You have Timing Units set to BPM, and the Ruler BPM is set to something like 20.122894.

Can you put up an example audio file somewhere for me to download?

Are you running Max 5.0.3?

-B

#136025
Jul 15, 2008 at 6:40pm

Hey Ben,

So i have replicated the bug on another computer. With an audio file you can download. It is not the only audio file that it happens with.

1. Open Max 5.0.3

2. replace buffer with 03.aif http://www.neongolden.net/media/03.aif

3. Zoom in to about bar 2.2

4. I get the same as the pic i attached earlier.

I really don’t have any idea why it is happening.

Let me know what you think.

Thanks again,

Tim

#136026
Jul 15, 2008 at 7:14pm

Tim,

Thanks for your persistence, i can see that there is something going on here. It seems like the math get a little funky when you use a bpm that has anything after the decimal seperator and you zoom in.

We will take a closer look.

-Ben

#136027
Jul 15, 2008 at 7:25pm

just to clarify, it doesn’t seem to happen with all decimal numbers, just some, and it doesn’t seem to happen with shorter audio files.

Again, i’ll pass it along.

-Ben

#136028

You must be logged in to reply to this topic.