[BUG] Max5 click on inlet to send message

Jun 7, 2008 at 2:32am

[BUG] Max5 click on inlet to send message

Hi everyone,

Hope this hasn’t already been reported. If so, my apologies.

I came across this today, actually while teaching the feature to a new Maxer.

In certain situations, sending a message via the new and extremely convenient “click on inlet -> select “Send Message” -> type message” feature seems to be buggy. Here’s an example patch walking your through it with the metro object. I’ve only tested this on Leopard. Can others confirm this behavior (see patch for explanation of exact behavior):

– Pasted Max Patch, click to expand. –

best,
Zachary

#38276
Jun 7, 2008 at 11:39am

On 7 juin 08, at 04:32, Zachary Seldess wrote:

>
> Hi everyone,
>
> Hope this hasn’t already been reported. If so, my apologies.
>
> I came across this today, actually while teaching the feature to a
> new Maxer.
>
> In certain situations, sending a message via the new and extremely
> convenient “click on inlet -> select “Send Message” -> type message”
> feature seems to be buggy. Here’s an example patch walking your
> through it with the metro object. I’ve only tested this on Leopard.
> Can others confirm this behavior (see patch for explanation of exact
> behavior):

Thanks for the report, there were a bug when the value was higher than
127. This is fixed fore the next incremental.

For your second issue though, the “Send Message” feature only send a
message to the left inlet, no matter what. So if you want to change
the speed, you can write “interval 500″ for instance in the send
message box.

ej

#133196
Jun 7, 2008 at 12:31pm

Ah, I see. I must have missed that detail in the documentation. So that shortcut only ever allows you to send a message to the 1st inlet, regardless of which inlet you actually clicked.

And the real issue is that all non-zero numbers above 128 did not start metro. Thanks for fixing it in the next incremental.

But I actually thought I was changing the interval when in fact I wasn’t. Thanks for the info.

Somewhat related to this (i.e. attribute names) – is there a way to have the object inspector display the attribute names by default (it is manually displayed by clicking the @ symbol at the bottom of the window). I get tired of clicking that button every time I open a new inspector. Couldn’t find a preference setting for this. Is it there somewhere?

best,
Zachary

#133197
Jun 7, 2008 at 12:44pm

On 7 juin 08, at 14:31, Zachary Seldess wrote:

> Ah, I see. I must have missed that detail in the documentation. So
> that shortcut only ever allows you to send a message to the 1st
> inlet, regardless of which inlet you actually clicked.
>
> And the real issue is that all non-zero numbers above 128 did not
> start metro. Thanks for fixing it in the next incremental.
>
> But I actually thought I was changing the interval when in fact I
> wasn’t. Thanks for the info.
>
> Somewhat related to this (i.e. attribute names) – is there a way to
> have the object inspector display the attribute names by default (it
> is manually displayed by clicking the @ symbol at the bottom of the
> window). I get tired of clicking that button every time I open a new
> inspector. Couldn’t find a preference setting for this. Is it there
> somewhere?

This is not saved in the preference, although it will remember that
the option is check for the all “session” (until you restart Max).

ej

#133198
Jun 7, 2008 at 1:43pm

“This is not saved in the preference, although it will remember that the option is check for the all “session” (until you restart Max).”

Not for me, unless – again – I’m missing something.

1. Create two objects
2. get info on one object and click the “@” button to display attribute names
3. select other object – the @ button must be clicked again. It doesn’t remember the setting
4. select the first object again – it also doesn’t remember the setting

Thanks for the help.

best,
Zachary

#133199
Jun 7, 2008 at 3:59pm

#133200
Jun 7, 2008 at 4:49pm

I haven’t tested on Win XP yet, but I can reproduce always on my MPB Intel Leopard 10.5.2 and Windows Vista Home Basic installs.

I have 5.0.2 installed on all platforms. Does anyone else have this problem? I’m surprised its’ working for you Emmanuel.

In fact, all I have to do (in Vista or Leopard) is:

1. make an object
2. open inspector
3. click the @ button to show attribute names
4. close the inspector
5. reopen the inspector for the same object, and the setting is forgotten

best,
Zachary

#133201
Jun 8, 2008 at 12:33pm

Can some other people please confirm this behavior. It seems very unlikely that it’s specific to my two computers. Cycling isn’t going to fix it if it’s just me, and apparently Emmanuel can’t reproduce on his machines. Again, do this:

1. make an object
2. open object inspector
3. click the @ button to show attribute names
4. close the inspector
5. reopen the inspector for the same object, and the setting is forgotten, requiring you to click teh @ button once again

Can anyone reproduce? Perhaps it’s a byproduct of some combination of global preference settings.

Zachary

#133202
Jun 9, 2008 at 12:41pm

#133203
Jun 12, 2008 at 4:02am

It forgets the setting on mine too, 5.0.0, XP. That would be nice if it remembered, I like having the attributes hideable, but for now I’d rather see them to learn the names better.

–CJ

#133204

You must be logged in to reply to this topic.