Bug MaxMSP5.0.6: sfplay doesn't mute~

Feb 27, 2009 at 1:56pm

Bug MaxMSP5.0.6: sfplay doesn't mute~

Hello,

I have a problem with sfplay~ which doesn’t respect [1 1]->mute~
instruction.

It is still playing after mute. I can stop the output with pass~ but it is playing (visible with probe and output position)

Here is a patch to test:
How to test:
1-open an audio file
2-switch on audio
3-start playing
4-mute/unmute and see the result. It is still playing.
Output is disabled by pass in inner patch, but it is playing.

Regards
Chris

– Pasted Max Patch, click to expand. –
#42557
Feb 27, 2009 at 2:50pm
kawkhins wrote on Fri, 27 February 2009 14:56
Hello,

I have a problem with sfplay~ which doesn’t respect [1 1]->mute~
instruction.

It is still playing after mute. I can stop the output with pass~ but it is playing (visible with probe and output position)

Here is a patch to test:
How to test:
1-open an audio file
2-switch on audio
3-start playing
4-mute/unmute and see the result. It is still playing.
Output is disabled by pass in inner patch, but it is playing.

AFAIK, mute never stopped sfplay~ from outputting signal. If you want a real muting mechanism you’ll have to use poly~, and probably also turn off snapshot~ when you mute.

#152313
Feb 27, 2009 at 3:33pm

ho… never noticed, I was optimizing my patch to mute all things not needed…

Is there any specific reason for sfplay~ not to respect mute~ ?
Are there some other objects like that ?
snapshot~
and ?

Should I put all the things I want to mute for saving CPU into poly ?

Regards
Chris

#152314
Feb 27, 2009 at 3:43pm

I don’t know why, but I feel a little upset since I know this…
Why so many inconsistencies in MaxMSP ?

In mute~ reference, it is said:
“…turns off the signal processing in all objects contained in the subpatch connected to the…”

At least, this should be changed.
“all but… objects”
Chris

#152315
Jun 23, 2009 at 10:32am

I don’t know if there are many inconsistencies, but I sure would like to get informed about the list of objects that are not supported by mute~, since because of this uncompleteness I thought it was working reversely as I told in recent post.

#152316

You must be logged in to reply to this topic.