[bug report CNMAT] smooth-biquad~ on intel

May 14, 2008 at 9:03am

[bug report CNMAT] smooth-biquad~ on intel

#37762
Jan 28, 2009 at 7:21pm

Yes, I have encountered the same. But I was not the Smooth biquad object. I used the CNMAT OSC-route object and for some reason every time i turned off my groove object the CPU went sky high. So I removed all my effect processing objects, like the regular biquad, some reverb effects, and then things was back to normal. I do not know what caused it, but reading your post made me think about the OSC object.

#130637
Jan 29, 2009 at 1:33am

Quote: Patrick Delges wrote on Wed, 14 May 2008 02:03
—————————————————-
> [smooth-biquad~] needs more CPU when its signal input is 0! This
> happens on intel, Max4 under OSX4 and OSX5. On a G5, the CPU%
> difference is much much smaller.
>

Intel is bad at at small numbers. Think of it as an artistic challenge. Why are you filtering 0′s anyway? You want a different 0?

Sorry. This sounds like a classic intel problem with denormal numbers* and we should be able to fix it soon in a new release. Thanks for the report.

mz

* http://en.wikipedia.org/wiki/Denormal

#130638
Jan 29, 2009 at 1:40am

Quote: Richardo wrote on Wed, 28 January 2009 11:21
—————————————————-
> Yes, I have encountered the same. But I was not the Smooth biquad object. I used the CNMAT OSC-route object and for some reason every time i turned off my groove object the CPU went sky high. So I removed all my effect processing objects, like the regular biquad, some reverb effects, and then things was back to normal. I do not know what caused it, but reading your post made me think about the OSC object.
—————————————————-

On the other hand, this *is* complete hooey.* It makes as much sense a a post about Yetis stealing your corn dogs. Check Patrick’s excellent bug report. I’ll need a patch to work on this one.

mz

http://en.wiktionary.org/wiki/hooey

#130639
Jan 30, 2009 at 12:12am

I think I have a fix for this, but it needs a bit of testing before I’m ready to release it. Hopefully I’ll have a new version up in a day or so, but it may take a bit longer for a Windows version.

JM

#130640
Jan 30, 2009 at 8:31pm

I’ve posted a fix for this on the CNMAT site:

http://cnmat.berkeley.edu/files/maxdl/OSX-MachO/smooth-biquad~_1.5.2.tar.gz

Unfortunately it’s only for Mac at this point, but I’ll try to get a Windows version released in the next couple of days.

Patrick: If you have the time to test this and let me know how it’s working for you, I’d appreciate it.

JM

#130641
Feb 3, 2009 at 3:04pm

On 30 janv. 09, at 21:31, John MacCallum wrote:

> Patrick: If you have the time to test this and let me know how it’s
> working for you, I’d appreciate it.

Sorry to answer so late (but hey, my bug report is from may 2008 ;-)

I don’t have time to test very deeply, but it seems to work fine for
me with 4.6.3 and 5.0.5 under OSX.5.6 on a MacBook Pro.

Thanks for the persistence!

Now that the regular [biquad~] is smooth too, I have to check which
one is the most efficient ;-)

_____________________________
Patrick Delges

Centre de Recherches et de Formation Musicales de Wallonie asbl

http://www.crfmw.be/max

#130642

You must be logged in to reply to this topic.