Forums > MaxMSP

Bug report: cursor doesn't change over panel lower right corner

May 29, 2007 | 9:22 am

Hi all,

This must be a (minor) bug: when I hover over the lower right corner of a panel, the cursor doesn’t change to the resize style.

When I then click the corner to actually resize the panel, the cursor does change.

Can someone confirm?

Max 4.6.3, Mac 10.4.8

Mattijs


May 29, 2007 | 12:05 pm

Sorry, some more info. This only happens when the panel is in the background:

#P user panel 30 38 128 128;
#X brgb 191 191 191;
#X frgb 0 0 0;
#X border 1;
#X rounded 0;
#X shadow 0;
#X done;
#P user panel 30 187 128 128;
#X brgb 191 191 191;
#X frgb 0 0 0;
#X border 1;
#X rounded 0;
#X shadow 0;
#X done;
#P background;

The top panel does show its resize cursor when you hover over the lower right corner, bottom panel doesn’t.

Thanks,
Mattijs


May 29, 2007 | 12:11 pm

This is not only the case with panel, but with all objects.

Guess it’s not too much of a problem once you know about it, but could be fixed nonetheless.


May 29, 2007 | 1:45 pm

tssj, Mattijs, is there maybe some kind of ‘most bugreports’-contest i didn’t know about? I guess your going for the first price: a free 5. upgrade!


May 29, 2007 | 3:23 pm

Quote: Berend wrote on Tue, 29 May 2007 15:45
—————————————————-
> tssj, Mattijs, is there maybe some kind of ‘most bugreports’-contest i didn’t know about? I guess your going for the first price: a free 5. upgrade!
—————————————————-

Yeah, now that they’re moving their office is a great time to score some points in the category ‘backlog’. ;)


May 30, 2007 | 6:21 pm

Mattijs Kneppers schrieb:
> This must be a (minor) bug: when I hover over the lower right corner
> of a panel, the cursor doesn’t change to the resize style.
>
> When I then click the corner to actually resize the panel, the cursor
> does change.
>
> Can someone confirm?

It’s not only panel, it seems a problem with most bigger sizeable UI
elements. Sometimes the cursor changes, sometimes not. I am living with
it for a while now…

Mattijs Kneppers schrieb:
> Sorry, some more info. This only happens when the panel is in the
> background:

For me its always on the lower panel of the patch you posted, no matter
if is in the foreground or not…

Stefan


Stefan Tiedje————x——-
–_____———–|————–
–(_|_ —-|—–|—–()——-
– _|_)—-|—–()————–
———-()——–www.ccmix.com


May 31, 2007 | 9:25 am

Quote: Stefan Tiedje wrote on Wed, 30 May 2007 20:21
—————————————————-
> Mattijs Kneppers schrieb:
> > This must be a (minor) bug: when I hover over the lower right corner
> > of a panel, the cursor doesn’t change to the resize style.
> >
> > When I then click the corner to actually resize the panel, the cursor
> > does change.
> >
> > Can someone confirm?
>
> It’s not only panel, it seems a problem with most bigger sizeable UI
> elements. Sometimes the cursor changes, sometimes not. I am living with
> it for a while now…

Me too, but I want to make sure that it’s on a list somewhere. It is an annoying little bug, probably easily fixed.

>
> Mattijs Kneppers schrieb:
> > Sorry, some more info. This only happens when the panel is in the
> > background:
>
> For me its always on the lower panel of the patch you posted, no matter
> if is in the foreground or not…

Really? As soon as I rightclick the lower panel and choose ‘Remove from background’ the cursor works correctly. Note: this is different from ‘Bring to front’. Which Max version are you on? Me: OS 10.4.9, Max 4.6.3

>
> Stefan
>
> —
> Stefan Tiedje————x——-
> –_____———–|————–
> –(_|_ —-|—–|—–()——-
> — _|_)—-|—–()————–
> ———-()——–www.ccmix.com
>
>
>
—————————————————-


June 1, 2007 | 4:55 am

Mattijs Kneppers schrieb:
> Really? As soon as I rightclick the lower panel and choose ‘Remove
> from background’ the cursor works correctly. Note: this is different
> from ‘Bring to front’. Which Max version are you on? Me: OS 10.4.9,
> Max 4.6.3

Ahh, I just tried "bring to front", didn’t realise you were talking
about the background. I just experience in general a little flakiness
with the cursor changes. Sometimes its not changing but would grab the
corner, sometimes it is changing, but moves the object etc…

Stefan


Stefan Tiedje————x——-
–_____———–|————–
–(_|_ —-|—–|—–()——-
– _|_)—-|—–()————–
———-()——–www.ccmix.com


June 1, 2007 | 8:23 am

Thanks for confirming.

I have the feeling that I have more problems with the cursor as well, but this seems the only clearly reproducable bug for now. Confirmed by Cycling?

Cheers,
Mattijs

Quote: Stefan Tiedje wrote on Fri, 01 June 2007 06:55
—————————————————-
> Mattijs Kneppers schrieb:
> > Really? As soon as I rightclick the lower panel and choose ‘Remove
> > from background’ the cursor works correctly. Note: this is different
> > from ‘Bring to front’. Which Max version are you on? Me: OS 10.4.9,
> > Max 4.6.3
>
> Ahh, I just tried "bring to front", didn’t realise you were talking
> about the background. I just experience in general a little flakiness
> with the cursor changes. Sometimes its not changing but would grab the
> corner, sometimes it is changing, but moves the object etc…
>
> Stefan
>
> —
> Stefan Tiedje————x——-
> –_____———–|————–
> –(_|_ —-|—–|—–()——-
> — _|_)—-|—–()————–
> ———-()——–www.ccmix.com
>
>
—————————————————-


June 1, 2007 | 9:12 am

On 1 juin 07, at 10:23, Mattijs Kneppers wrote:

> I have the feeling that I have more problems with the cursor as
> well, but this seems the only clearly reproducable bug for now.
> Confirmed by Cycling?

This is fixed in the next major update…

ej


June 1, 2007 | 9:27 am

Quote: Emmanuel Jourdan wrote on Fri, 01 June 2007 11:12
—————————————————-
> On 1 juin 07, at 10:23, Mattijs Kneppers wrote:
>
> > I have the feeling that I have more problems with the cursor as
> > well, but this seems the only clearly reproducable bug for now.
> > Confirmed by Cycling?
>
> This is fixed in the next major update…
>
> ej
>
—————————————————-

Great!

Mattijs


Viewing 11 posts - 1 through 11 (of 11 total)