Bug report. Since Javascript crash 3d models "can't be found"

Jul 13, 2013 at 5:36am

Bug report. Since Javascript crash 3d models "can't be found"

Hi Everyone,

I have a patch which loads 3d models and rums them through a jit.gl.slab . Nothing fancy.
I loaded up the javascript in Jitter shaders “Special FX/Blobby” Bam ! My entire mac froze completely. Had to restart. Now I get the error that Max can’t find the 3d models, they’re still in the same place, I can open them in blender.
When i click the message box ” read/object name ” I also get the error “Warning you have multiple files in your search path Folder name ”
The folder only has 1 copy of each model not two so thats confusing.
I removed and remade the file path with options/file preferences and also with dependencies, This is a real bummer as I have no idea what to do to fix it. I also loaded a backup file from last week and its the same problem so it can’t be that one max patcher file.
Do I have to reset the way Max looks at locations in its search preferences ? If so how ?
Any and all advice welcome.

#255885
Jul 13, 2013 at 5:39am

I also get the error “method getname called on invalid object”.

#255887
Jul 13, 2013 at 10:47am

Got it fixed. Uninstalled max 5 and 6, deleted preferences file in application support (mac osx.10.6) that didn’t fix it.
I finally found out that the “method getname called on invalid object” was on the jit.gl.model object (both of them).
So I deleted the name of the object “jit.gl.model” confirmed it. then re-typed the argument “jit.gl.model”.
Voila it worked ! I have no idea what changed but it’s fixed now :)

#255917

You must be logged in to reply to this topic.