Forums > MaxMSP

Bug report [Was: mystery object...]

February 10, 2006 | 4:57 pm

BUG REPORT

Summary: Typing /6 into an object box instantiates a random object

Steps: create new patch, click on 1st item in palette (object box),
drop it in the empty patch, type "/6" (w/out quote marks, no space
between chars), hit enter.

Expected result: error message in Max window "error: /6: No such object"

Actual result: an arbitrary object is instantiated.

Remission/discussion: seems to work with any digit. The assistance text
and the ctrl-opt-click (alt-right click) popup menu may identify the
actual object instantiated, which is different on different systems.
The character combination may seem unlikely, but is easy enough to type
if you miss the space bar while attempting to create a [/ 6] (division
by six) object. Judging by the discussion this has generated on the
Max/MSP list, the effect causes considerable confusion.

============

Deliberately relabeled the Subject: to something more catchy while
retaining threading-headers. Apols if you guys (and gals?) at support
get it twice. It would be nice to know if this is recognized as a bug
and has any priority whatsoever.

Thanks for your consideration,
Peter

————– http://www.bek.no/~pcastine/Litter/ ————–
Peter Castine | ^
| Litter Power & Litter Bundle for Jitter
pcastine@gmx.net |
pcastine@bek.no | iCE: Sequencing, Recording, and Interface Building
4-15@kagi.com | for Max/MSP
| Extremely cool
| http://www.dspaudio.com
| http://www.dspaudio.com/software/software.html


February 10, 2006 | 5:10 pm

Platform? Version of MaxMSP?

:)

I cannot duplicate this in the shortly to be released 4.5.7 version of MaxMSP on both platforms .Expect the update in the next week or so. Until then, enjoy it while it lasts!


February 10, 2006 | 5:45 pm

I can’t even reproduce using the currently released version of MaxMSP.
Seems like some of you may have poltergeists…

;)
AB


February 10, 2006 | 6:06 pm

I believe this is due to having the MySQL external installed?

I could be way off base though?

v a d e //

http://www.vade.info
abstrakt.vade.info

I LIVE! I LIVE! I LIVE! I LIVE! I LIVE! I LIVE! I LIVE! I LIVE! I
LIVE! I LIVE! I LIVE! I LIVE!

You will not be saved by the Holy Ghost. You will not be saved by the
God Plutonium.

In fact, YOU WILL NOT BE SAVED!


February 10, 2006 | 9:07 pm

On around Feb 10, 2006, at 18:10, Andrew Pask said something like:
> Platform? Version of MaxMSP?

I knew I’d forgotten something. Sorry.

OS X (10.3.9), Max 4.5.5. (still, must update…).

CC to Support, Andrew B. asked the same question (of course).

Add’l remission: since I was doing backwards-compatability testing with
4.1 anyway, I tried /6 there and got the expected "error: /6: No such
object"

Charlie, Alessandro and I seem to have in common that we use OS X and
have unusual custom (XCode-based?) externals installed. Of course, this
may be like the story about the mathematician, the physicist, and the
engineer agreeing that it was the water that was giving them their
hangovers.

Yes, it’s tempting to investigate ways to use this as some kind of RNG
(as Georg B. suggested), but it appears to not "work" with either XP or
Classic Mac OS.

Thanks — Peter

>
————– http://www.bek.no/~pcastine/Litter/ ————–
Peter Castine | ^
| Litter Power & Litter Bundle for Jitter
pcastine@gmx.net |
pcastine@bek.no | iCE: Sequencing, Recording, and Interface Building
4-15@kagi.com | for Max/MSP
| Extremely cool
| http://www.dspaudio.com
| http://www.dspaudio.com/software/software.html


February 10, 2006 | 9:47 pm

It’s crashing here as well. The crashing thread ends here:

Thread 0 Crashed:
0 ftm.aaa 0x0511e988 value_init + 88
(bundle1.s:283)

My guess is that this in my case is related to the Ircam FTM lib:

http://recherche.ircam.fr/equipes/temps-reel/ftm/index.html

Best,
Trond


February 10, 2006 | 10:11 pm

/6 in an object box earns me this:

FATAL: cannot find FTM external class: /6

I do have FTM installed. Max 4.5.7, OS 10.4.4

mzed


Viewing 7 posts - 1 through 7 (of 7 total)