building jit standalone jit.1.7 win errors

May 2, 2008 at 5:24pm

building jit standalone jit.1.7 win errors

hi List
I

#37479
May 2, 2008 at 5:34pm

#129563
May 2, 2008 at 5:35pm

#129564
May 2, 2008 at 9:53pm

hi wes,

thanks this fixed the texture error. I downloaded and included MSVCR71.dll and the externals work too. btw. this should at least be mentioned in a readme about making standalones on windows.
what I didn

#129565
May 3, 2008 at 7:44am

I just came across message #140375 in the Maxlist by DonK: he reported errors on making standalones on win in Demo mode. I don

#129566
May 3, 2008 at 5:45pm

What happened in XP when i saved as an executable was that non of the jitter libraries copied into the folder.

The first time I tried, Max5 was in demo mode (I mostly use my mac). I tried copying all the jitter libraries over to the exe’s folder (basically copied all the support folder .dll’s). On starting the app, there were a TON of jitter errors, and jitter windows and some graphic elements showed up in that grey striped pattern.

It was late, so i just went to bed and thought about it. The Mac has successfully compiled the same exact patch that only uses cycling’s objects. The only difference in installation was some 3rd party objects (which were not used), and authorization. I wondered if demo mode was the real difference. Sure enough, authorizing Max and saving the exe worked after it was authorized. I can’t remember for sure, but i could swear I still had to copy the .dll’s from the support folder. I never tried building an app in demo mode on OSX, so I don’t know if that’s the same.

speaking of spash windows, is there an easier way to change it other than opening up a resource editor?

#129567
May 3, 2008 at 9:06pm

Hi DonK,

Thanks for your reply, I checked again using this little patch I sent(see post 2 up or text below): I included all the dlls but no change: As soon as I switch on qmetro there will be jit.gl.render errors:
The funny thing is when I render into a pwindow it

#129568
May 5, 2008 at 8:22am

It seems to be a bug:

After some patching I solved the problem by simply adding a pwindow to the patch without any connections. Removing the window again will make the bug appear again.

falk

steps to reproduce:

1. open the patch below
2. build collective/application
3. add jit.openexr
4. build app
5. add MSVCR71.dll,jitlib.dll, cg.dll and cgGL.dll into the support folder
6. error: jit.gl.render: couldn

#129569
May 5, 2008 at 8:30am

#129570
May 6, 2008 at 9:37am

#129571
Dec 9, 2008 at 4:14am

I’ve been trying to create a standalone with Max 5.05 on Windows XP and the max window comes up when I start the standalone saying “jit.openexr: no such object” and then “jit.gl.texture: jit.openexr not found, openexr support unavailable”. The program then opens and works fine. But I’ve been trying to get rid of the error in the final standalone to be distributed. I was not using either of these externals as far as I knew but The Show Object arrow points to the cv.jit.centroids external that I’m using, so I assume it is using it internally.
I searched the forum and found this message, the one I am replying to (also quoted below). So I included the jit.openexr external and now I’m getting an alert box that says “MAXCRT_P.dll was not found – reinstalling the application may fix this problem”. Then the Max window comes up with an error 126 loading external jit.openexr. And the program still works correctly!
Can anyone shed some light on what I should try next? I don’t think I want to re-install the program…
Thanks, bob

——————-
>jit.gl.texture now depends on jit.openexr so unless you don’t want
that error, include it in your standalone. The reason for this change
was so that one could specify OpenEXR images in the JXS shader format
in order to have full floating point image files loaded automagically
by jit.gl.shader and jit.gl.slab.

wes

#129572

You must be logged in to reply to this topic.