Forums > MaxMSP

can waveform~display 2 channels in 1 window ?

December 15, 2012 | 3:58 pm

i built a small looper that uses a 2-channel buffer~. the associated waveform~object displays always only one channel (the left one…). if i have a stereo signal coming from the buffer this is ok. but if i have 2 mono-signals, the one of them (in channel1 of the buffer) is displayed, but the other one (buffer~channel 2) draws just a flat line in waveform~. is there a way to have 2 channels displayed simultaneously in ONE waveform~object or do i have to have one waveform~object for each channel ?
thanks already.
udo


December 16, 2012 | 7:18 am

If you open the maxhelp file for the [waveform~] object, you will see there is a tab called "Multi-Channel".

Hope this helps.


December 16, 2012 | 4:41 pm

thanks for the tip, but i did this already. and what they say is, basically, that you can switch the channel that is displayed in the waveform~object with a certain message. but then it is still only one channel at a time. and following that logic i would have to have 2 waveform~objects to display 2 channels. that is why i was asking if it is possible to have something like a "stereo mode" where you can see 2 channels in one waveform object. or maybe there is another object that would do this ?



jko
December 16, 2012 | 5:01 pm

Build yourself an abstraction like that: (to be used in presentaion mode)

– Pasted Max Patch, click to expand. –

December 17, 2012 | 3:53 pm

@jko : ah, ok, nice little workaround. i will try it out as soon as i have some time left. thank you !


December 25, 2012 | 9:16 pm

Here’s another way you might want to try doing this…

You’d still need two waveform~ objects, but…

– Pasted Max Patch, click to expand. –

Viewing 6 posts - 1 through 6 (of 6 total)