Can you turn off auto completion for message boxes?

Mar 7, 2013 at 2:28pm

Can you turn off auto completion for message boxes?

I guess the title says it all. I know of the option “Object Box Autocompletion” but that turns all auto completion on or off. Auto completion is obviously very useful when adding new objects; but it drives me completely insane when using message objects. Which I happen to use quite a lot.

Because the system keeps insisting to use specific words while I don’t need those at all. I would assume that pressing space would remove the selected contents of the message object with the space I just typed, but instead its used to confirm (complete) the suggested word.

For example; I have an empty patcher and I add a [live.path] object. Below it I add a trigger which listens for a list and a bang; “[t b l]“.

Now I want to add a message object below those two which contains “get name”. I press m, type ‘get’ and it immediately gets completed with “children” (for the ‘getchildren’ message which can be used on the [live.path]). I also have the option to select “getcount” or “getpath”.

Needless to say; I don’t want nor need that, I want to be able and type “get name” and nothing else. Yet when I do that I end up with “getchildren name”.

Sure; I could add a [live.object] first after which the auto completion would comply with whatever [live.object] needs. But that’s really not my point since I’m using message objects for many other purposes as well.

So; is there a way to easily overcome this auto completion madness when adding a message object ?

Thanks in advance for any tips you might have.

#66935

You must be logged in to reply to this topic.