cannot write to pattrstorage files in a Windows standalone — permissions?

Jul 8, 2010 at 6:28pm

cannot write to pattrstorage files in a Windows standalone — permissions?

List!

I’m working on a cross-platform standalone, and having problems getting my pattrstorage preference files to save under Windows. the .json files are inside the application itself, in the support folder — as I’m loading them manually, I know that the path to the folder I’m using(app_foldersupportdata) is being read by the patch, but I get a -1 error when a writeagain message is sent. Checking the properties of that folder, I noticed that it is marked read-only. After nosing around the internets for Windows, I changed variousl settings, only to find that once I closed the folder and reopened it, the read-only flag turned itself on again. Is there a workaround for this, or do I have to stick my settings files somewhere else?

I note that Windows has the “documents and Settings” folder — is that the place I have to write the .json files to? Or is there some trick to get my permissions change to stick?

Thanks,

M

#51283
Jul 9, 2010 at 10:03am

Hello,

Have a look at that thread :

http://cycling74.com/forums/topic.php?id=25895

léo

#183912
Jul 9, 2010 at 4:59pm

Thanks for the pointer, but I’m aware of all of those issues and I’m loading my .jsons manually and so forth. The Mac build has no problem storing settings changes — it is only the Windows build, which makes me think it may be an OS issue rather than a Max issue….

M

#183913
Jul 12, 2010 at 6:09pm

never mind — sorted it out…

m

#183914
Jul 22, 2010 at 5:06pm

I also had a similar problem. I tried everything to save my json files in Windows with no luck. Everytime I re-opened the program and sent the read command to pattrstorage with the correct filepath I could never read the file contents. I tried every syntax for the filepath with no luck (max version 5.0.7, WinXP-32bit). I sorted it out by changing the json files to xml. I had the exactly same problem on my MacPro, only that time I couldn’t save anything using xml, but instead I used json and everything worked.

So I guess if anyone has similar problems try changing json and xml files to see what works best for you.

Cheers!

#183915
Jul 22, 2010 at 7:12pm

Stav,

Again, please update to the latest version, 5.1.4. Send an email to support if you find that json file read/write does not work as expected.

-Ben

#183916

You must be logged in to reply to this topic.