Forums > MaxMSP

can't figure out my MIDI setup

November 26, 2007 | 6:00 am

Help! I’m trying to work my way through the tutorials and I can’t sort out my MIDI setup. I"m on tutorial 12.

My setup:
iMac 10.5
Max 4.6
Access Virus TI via USB

Max is receiving MIDI from the Virus, no problem…it’s doing so even when I had not assigned the Virus to Abbrev "a", which, to my understanding, it should actually NOT do since the tutorial patch specifies "notein a".

Furthermore, I can’t get any sound out of the Virus via Max. I set the Abbrev to A, no offset, turned off the other devices, made sure it set to receive channel 1…can’t get a thing.

Further weirdness: in Max’s MIDI setup window, I can deselect every input and output device, and Max is still receiving the note messages from the Virus’ keyboard.

Everything looks to be in order in the Mac’s MIDI Setup as well.

Any suggestions?


November 26, 2007 | 6:28 am

Hmmm…I can get sound out of the Virus by clicking the on-screen keyboard in MIDITester. Still can’t get notes out of Max, though.


November 26, 2007 | 6:49 am

got it by double-clicking on each note out object while locked and switching the output to the virus manually. should i have to do that when the virus is the only enabled output device in MIDI setup, or is this a OS 10.5 glitch?


November 26, 2007 | 9:27 am

Does your Virus work at all in X.5? I’ve read lots of complaints of
people using Logic/Leopard/Virus.
Don’t know if this is with all Virus models, or just with some.

Best,

Zip Boterbloem
Media Mechanics
Zwaluwstraat 54
2025 VR Haarlem
The Netherlands
+31627014758
zip@knoware.nl

Op 26-nov-2007, om 7:00 heeft Adam Barnett het volgende geschreven:

>
> Help! I’m trying to work my way through the tutorials and I can’t
> sort out my MIDI setup. I"m on tutorial 12.
>
> My setup:
> iMac 10.5
> Max 4.6
> Access Virus TI via USB
>
> Max is receiving MIDI from the Virus, no problem…it’s doing so
> even when I had not assigned the Virus to Abbrev "a", which, to my
> understanding, it should actually NOT do since the tutorial patch
> specifies "notein a".
>
> Furthermore, I can’t get any sound out of the Virus via Max. I set
> the Abbrev to A, no offset, turned off the other devices, made sure
> it set to receive channel 1…can’t get a thing.
>
> Further weirdness: in Max’s MIDI setup window, I can deselect every
> input and output device, and Max is still receiving the note
> messages from the Virus’ keyboard.
>
> Everything looks to be in order in the Mac’s MIDI Setup as well.
>
> Any suggestions?


November 26, 2007 | 9:44 pm

On 26 Nov 2007, at 06:49, Adam Barnett wrote:

> got it by double-clicking on each note out object while locked and
> switching the output to the virus manually. should i have to do
> that when the virus is the only enabled output device in MIDI
> setup, or is this a OS 10.5 glitch?

You can specify the device name in the noteout:

[noteout "Virus Synth or Whatever it is Called" 14]

(name followed by channel). This is safer than relying on any
implicit selection of device.

You can, of course, build menus of devices, but figuring out which
item to loadbang in brings you back to your original problem unless
you do it by name.

– N.

Nick Rothwell / Cassiel.com Limited
http://www.cassiel.com
http://www.myspace.com/cassieldotcom
http://www.last.fm/music/cassiel
http://www.loadbang.net


November 26, 2007 | 9:49 pm

Adam Barnett schrieb:
> got it by double-clicking on each note out object while locked and
> switching the output to the virus manually. should i have to do that
> when the virus is the only enabled output device in MIDI setup, or is
> this a OS 10.5 glitch?

I guess the midi documentation needs to be refurbished. They deal with
old OS 9 issues, though still functional, I never touched these a..
abbreviations since years. Instead have a look at midiinfo to see how to
set midiports nowadays.

If you do not specify a port, any receiving object like notein, ctlin
etc. will receive on all ports. But you can send only on one port, which
is by default the internal synth…

hth

Stefan…


Stefan Tiedje————x——-
–_____———–|————–
–(_|_ —-|—–|—–()——-
– _|_)—-|—–()————–
———-()——–www.ccmix.com


November 26, 2007 | 10:51 pm

Nick Rothwell schrieb:
> You can, of course, build menus of devices, but figuring out which item
> to loadbang in brings you back to your original problem unless you do it
> by name.

That’s why I made my St.Midinport You can specify a part of the name and
it will switch to it on loadbang. [St.Midinport Virus] would be enough
no matter how complicated the real name is…

Stefan


Stefan Tiedje————x——-
–_____———–|————–
–(_|_ —-|—–|—–()——-
– _|_)—-|—–()————–
———-()——–www.ccmix.com


Viewing 7 posts - 1 through 7 (of 7 total)