can't set bpatcher arguments using a message

Sep 8, 2008 at 12:24am

can't set bpatcher arguments using a message

If understand correctly when I need to set the bpatcher arguments attribute I do not have to do this via the inspector but I can send a message starting ‘args’ to the bpatcher. In practice the message appears to do nothing. The bpatcher needs an inlet to receive the message and whatever is attached to the inlet gives me an error message that it doesn’t recognise the message ‘args’. If the inlet is not attached to anything the message still does nothing. Either way, checking the inspector also shows that the arguments haven’t changed. The documentation states on some bpatcher attributes that they can only be set via the inspector but not on ‘arguments’…what am I doing wrong? Try send an ‘args 10 20 30′ message to the bpatcher in ‘interface tutorial 1 bpatcher’ for a demonstration…

Thanks

Don

#39602
Sep 8, 2008 at 1:03pm

Try sending it to your named bpatcher using the thispatcher object. Anything sent to the inlet of a bpatcher is passed through to the inside patcher so if you want to send messages to the bpatcher itself use the thispatcher object.

#139578
Sep 8, 2008 at 11:48pm

Still doesn’t work for me – I get an error ‘patcher – doesn’t understand “args”‘. Could you post a working example demonstrating it?

#139579
Sep 9, 2008 at 5:12am

i’m not so sure it is possible to set bpatchers @args by sending a message via an inlet to the bpatcher, though i’ll look into it. But, you can definitely set @args using thispatcher:

– Pasted Max Patch, click to expand. –
#139580

You must be logged in to reply to this topic.