capture to texture isn`t working anymore on intel mac

Feb 8, 2007 at 5:45am

capture to texture isn`t working anymore on intel mac

Hi,

can anybody confirm this behavior?
on my macbook pro 1.83, max 4.62, jit 1.6 and os 10.4.8
if i want to capture to texture i get only half
width objects and normal height. wtf?

thanks, wk

max v2;
#N vpatcher 512 173 1112 573;
#P window setfont “Sans Serif” 9.;
#P newex 194 175 48 196617 loadbang;
#P message 194 198 51 196617 plane 0.5;
#P newex 26 268 99 196617 jit.gl.videoplane huj;
#P newex 26 237 141 196617 jit.gl.texture huj @name cipa;
#P toggle 43 68 15 0;
#P newex 54 102 51 196617 qmetro 2;
#P newex 95 123 58 196617 t b b erase;
#P newex 86 149 82 196617 jit.gl.render huj;
#P newex 82 345 75 196617 jit.window huj;
#P newex 194 227 147 196617 jit.gl.sketch huj @capture cipa;
#P connect 3 1 6 0;
#P connect 6 0 7 0;
#P connect 5 0 4 0;
#P connect 3 0 2 0;
#P connect 3 2 2 0;
#P connect 4 0 3 0;
#P connect 9 0 8 0;
#P connect 8 0 0 0;
#P pop;

#30184
Feb 8, 2007 at 6:00am

Works here.

use @transform_reset 2 on your videoplane that is rendering the whole
scene. This will make sure that the aspect ratio of your texture
matches that the quad you render on.

#P window setfont “Sans Serif” 9.;
#P window linecount 1;
#P newex 307 143 48 196617 loadbang;
#P message 307 166 51 196617 plane 0.5;
#P newex 124 262 195 196617 jit.gl.videoplane huj @transform_reset 2;
#P newex 124 231 141 196617 jit.gl.texture huj @name cipa;
#P toggle 17 21 15 0;
#P newex 28 55 51 196617 qmetro 2;
#P newex 69 76 58 196617 t b b erase;
#P newex 60 102 82 196617 jit.gl.render huj;
#P newex 56 298 75 196617 jit.window huj;
#P newex 292 221 147 196617 jit.gl.sketch huj @capture cipa;
#P connect 6 0 7 0;
#P connect 8 0 0 0;
#P connect 9 0 8 0;
#P connect 4 0 3 0;
#P connect 3 2 2 0;
#P connect 3 0 2 0;
#P connect 5 0 4 0;
#P connect 3 1 6 0;
#P window clipboard copycount 10;

On Feb 8, 2007, at 12:45 AM, wojciech kosma wrote:

> Hi,
>
> can anybody confirm this behavior?
> on my macbook pro 1.83, max 4.62, jit 1.6 and os 10.4.8
> if i want to capture to texture i get only half
> width objects and normal height. wtf?
>
> thanks, wk
>
> max v2;
> #N vpatcher 512 173 1112 573;
> #P window setfont “Sans Serif” 9.;
> #P newex 194 175 48 196617 loadbang;
> #P message 194 198 51 196617 plane 0.5;
> #P newex 26 268 99 196617 jit.gl.videoplane huj;
> #P newex 26 237 141 196617 jit.gl.texture huj @name cipa;
> #P toggle 43 68 15 0;
> #P newex 54 102 51 196617 qmetro 2;
> #P newex 95 123 58 196617 t b b erase;
> #P newex 86 149 82 196617 jit.gl.render huj;
> #P newex 82 345 75 196617 jit.window huj;
> #P newex 194 227 147 196617 jit.gl.sketch huj @capture cipa;
> #P connect 3 1 6 0;
> #P connect 6 0 7 0;
> #P connect 5 0 4 0;
> #P connect 3 0 2 0;
> #P connect 3 2 2 0;
> #P connect 4 0 3 0;
> #P connect 9 0 8 0;
> #P connect 8 0 0 0;
> #P pop;

v a d e //

http://www.vade.info
abstrakt.vade.info

#95905
Feb 8, 2007 at 6:55am

thanks, but its doesnt help
i`m just moving huge patch to intel mac

and this is definitely not working

although i could make the example patch i`ve send working
with @transform_reset, it doesn`t help for the patch

im doing lots of capturing and slab processing its
bit to complicated make demo patch,
was something changed recently with textures?

wk
On 7 Feb 2007, at 22:00, vade wrote:

> Works here.
>
> use @transform_reset 2 on your videoplane that is rendering the
> whole scene. This will make sure that the aspect ratio of your
> texture matches that the quad you render on.
>
>
>
>
> #P window setfont “Sans Serif” 9.;
> #P window linecount 1;
> #P newex 307 143 48 196617 loadbang;
> #P message 307 166 51 196617 plane 0.5;
> #P newex 124 262 195 196617 jit.gl.videoplane huj @transform_reset 2;
> #P newex 124 231 141 196617 jit.gl.texture huj @name cipa;
> #P toggle 17 21 15 0;
> #P newex 28 55 51 196617 qmetro 2;
> #P newex 69 76 58 196617 t b b erase;
> #P newex 60 102 82 196617 jit.gl.render huj;
> #P newex 56 298 75 196617 jit.window huj;
> #P newex 292 221 147 196617 jit.gl.sketch huj @capture cipa;
> #P connect 6 0 7 0;
> #P connect 8 0 0 0;
> #P connect 9 0 8 0;
> #P connect 4 0 3 0;
> #P connect 3 2 2 0;
> #P connect 3 0 2 0;
> #P connect 5 0 4 0;
> #P connect 3 1 6 0;
> #P window clipboard copycount 10;
>
>
>
> On Feb 8, 2007, at 12:45 AM, wojciech kosma wrote:
>
>> Hi,
>>
>> can anybody confirm this behavior?
>> on my macbook pro 1.83, max 4.62, jit 1.6 and os 10.4.8
>> if i want to capture to texture i get only half
>> width objects and normal height. wtf?
>>
>> thanks, wk
>>
>> max v2;
>> #N vpatcher 512 173 1112 573;
>> #P window setfont “Sans Serif” 9.;
>> #P newex 194 175 48 196617 loadbang;
>> #P message 194 198 51 196617 plane 0.5;
>> #P newex 26 268 99 196617 jit.gl.videoplane huj;
>> #P newex 26 237 141 196617 jit.gl.texture huj @name cipa;
>> #P toggle 43 68 15 0;
>> #P newex 54 102 51 196617 qmetro 2;
>> #P newex 95 123 58 196617 t b b erase;
>> #P newex 86 149 82 196617 jit.gl.render huj;
>> #P newex 82 345 75 196617 jit.window huj;
>> #P newex 194 227 147 196617 jit.gl.sketch huj @capture cipa;
>> #P connect 3 1 6 0;
>> #P connect 6 0 7 0;
>> #P connect 5 0 4 0;
>> #P connect 3 0 2 0;
>> #P connect 3 2 2 0;
>> #P connect 4 0 3 0;
>> #P connect 9 0 8 0;
>> #P connect 8 0 0 0;
>> #P pop;
>
> v a d e //
>
> http://www.vade.info
> abstrakt.vade.info
>
>
>

#95906
Feb 8, 2007 at 7:02am

more tests:
i have 4.5 and 4.6 installed on this machine
top window from this screenshot is 4.5
bottom 4.6
http://theps.net/~media-theps/tex.png
??
can anybody explain this,
wk

On 7 Feb 2007, at 22:00, vade wrote:

> Works here.
>
> use @transform_reset 2 on your videoplane that is rendering the
> whole scene. This will make sure that the aspect ratio of your
> texture matches that the quad you render on.
>
>
>
>
> #P window setfont “Sans Serif” 9.;
> #P window linecount 1;
> #P newex 307 143 48 196617 loadbang;
> #P message 307 166 51 196617 plane 0.5;
> #P newex 124 262 195 196617 jit.gl.videoplane huj @transform_reset 2;
> #P newex 124 231 141 196617 jit.gl.texture huj @name cipa;
> #P toggle 17 21 15 0;
> #P newex 28 55 51 196617 qmetro 2;
> #P newex 69 76 58 196617 t b b erase;
> #P newex 60 102 82 196617 jit.gl.render huj;
> #P newex 56 298 75 196617 jit.window huj;
> #P newex 292 221 147 196617 jit.gl.sketch huj @capture cipa;
> #P connect 6 0 7 0;
> #P connect 8 0 0 0;
> #P connect 9 0 8 0;
> #P connect 4 0 3 0;
> #P connect 3 2 2 0;
> #P connect 3 0 2 0;
> #P connect 5 0 4 0;
> #P connect 3 1 6 0;
> #P window clipboard copycount 10;
>
>
>
> On Feb 8, 2007, at 12:45 AM, wojciech kosma wrote:
>
>> Hi,
>>
>> can anybody confirm this behavior?
>> on my macbook pro 1.83, max 4.62, jit 1.6 and os 10.4.8
>> if i want to capture to texture i get only half
>> width objects and normal height. wtf?
>>
>> thanks, wk
>>
>> max v2;
>> #N vpatcher 512 173 1112 573;
>> #P window setfont “Sans Serif” 9.;
>> #P newex 194 175 48 196617 loadbang;
>> #P message 194 198 51 196617 plane 0.5;
>> #P newex 26 268 99 196617 jit.gl.videoplane huj;
>> #P newex 26 237 141 196617 jit.gl.texture huj @name cipa;
>> #P toggle 43 68 15 0;
>> #P newex 54 102 51 196617 qmetro 2;
>> #P newex 95 123 58 196617 t b b erase;
>> #P newex 86 149 82 196617 jit.gl.render huj;
>> #P newex 82 345 75 196617 jit.window huj;
>> #P newex 194 227 147 196617 jit.gl.sketch huj @capture cipa;
>> #P connect 3 1 6 0;
>> #P connect 6 0 7 0;
>> #P connect 5 0 4 0;
>> #P connect 3 0 2 0;
>> #P connect 3 2 2 0;
>> #P connect 4 0 3 0;
>> #P connect 9 0 8 0;
>> #P connect 8 0 0 0;
>> #P pop;
>
> v a d e //
>
> http://www.vade.info
> abstrakt.vade.info
>
>
>

#95907
Feb 8, 2007 at 7:11am

Set the scale of the video plane such that it has the same aspect
ratio of your window and you will find things to workout.

wes

On 2/7/07, wojciech kosma wrote:
> thanks, but its doesnt help
> i`m just moving huge patch to intel mac

> and this is definitely not working

> although i could make the example patch i`ve send working
> with @transform_reset, it doesn`t help for the patch

> im doing lots of capturing and slab processing its
> bit to complicated make demo patch,
> was something changed recently with textures?
>
> wk
>
> On 7 Feb 2007, at 22:00, vade wrote:
> Works here.
>
> use @transform_reset 2 on your videoplane that is rendering the whole scene.
> This will make sure that the aspect ratio of your texture matches that the
> quad you render on.
>
>
>
>
>
> #P window setfont “Sans Serif” 9.;
> #P window linecount 1;
> #P newex 307 143 48 196617 loadbang;
> #P message 307 166 51 196617 plane 0.5;
> #P newex 124 262 195 196617 jit.gl.videoplane huj @transform_reset 2;
> #P newex 124 231 141 196617 jit.gl.texture huj @name cipa;
> #P toggle 17 21 15 0;
> #P newex 28 55 51 196617 qmetro 2;
> #P newex 69 76 58 196617 t b b erase;
> #P newex 60 102 82 196617 jit.gl.render huj;
> #P newex 56 298 75 196617 jit.window huj;
> #P newex 292 221 147 196617 jit.gl.sketch huj @capture cipa;
> #P connect 6 0 7 0;
> #P connect 8 0 0 0;
> #P connect 9 0 8 0;
> #P connect 4 0 3 0;
> #P connect 3 2 2 0;
> #P connect 3 0 2 0;
> #P connect 5 0 4 0;
> #P connect 3 1 6 0;
> #P window clipboard copycount 10;
>
>
>
>
> On Feb 8, 2007, at 12:45 AM, wojciech kosma wrote:
>
> Hi,
>
> can anybody confirm this behavior?
> on my macbook pro 1.83, max 4.62, jit 1.6 and os 10.4.8
> if i want to capture to texture i get only half
> width objects and normal height. wtf?
>
> thanks, wk
>
> max v2;
> #N vpatcher 512 173 1112 573;
> #P window setfont “Sans Serif” 9.;
> #P newex 194 175 48 196617 loadbang;
> #P message 194 198 51 196617 plane 0.5;
> #P newex 26 268 99 196617 jit.gl.videoplane huj;
> #P newex 26 237 141 196617 jit.gl.texture huj @name cipa;
> #P toggle 43 68 15 0;
> #P newex 54 102 51 196617 qmetro 2;
> #P newex 95 123 58 196617 t b b erase;
> #P newex 86 149 82 196617 jit.gl.render huj;
> #P newex 82 345 75 196617 jit.window huj;
> #P newex 194 227 147 196617 jit.gl.sketch huj @capture cipa;
> #P connect 3 1 6 0;
> #P connect 6 0 7 0;
> #P connect 5 0 4 0;
> #P connect 3 0 2 0;
> #P connect 3 2 2 0;
> #P connect 4 0 3 0;
> #P connect 9 0 8 0;
> #P connect 8 0 0 0;
> #P pop;
>
> v a d e //
>
> http://www.vade.info
> abstrakt.vade.info
>
>
>
>
>
>

#95908
Feb 8, 2007 at 7:13am

There were alot of changes made to texture capture between 4.5 to 4.6.
Frankly, the capture mechanism in 4.5 was broken. Consider the 4.6
version to be fixed. Sorry for any inconvenience this might cause.
Se my previous email for a simple remedy.

wes

On 2/7/07, wojciech kosma wrote:
> more tests:
> i have 4.5 and 4.6 installed on this machine
> top window from this screenshot is 4.5
> bottom 4.6
> http://theps.net/~media-theps/tex.png
> ??
> can anybody explain this,
> wk
>
>
> On 7 Feb 2007, at 22:00, vade wrote:
>
> Works here.
>
> use @transform_reset 2 on your videoplane that is rendering the whole scene.
> This will make sure that the aspect ratio of your texture matches that the
> quad you render on.
>
>
>
>
>
> #P window setfont “Sans Serif” 9.;
> #P window linecount 1;
> #P newex 307 143 48 196617 loadbang;
> #P message 307 166 51 196617 plane 0.5;
> #P newex 124 262 195 196617 jit.gl.videoplane huj @transform_reset 2;
> #P newex 124 231 141 196617 jit.gl.texture huj @name cipa;
> #P toggle 17 21 15 0;
> #P newex 28 55 51 196617 qmetro 2;
> #P newex 69 76 58 196617 t b b erase;
> #P newex 60 102 82 196617 jit.gl.render huj;
> #P newex 56 298 75 196617 jit.window huj;
> #P newex 292 221 147 196617 jit.gl.sketch huj @capture cipa;
> #P connect 6 0 7 0;
> #P connect 8 0 0 0;
> #P connect 9 0 8 0;
> #P connect 4 0 3 0;
> #P connect 3 2 2 0;
> #P connect 3 0 2 0;
> #P connect 5 0 4 0;
> #P connect 3 1 6 0;
> #P window clipboard copycount 10;
>
>
>
>
> On Feb 8, 2007, at 12:45 AM, wojciech kosma wrote:
>
> Hi,
>
> can anybody confirm this behavior?
> on my macbook pro 1.83, max 4.62, jit 1.6 and os 10.4.8
> if i want to capture to texture i get only half
> width objects and normal height. wtf?
>
> thanks, wk
>
> max v2;
> #N vpatcher 512 173 1112 573;
> #P window setfont “Sans Serif” 9.;
> #P newex 194 175 48 196617 loadbang;
> #P message 194 198 51 196617 plane 0.5;
> #P newex 26 268 99 196617 jit.gl.videoplane huj;
> #P newex 26 237 141 196617 jit.gl.texture huj @name cipa;
> #P toggle 43 68 15 0;
> #P newex 54 102 51 196617 qmetro 2;
> #P newex 95 123 58 196617 t b b erase;
> #P newex 86 149 82 196617 jit.gl.render huj;
> #P newex 82 345 75 196617 jit.window huj;
> #P newex 194 227 147 196617 jit.gl.sketch huj @capture cipa;
> #P connect 3 1 6 0;
> #P connect 6 0 7 0;
> #P connect 5 0 4 0;
> #P connect 3 0 2 0;
> #P connect 3 2 2 0;
> #P connect 4 0 3 0;
> #P connect 9 0 8 0;
> #P connect 8 0 0 0;
> #P pop;
>
> v a d e //
>
> http://www.vade.info
> abstrakt.vade.info
>
>
>
>
>
>

#95909
Feb 8, 2007 at 7:14am

BTW. You could also set jit.gl.sketch @scale 1.333 1 1 and things
would be good there too.

wes

On 2/7/07, Wesley Smith wrote:
> There were alot of changes made to texture capture between 4.5 to 4.6.
> Frankly, the capture mechanism in 4.5 was broken. Consider the 4.6
> version to be fixed. Sorry for any inconvenience this might cause.
> Se my previous email for a simple remedy.
>
> wes
>
> On 2/7/07, wojciech kosma wrote:
> > more tests:
> > i have 4.5 and 4.6 installed on this machine
> > top window from this screenshot is 4.5
> > bottom 4.6
> > http://theps.net/~media-theps/tex.png
> > ??
> > can anybody explain this,
> > wk
> >
> >
> > On 7 Feb 2007, at 22:00, vade wrote:
> >
> > Works here.
> >
> > use @transform_reset 2 on your videoplane that is rendering the whole scene.
> > This will make sure that the aspect ratio of your texture matches that the
> > quad you render on.
> >
> >
> >
> >
> >
> > #P window setfont “Sans Serif” 9.;
> > #P window linecount 1;
> > #P newex 307 143 48 196617 loadbang;
> > #P message 307 166 51 196617 plane 0.5;
> > #P newex 124 262 195 196617 jit.gl.videoplane huj @transform_reset 2;
> > #P newex 124 231 141 196617 jit.gl.texture huj @name cipa;
> > #P toggle 17 21 15 0;
> > #P newex 28 55 51 196617 qmetro 2;
> > #P newex 69 76 58 196617 t b b erase;
> > #P newex 60 102 82 196617 jit.gl.render huj;
> > #P newex 56 298 75 196617 jit.window huj;
> > #P newex 292 221 147 196617 jit.gl.sketch huj @capture cipa;
> > #P connect 6 0 7 0;
> > #P connect 8 0 0 0;
> > #P connect 9 0 8 0;
> > #P connect 4 0 3 0;
> > #P connect 3 2 2 0;
> > #P connect 3 0 2 0;
> > #P connect 5 0 4 0;
> > #P connect 3 1 6 0;
> > #P window clipboard copycount 10;
> >
> >
> >
> >
> > On Feb 8, 2007, at 12:45 AM, wojciech kosma wrote:
> >
> > Hi,
> >
> > can anybody confirm this behavior?
> > on my macbook pro 1.83, max 4.62, jit 1.6 and os 10.4.8
> > if i want to capture to texture i get only half
> > width objects and normal height. wtf?
> >
> > thanks, wk
> >
> > max v2;
> > #N vpatcher 512 173 1112 573;
> > #P window setfont “Sans Serif” 9.;
> > #P newex 194 175 48 196617 loadbang;
> > #P message 194 198 51 196617 plane 0.5;
> > #P newex 26 268 99 196617 jit.gl.videoplane huj;
> > #P newex 26 237 141 196617 jit.gl.texture huj @name cipa;
> > #P toggle 43 68 15 0;
> > #P newex 54 102 51 196617 qmetro 2;
> > #P newex 95 123 58 196617 t b b erase;
> > #P newex 86 149 82 196617 jit.gl.render huj;
> > #P newex 82 345 75 196617 jit.window huj;
> > #P newex 194 227 147 196617 jit.gl.sketch huj @capture cipa;
> > #P connect 3 1 6 0;
> > #P connect 6 0 7 0;
> > #P connect 5 0 4 0;
> > #P connect 3 0 2 0;
> > #P connect 3 2 2 0;
> > #P connect 4 0 3 0;
> > #P connect 9 0 8 0;
> > #P connect 8 0 0 0;
> > #P pop;
> >
> > v a d e //
> >
> > http://www.vade.info
> > abstrakt.vade.info
> >
> >
> >
> >
> >
> >
>

#95910
Feb 8, 2007 at 7:59am

what about this?

max v2;
#N vpatcher 582 287 1404 808;
#P window setfont “Sans Serif” 9.;
#P window linecount 1;
#P message 350 230 42 196617 scale 1;
#P message 136 307 42 196617 scale 1;
#P message 314 257 66 196617 scale 1.33 1;
#P newex 294 33 48 196617 loadbang;
#P newex 191 217 147 196617 jit.gl.sketch huj @capture cipa;
#P message 120 331 81 196617 scale 1.11 0.83;
#P message 286 320 288 196617 reset , glcolor 0 1 0 1 , point_size
20 , drawmatrix was points;
#P newex 292 348 145 196617 jit.gl.sketch huj @automatic 0;
#P window linecount 2;
#P message 294 56 279 196617 setcell 0 0 val -0.5 0.5 0 , setcell 1
0 val 0.5 0.5 0 , setcell 2 0 val 0.5 -0.5 0 , setcell 3 0 val -0.5
-0.5 0 , bang;
#P window linecount 1;
#P newex 299 135 130 196617 jit.matrix was 3 float32 4;
#P newex 194 175 48 196617 loadbang;
#P message 194 198 288 196617 reset , glcolor 1 0 0 1 , point_size
20 , drawmatrix was points;
#P newex 26 237 141 196617 jit.gl.texture huj @name cipa;
#P toggle 43 68 15 0;
#P newex 54 102 51 196617 qmetro 2;
#P newex 95 123 74 196617 t b b b b erase;
#P newex 86 159 82 196617 jit.gl.render huj;
#P newex 48 387 75 196617 jit.window huj;
#P newex 26 277 163 196617 jit.gl.videoplane huj @automatic 0;
#P connect 3 2 6 0;
#P connect 17 0 0 0;
#P connect 3 3 0 0;
#P connect 6 0 0 0;
#P connect 13 0 0 0;
#P connect 5 0 4 0;
#P connect 3 0 2 0;
#P connect 3 4 2 0;
#P connect 4 0 3 0;
#P connect 18 0 14 0;
#P connect 16 0 14 0;
#P connect 7 0 14 0;
#P connect 8 0 7 0;
#P connect 8 0 12 0;
#P connect 12 0 11 0;
#P connect 3 1 11 0;
#P connect 15 0 10 0;
#P connect 10 0 9 0;
#P pop;

On 7 Feb 2007, at 23:14, Wesley Smith wrote:

> BTW. You could also set jit.gl.sketch @scale 1.333 1 1 and things
> would be good there too.
>
> wes
>
> On 2/7/07, Wesley Smith wrote:
>> There were alot of changes made to texture capture between 4.5 to
>> 4.6.
>> Frankly, the capture mechanism in 4.5 was broken. Consider the 4.6
>> version to be fixed. Sorry for any inconvenience this might cause.
>> Se my previous email for a simple remedy.
>>
>> wes
>>
>> On 2/7/07, wojciech kosma wrote:
>> > more tests:
>> > i have 4.5 and 4.6 installed on this machine
>> > top window from this screenshot is 4.5
>> > bottom 4.6
>> > http://theps.net/~media-theps/tex.png
>> > ??
>> > can anybody explain this,
>> > wk
>> >
>> >
>> > On 7 Feb 2007, at 22:00, vade wrote:
>> >
>> > Works here.
>> >
>> > use @transform_reset 2 on your videoplane that is rendering the
>> whole scene.
>> > This will make sure that the aspect ratio of your texture
>> matches that the
>> > quad you render on.
>> >
>> >
>> >
>> >
>> >
>> > #P window setfont “Sans Serif” 9.;
>> > #P window linecount 1;
>> > #P newex 307 143 48 196617 loadbang;
>> > #P message 307 166 51 196617 plane 0.5;
>> > #P newex 124 262 195 196617 jit.gl.videoplane huj
>> @transform_reset 2;
>> > #P newex 124 231 141 196617 jit.gl.texture huj @name cipa;
>> > #P toggle 17 21 15 0;
>> > #P newex 28 55 51 196617 qmetro 2;
>> > #P newex 69 76 58 196617 t b b erase;
>> > #P newex 60 102 82 196617 jit.gl.render huj;
>> > #P newex 56 298 75 196617 jit.window huj;
>> > #P newex 292 221 147 196617 jit.gl.sketch huj @capture cipa;
>> > #P connect 6 0 7 0;
>> > #P connect 8 0 0 0;
>> > #P connect 9 0 8 0;
>> > #P connect 4 0 3 0;
>> > #P connect 3 2 2 0;
>> > #P connect 3 0 2 0;
>> > #P connect 5 0 4 0;
>> > #P connect 3 1 6 0;
>> > #P window clipboard copycount 10;
>> >
>> >
>> >
>> >
>> > On Feb 8, 2007, at 12:45 AM, wojciech kosma wrote:
>> >
>> > Hi,
>> >
>> > can anybody confirm this behavior?
>> > on my macbook pro 1.83, max 4.62, jit 1.6 and os 10.4.8
>> > if i want to capture to texture i get only half
>> > width objects and normal height. wtf?
>> >
>> > thanks, wk
>> >
>> > max v2;
>> > #N vpatcher 512 173 1112 573;
>> > #P window setfont “Sans Serif” 9.;
>> > #P newex 194 175 48 196617 loadbang;
>> > #P message 194 198 51 196617 plane 0.5;
>> > #P newex 26 268 99 196617 jit.gl.videoplane huj;
>> > #P newex 26 237 141 196617 jit.gl.texture huj @name cipa;
>> > #P toggle 43 68 15 0;
>> > #P newex 54 102 51 196617 qmetro 2;
>> > #P newex 95 123 58 196617 t b b erase;
>> > #P newex 86 149 82 196617 jit.gl.render huj;
>> > #P newex 82 345 75 196617 jit.window huj;
>> > #P newex 194 227 147 196617 jit.gl.sketch huj @capture cipa;
>> > #P connect 3 1 6 0;
>> > #P connect 6 0 7 0;
>> > #P connect 5 0 4 0;
>> > #P connect 3 0 2 0;
>> > #P connect 3 2 2 0;
>> > #P connect 4 0 3 0;
>> > #P connect 9 0 8 0;
>> > #P connect 8 0 0 0;
>> > #P pop;
>> >
>> > v a d e //
>> >
>> > http://www.vade.info
>> > abstrakt.vade.info
>> >
>> >
>> >
>> >
>> >
>> >
>>

#95911
Feb 8, 2007 at 8:06am

besides, i get plenty of:
jit.gl.texture: setting subteximage during submission.: GL Error:
Invalid operation
when switching from one texture to another,
sometimes things would get so f**ked that only restart can help

wk
On 7 Feb 2007, at 23:14, Wesley Smith wrote:

> BTW. You could also set jit.gl.sketch @scale 1.333 1 1 and things
> would be good there too.
>
> wes
>
> On 2/7/07, Wesley Smith wrote:
>> There were alot of changes made to texture capture between 4.5 to
>> 4.6.
>> Frankly, the capture mechanism in 4.5 was broken. Consider the 4.6
>> version to be fixed. Sorry for any inconvenience this might cause.
>> Se my previous email for a simple remedy.
>>
>> wes
>>
>> On 2/7/07, wojciech kosma wrote:
>> > more tests:
>> > i have 4.5 and 4.6 installed on this machine
>> > top window from this screenshot is 4.5
>> > bottom 4.6
>> > http://theps.net/~media-theps/tex.png
>> > ??
>> > can anybody explain this,
>> > wk
>> >
>> >
>> > On 7 Feb 2007, at 22:00, vade wrote:
>> >
>> > Works here.
>> >
>> > use @transform_reset 2 on your videoplane that is rendering the
>> whole scene.
>> > This will make sure that the aspect ratio of your texture
>> matches that the
>> > quad you render on.
>> >
>> >
>> >
>> >
>> >
>> > #P window setfont “Sans Serif” 9.;
>> > #P window linecount 1;
>> > #P newex 307 143 48 196617 loadbang;
>> > #P message 307 166 51 196617 plane 0.5;
>> > #P newex 124 262 195 196617 jit.gl.videoplane huj
>> @transform_reset 2;
>> > #P newex 124 231 141 196617 jit.gl.texture huj @name cipa;
>> > #P toggle 17 21 15 0;
>> > #P newex 28 55 51 196617 qmetro 2;
>> > #P newex 69 76 58 196617 t b b erase;
>> > #P newex 60 102 82 196617 jit.gl.render huj;
>> > #P newex 56 298 75 196617 jit.window huj;
>> > #P newex 292 221 147 196617 jit.gl.sketch huj @capture cipa;
>> > #P connect 6 0 7 0;
>> > #P connect 8 0 0 0;
>> > #P connect 9 0 8 0;
>> > #P connect 4 0 3 0;
>> > #P connect 3 2 2 0;
>> > #P connect 3 0 2 0;
>> > #P connect 5 0 4 0;
>> > #P connect 3 1 6 0;
>> > #P window clipboard copycount 10;
>> >
>> >
>> >
>> >
>> > On Feb 8, 2007, at 12:45 AM, wojciech kosma wrote:
>> >
>> > Hi,
>> >
>> > can anybody confirm this behavior?
>> > on my macbook pro 1.83, max 4.62, jit 1.6 and os 10.4.8
>> > if i want to capture to texture i get only half
>> > width objects and normal height. wtf?
>> >
>> > thanks, wk
>> >
>> > max v2;
>> > #N vpatcher 512 173 1112 573;
>> > #P window setfont “Sans Serif” 9.;
>> > #P newex 194 175 48 196617 loadbang;
>> > #P message 194 198 51 196617 plane 0.5;
>> > #P newex 26 268 99 196617 jit.gl.videoplane huj;
>> > #P newex 26 237 141 196617 jit.gl.texture huj @name cipa;
>> > #P toggle 43 68 15 0;
>> > #P newex 54 102 51 196617 qmetro 2;
>> > #P newex 95 123 58 196617 t b b erase;
>> > #P newex 86 149 82 196617 jit.gl.render huj;
>> > #P newex 82 345 75 196617 jit.window huj;
>> > #P newex 194 227 147 196617 jit.gl.sketch huj @capture cipa;
>> > #P connect 3 1 6 0;
>> > #P connect 6 0 7 0;
>> > #P connect 5 0 4 0;
>> > #P connect 3 0 2 0;
>> > #P connect 3 2 2 0;
>> > #P connect 4 0 3 0;
>> > #P connect 9 0 8 0;
>> > #P connect 8 0 0 0;
>> > #P pop;
>> >
>> > v a d e //
>> >
>> > http://www.vade.info
>> > abstrakt.vade.info
>> >
>> >
>> >
>> >
>> >
>> >
>>

#95912
Feb 8, 2007 at 9:34am

What about it?

wes

On 2/7/07, wojciech kosma wrote:
> what about this?
>
> max v2;
> #N vpatcher 582 287 1404 808;
> #P window setfont “Sans Serif” 9.;
> #P window linecount 1;
> #P message 350 230 42 196617 scale 1;
> #P message 136 307 42 196617 scale 1;
> #P message 314 257 66 196617 scale 1.33 1;
> #P newex 294 33 48 196617 loadbang;
> #P newex 191 217 147 196617 jit.gl.sketch huj @capture cipa;
> #P message 120 331 81 196617 scale 1.11 0.83;
> #P message 286 320 288 196617 reset , glcolor 0 1 0 1 , point_size 20 ,
> drawmatrix was points;
> #P newex 292 348 145 196617 jit.gl.sketch huj @automatic 0;
> #P window linecount 2;
> #P message 294 56 279 196617 setcell 0 0 val -0.5 0.5 0 , setcell 1 0 val
> 0.5 0.5 0 , setcell 2 0 val 0.5 -0.5 0 , setcell 3 0 val -0.5 -0.5 0 ,
> bang;
> #P window linecount 1;
> #P newex 299 135 130 196617 jit.matrix was 3 float32 4;
> #P newex 194 175 48 196617 loadbang;
> #P message 194 198 288 196617 reset , glcolor 1 0 0 1 , point_size 20 ,
> drawmatrix was points;
> #P newex 26 237 141 196617 jit.gl.texture huj @name cipa;
> #P toggle 43 68 15 0;
> #P newex 54 102 51 196617 qmetro 2;
> #P newex 95 123 74 196617 t b b b b erase;
> #P newex 86 159 82 196617 jit.gl.render huj;
> #P newex 48 387 75 196617 jit.window huj;
> #P newex 26 277 163 196617 jit.gl.videoplane huj @automatic 0;
> #P connect 3 2 6 0;
> #P connect 17 0 0 0;
> #P connect 3 3 0 0;
> #P connect 6 0 0 0;
> #P connect 13 0 0 0;
> #P connect 5 0 4 0;
> #P connect 3 0 2 0;
> #P connect 3 4 2 0;
> #P connect 4 0 3 0;
> #P connect 18 0 14 0;
> #P connect 16 0 14 0;
> #P connect 7 0 14 0;
> #P connect 8 0 7 0;
> #P connect 8 0 12 0;
> #P connect 12 0 11 0;
> #P connect 3 1 11 0;
> #P connect 15 0 10 0;
> #P connect 10 0 9 0;
> #P pop;
>
>
> On 7 Feb 2007, at 23:14, Wesley Smith wrote:
>
> BTW.� You could also set jit.gl.sketch @scale 1.333 1 1 and things
> would be good there too.
>
> wes
>
> On 2/7/07, Wesley Smith wrote:
> There were alot of changes made to texture capture between 4.5 to 4.6.
> �Frankly, the capture mechanism in 4.5 was broken.� Consider the 4.6
> version to be fixed.� Sorry for any inconvenience this might cause.
> Se my previous email for a simple remedy.
>
> wes
>
> On 2/7/07, wojciech kosma wrote:
> > more tests:
> > i have 4.5 and 4.6 installed on this machine
> > top window from this screenshot is 4.5
> > bottom 4.6
> > http://theps.net/~media-theps/tex.png
> > ??
> > can anybody explain this,
> > wk
> >
> >
> > On 7 Feb 2007, at 22:00, vade wrote:
> >
> > Works here.
> >
> > use @transform_reset 2 on your videoplane that is rendering the whole
> scene.
> > This will make sure that the aspect ratio of your texture matches that the
> > quad you render on.
> >
> >
> >
> >
> >
> > #P window setfont “Sans Serif” 9.;
> > #P window linecount 1;
> > #P newex 307 143 48 196617 loadbang;
> > #P message 307 166 51 196617 plane 0.5;
> > #P newex 124 262 195 196617 jit.gl.videoplane huj @transform_reset 2;
> > #P newex 124 231 141 196617 jit.gl.texture huj @name cipa;
> > #P toggle 17 21 15 0;
> > #P newex 28 55 51 196617 qmetro 2;
> > #P newex 69 76 58 196617 t b b erase;
> > #P newex 60 102 82 196617 jit.gl.render huj;
> > #P newex 56 298 75 196617 jit.window huj;
> > #P newex 292 221 147 196617 jit.gl.sketch huj @capture cipa;
> > #P connect 6 0 7 0;
> > #P connect 8 0 0 0;
> > #P connect 9 0 8 0;
> > #P connect 4 0 3 0;
> > #P connect 3 2 2 0;
> > #P connect 3 0 2 0;
> > #P connect 5 0 4 0;
> > #P connect 3 1 6 0;
> > #P window clipboard copycount 10;
> >
> >
> >
> >
> > On Feb 8, 2007, at 12:45 AM, wojciech kosma wrote:
> >
> > Hi,
> >
> > can anybody confirm this behavior?
> > on my macbook pro 1.83, max 4.62, jit 1.6 and os 10.4.8
> > if i want to capture to texture i get only half
> > width objects and normal height. wtf?
> >
> > thanks, wk
> >
> > max v2;
> > #N vpatcher 512 173 1112 573;
> > #P window setfont “Sans Serif” 9.;
> > #P newex 194 175 48 196617 loadbang;
> > #P message 194 198 51 196617 plane 0.5;
> > #P newex 26 268 99 196617 jit.gl.videoplane huj;
> > #P newex 26 237 141 196617 jit.gl.texture huj @name cipa;
> > #P toggle 43 68 15 0;
> > #P newex 54 102 51 196617 qmetro 2;
> > #P newex 95 123 58 196617 t b b erase;
> > #P newex 86 149 82 196617 jit.gl.render huj;
> > #P newex 82 345 75 196617 jit.window huj;
> > #P newex 194 227 147 196617 jit.gl.sketch huj @capture cipa;
> > #P connect 3 1 6 0;
> > #P connect 6 0 7 0;
> > #P connect 5 0 4 0;
> > #P connect 3 0 2 0;
> > #P connect 3 2 2 0;
> > #P connect 4 0 3 0;
> > #P connect 9 0 8 0;
> > #P connect 8 0 0 0;
> > #P pop;
> >
> > v a d e //
> >
> > http://www.vade.info
> > abstrakt.vade.info
> >
> >
> >
> >
> >
> >
>
>
>
>
>

#95913
Feb 8, 2007 at 9:35am

I believe this is the same bug as was recently reported in another
thread and has been addressed. Do you have a patch that shows this
problem? I can’t past F*cked into a max patch and get anything
useful.

wes

On 2/8/07, wojciech kosma wrote:
> besides, i get plenty of:
> jit.gl.texture: setting subteximage during submission.: GL Error:
> Invalid operation
> when switching from one texture to another,
> sometimes things would get so f**ked that only restart can help
>
> wk
> On 7 Feb 2007, at 23:14, Wesley Smith wrote:
>
> > BTW. You could also set jit.gl.sketch @scale 1.333 1 1 and things
> > would be good there too.
> >
> > wes
> >
> > On 2/7/07, Wesley Smith wrote:
> >> There were alot of changes made to texture capture between 4.5 to
> >> 4.6.
> >> Frankly, the capture mechanism in 4.5 was broken. Consider the 4.6
> >> version to be fixed. Sorry for any inconvenience this might cause.
> >> Se my previous email for a simple remedy.
> >>
> >> wes
> >>
> >> On 2/7/07, wojciech kosma wrote:
> >> > more tests:
> >> > i have 4.5 and 4.6 installed on this machine
> >> > top window from this screenshot is 4.5
> >> > bottom 4.6
> >> > http://theps.net/~media-theps/tex.png
> >> > ??
> >> > can anybody explain this,
> >> > wk
> >> >
> >> >
> >> > On 7 Feb 2007, at 22:00, vade wrote:
> >> >
> >> > Works here.
> >> >
> >> > use @transform_reset 2 on your videoplane that is rendering the
> >> whole scene.
> >> > This will make sure that the aspect ratio of your texture
> >> matches that the
> >> > quad you render on.
> >> >
> >> >
> >> >
> >> >
> >> >
> >> > #P window setfont “Sans Serif” 9.;
> >> > #P window linecount 1;
> >> > #P newex 307 143 48 196617 loadbang;
> >> > #P message 307 166 51 196617 plane 0.5;
> >> > #P newex 124 262 195 196617 jit.gl.videoplane huj
> >> @transform_reset 2;
> >> > #P newex 124 231 141 196617 jit.gl.texture huj @name cipa;
> >> > #P toggle 17 21 15 0;
> >> > #P newex 28 55 51 196617 qmetro 2;
> >> > #P newex 69 76 58 196617 t b b erase;
> >> > #P newex 60 102 82 196617 jit.gl.render huj;
> >> > #P newex 56 298 75 196617 jit.window huj;
> >> > #P newex 292 221 147 196617 jit.gl.sketch huj @capture cipa;
> >> > #P connect 6 0 7 0;
> >> > #P connect 8 0 0 0;
> >> > #P connect 9 0 8 0;
> >> > #P connect 4 0 3 0;
> >> > #P connect 3 2 2 0;
> >> > #P connect 3 0 2 0;
> >> > #P connect 5 0 4 0;
> >> > #P connect 3 1 6 0;
> >> > #P window clipboard copycount 10;
> >> >
> >> >
> >> >
> >> >
> >> > On Feb 8, 2007, at 12:45 AM, wojciech kosma wrote:
> >> >
> >> > Hi,
> >> >
> >> > can anybody confirm this behavior?
> >> > on my macbook pro 1.83, max 4.62, jit 1.6 and os 10.4.8
> >> > if i want to capture to texture i get only half
> >> > width objects and normal height. wtf?
> >> >
> >> > thanks, wk
> >> >
> >> > max v2;
> >> > #N vpatcher 512 173 1112 573;
> >> > #P window setfont “Sans Serif” 9.;
> >> > #P newex 194 175 48 196617 loadbang;
> >> > #P message 194 198 51 196617 plane 0.5;
> >> > #P newex 26 268 99 196617 jit.gl.videoplane huj;
> >> > #P newex 26 237 141 196617 jit.gl.texture huj @name cipa;
> >> > #P toggle 43 68 15 0;
> >> > #P newex 54 102 51 196617 qmetro 2;
> >> > #P newex 95 123 58 196617 t b b erase;
> >> > #P newex 86 149 82 196617 jit.gl.render huj;
> >> > #P newex 82 345 75 196617 jit.window huj;
> >> > #P newex 194 227 147 196617 jit.gl.sketch huj @capture cipa;
> >> > #P connect 3 1 6 0;
> >> > #P connect 6 0 7 0;
> >> > #P connect 5 0 4 0;
> >> > #P connect 3 0 2 0;
> >> > #P connect 3 2 2 0;
> >> > #P connect 4 0 3 0;
> >> > #P connect 9 0 8 0;
> >> > #P connect 8 0 0 0;
> >> > #P pop;
> >> >
> >> > v a d e //
> >> >
> >> > http://www.vade.info
> >> > abstrakt.vade.info
> >> >
> >> >
> >> >
> >> >
> >> >
> >> >
> >>
>
>

#95914
Feb 8, 2007 at 10:10am

Just to make my point clear that there is nothing wrong with the
capture stuff although it is different from 4.5 since 4.5 was
*broken*, here’s your patch wither the captured and rendered geometry
matching perfrectly.

#P window setfont “Sans Serif” 9.;
#P window linecount 1;
#P message 79 213 42 196617 scale 1;
#P message 11 213 66 196617 scale 1.33 1;
#P newex 181 74 48 196617 loadbang;
#P newex 437 250 268 196617 jit.gl.sketch huj @capture cipa
@blend_enable 1 @layer 0;
#P message 136 213 297 196617 reset , glcolor 0 1 0 0.5 , point_size
20 , drawmatrix was points;
#P newex 136 250 280 196617 jit.gl.sketch huj @layer 1 @blend_enable 1
@depth_enable 0;
#P window linecount 2;
#P message 181 97 279 196617 setcell 0 0 val -0.5 0.5 0 , setcell 1 0
val 0.5 0.5 0 , setcell 2 0 val 0.5 -0.5 0 , setcell 3 0 val -0.5
-0.5 0 , bang;
#P window linecount 1;
#P newex 181 131 130 196617 jit.matrix was 3 float32 4;
#P newex 232 170 48 196617 loadbang;
#P message 437 213 297 196617 reset , glcolor 1 0 0 0.5 , point_size
20 , drawmatrix was points;
#P newex 11 312 210 196617 jit.gl.texture huj @name cipa @dim 320 240;
#P toggle 24 46 15 0;
#P newex 24 68 51 196617 qmetro 2;
#P newex 24 90 82 196617 jit.gl.render huj;
#P newex 24 117 75 196617 jit.window huj;
#P window linecount 2;
#P newex 11 334 237 196617 jit.gl.videoplane huj @layer 3
@transform_reset 2 @blend_enable 1 @depth_enable 0 @texture cipa;
#P fasten 15 0 10 0 84 241 141 241;
#P fasten 15 0 12 0 84 241 442 241;
#P fasten 14 0 10 0 16 241 141 241;
#P fasten 14 0 12 0 16 241 442 241;
#P fasten 7 0 11 0 237 202 141 202;
#P fasten 7 0 6 0 237 202 442 202;
#P connect 11 0 10 0;
#P connect 6 0 12 0;
#P connect 3 0 2 0;
#P connect 9 0 8 0;
#P connect 13 0 9 0;
#P connect 4 0 3 0;
#P window clipboard copycount 16;

#95915
Feb 8, 2007 at 5:04pm

It’s not clear from any of your emails:
–What version of Jitter are you using?
–What video hardware?

Talking about the difference between MaxMSP 4.5 and 4.6 is not very
relevant when you are discussing a problem with Jitter functionality.

You might consider downloading and installing the public beta of Jitter
1.6.3, as many bugs related to textures and capturing have been fixed
since the initial 1.6 release.

In the future, please post questions about Jitter to the Jitter forum/list.

Cheers,
Andrew B.

#95916
Feb 9, 2007 at 12:21am

thanks, i`ll try solution from wes,
>
> You might consider downloading and installing the public beta of
> Jitter 1.6.3, as many bugs related to textures and capturing have
> been fixed since the initial 1.6 release.

ok, where do i find it?

wk

#95917
Feb 9, 2007 at 12:30am

OS X Universal Binary:

http://www.cycling74.com/download/jitter163b2.dmg

Windows XP:

http://www.cycling74.com/download/jitter163b2.zip

wes

On 2/8/07, wojciech kosma wrote:
> thanks, i`ll try solution from wes,
> >
> > You might consider downloading and installing the public beta of
> > Jitter 1.6.3, as many bugs related to textures and capturing have
> > been fixed since the initial 1.6 release.
>
> ok, where do i find it?
>
> wk
>
>
>

#95918
Feb 9, 2007 at 1:26am

thanks wes,

ive tracked it down - im using matrox triplehead2go
means i`m rendering to 3072×768 window,

after changing dim attr in texture to corresponding ratio

it works, sorry for multiple stupid emails, but

personally i`m finding this very confusing,

best,
wojciech
On 8 Feb 2007, at 16:30, Wesley Smith wrote:

> OS X Universal Binary:
> http://www.cycling74.com/download/jitter163b2.dmg
>
> Windows XP:
> http://www.cycling74.com/download/jitter163b2.zip
>
>
> wes
>
> On 2/8/07, wojciech kosma wrote:
>> thanks, i`ll try solution from wes,
>> >
>> > You might consider downloading and installing the public beta of
>> > Jitter 1.6.3, as many bugs related to textures and capturing have
>> > been fixed since the initial 1.6 release.
>>
>> ok, where do i find it?
>>
>> wk
>>
>>
>>

#95919
Feb 9, 2007 at 2:39am

No problem. I find it confusing sometimes as well. There’s alot to
keep track of.

wes

On 2/8/07, wojciech kosma wrote:
> thanks wes,
>
> ive tracked it down - im using matrox triplehead2go
> means i`m rendering to 3072×768 window,

> after changing dim attr in texture to corresponding ratio

> it works, sorry for multiple stupid emails, but

> personally i`m finding this very confusing,
>
> best,
> wojciech
> On 8 Feb 2007, at 16:30, Wesley Smith wrote:
>
> > OS X Universal Binary:
> > http://www.cycling74.com/download/jitter163b2.dmg
> >
> > Windows XP:
> > http://www.cycling74.com/download/jitter163b2.zip
> >
> >
> > wes
> >
> > On 2/8/07, wojciech kosma wrote:
> >> thanks, i`ll try solution from wes,
> >> >
> >> > You might consider downloading and installing the public beta of
> >> > Jitter 1.6.3, as many bugs related to textures and capturing have
> >> > been fixed since the initial 1.6 release.
> >>
> >> ok, where do i find it?
> >>
> >> wk
> >>
> >>
> >>
>
>

#95920

You must be logged in to reply to this topic.