Forums > Jitter

capturing video to disk (bad quality!)

September 7, 2006 | 12:32 am

Hi!

I?m trying to capture Video from a DVPAL-Cam via Firewire.

My jit.qt.grab object has this attributes:

jit.qt.grab 720 576 @codecquality 5 @standard pal @vmode 2

I can watch the video in a jit.pwindow.
with vmode 2 i get the best quality.

A strange thing is happening if I send a write message to the jit.qt.grab object (attributes: /Users/spierala/Desktop/clip.mov 25 jpeg lossless).
Suddenly the quality is becoming worse. It looks like vmode 0 or 1 qualtity.
I have to open the grabber component again to get the vmode 2 quality again.

I can only capture in good quality with the jit.qt.record object. But I don?t have enough performance for realtime recording at a framerate of 25fps. So send a write message to jit.qt.grab should be the perfect solution. But does somebody know how to get the maximum of quality out of it?

thanx for any advice!
cheers flo


September 7, 2006 | 7:39 am

Sounds like there may be 2 things happening here. There was a bug
fixed this past week (will be in the next update) that was causing
codec and quality to be ignored when writing files to disk. However,
this quality-reset issue is something I will have to look at and get
back to you on. Sounds like it might be a bug, but until I see it for
myself, I can’t say.

jb

Am 07.09.2006 um 02:32 schrieb flo spier:

> I can watch the video in a jit.pwindow.
> with vmode 2 i get the best quality.
>
> A strange thing is happening if I send a write message to the
> jit.qt.grab object (attributes: /Users/spierala/Desktop/clip.mov 25
> jpeg lossless).
> Suddenly the quality is becoming worse. It looks like vmode 0 or 1
> qualtity.
> I have to open the grabber component again to get the vmode 2
> quality again.
>
> I can only capture in good quality with the jit.qt.record object.
> But I don?t have enough performance for realtime recording at a
> framerate of 25fps. So send a write message to jit.qt.grab should
> be the perfect solution. But does somebody know how to get the
> maximum of quality out of it?


September 7, 2006 | 11:33 am

I was able to reproduce and repair this behavior for the next
release. Thanks for the report.

jb

Am 07.09.2006 um 02:32 schrieb flo spier:

> Suddenly the quality is becoming worse. It looks like vmode 0 or 1
> qualtity.
> I have to open the grabber component again to get the vmode 2
> quality again.


Viewing 3 posts - 1 through 3 (of 3 total)